summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-02-12 10:23:21 +0000
committerThilo Bangert <bangert@gentoo.org>2010-02-12 10:23:21 +0000
commita18eb13a840d794a4a7af73823e65c5981ed4885 (patch)
tree9a338acb87236a57b5251d5f8c8d34151f4ba28d /www-servers
parentadd /dev/ttyACM type devices to list of know serial ports (#301126) (diff)
downloadgentoo-2-a18eb13a840d794a4a7af73823e65c5981ed4885.tar.gz
gentoo-2-a18eb13a840d794a4a7af73823e65c5981ed4885.tar.bz2
gentoo-2-a18eb13a840d794a4a7af73823e65c5981ed4885.zip
version bump
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog9
-rw-r--r--www-servers/pound/pound-2.5.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index d96955121de1..0f7cb0c50f3e 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.42 2009/10/14 08:23:53 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.43 2010/02/12 10:23:21 bangert Exp $
+
+*pound-2.5 (12 Feb 2010)
+
+ 12 Feb 2010; Thilo Bangert <bangert@gentoo.org> +pound-2.5.ebuild:
+ version bump
*pound-2.4.5-r1 (14 Oct 2009)
diff --git a/www-servers/pound/pound-2.5.ebuild b/www-servers/pound/pound-2.5.ebuild
new file mode 100644
index 000000000000..d00b381fec9b
--- /dev/null
+++ b/www-servers/pound/pound-2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.5.ebuild,v 1.1 2010/02/12 10:23:21 bangert Exp $
+
+EAPI="2"
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="dynscaler"
+
+DEPEND="dev-libs/libpcre
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ $(use_enable dynscaler) \
+ || die "configure failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}