summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-05-30 23:36:32 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-05-30 23:36:32 +0000
commit8d2f35e087a23c7cf439fbdf6bbd642401934184 (patch)
treeb1c46a5e0ce921054ce15b9cfa9d9152c6a03bbb /www-servers
parentVersion bump. (diff)
downloadgentoo-2-8d2f35e087a23c7cf439fbdf6bbd642401934184.tar.gz
gentoo-2-8d2f35e087a23c7cf439fbdf6bbd642401934184.tar.bz2
gentoo-2-8d2f35e087a23c7cf439fbdf6bbd642401934184.zip
Respecting LDFLAGS, fixing pre-stripped files bug #314111
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gatling/ChangeLog6
-rw-r--r--www-servers/gatling/files/gatling-0.12-FLAGS.patch40
-rw-r--r--www-servers/gatling/gatling-0.12.ebuild4
3 files changed, 47 insertions, 3 deletions
diff --git a/www-servers/gatling/ChangeLog b/www-servers/gatling/ChangeLog
index b9a33b6a5a64..7018776c3f60 100644
--- a/www-servers/gatling/ChangeLog
+++ b/www-servers/gatling/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/gatling
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/ChangeLog,v 1.5 2010/05/03 18:05:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/ChangeLog,v 1.6 2010/05/30 23:36:32 vostorga Exp $
+
+ 30 May 2010; Víctor Ostorga <vostorga@gentoo.org> gatling-0.12.ebuild,
+ +files/gatling-0.12-FLAGS.patch:
+ Respecting LDFLAGS, fixing pre-stripped files bug #314111
*gatling-0.12 (03 May 2010)
diff --git a/www-servers/gatling/files/gatling-0.12-FLAGS.patch b/www-servers/gatling/files/gatling-0.12-FLAGS.patch
new file mode 100644
index 000000000000..c7bd1fe4ceaf
--- /dev/null
+++ b/www-servers/gatling/files/gatling-0.12-FLAGS.patch
@@ -0,0 +1,40 @@
+diff -NrU5 gatling-0.12.original/GNUmakefile gatling-0.12/GNUmakefile
+--- gatling-0.12.original/GNUmakefile 2010-05-30 16:58:29.000000000 -0600
++++ gatling-0.12/GNUmakefile 2010-05-30 17:03:21.000000000 -0600
+@@ -1,8 +1,8 @@
+ #DEBUG=1
+ ZLIB=1
+-prefix=/opt/diet
++prefix=/usr
+ BINDIR=${prefix}/bin
+ MANDIR=${prefix}/man
+ man1dir=$(MANDIR)/man1
+
+ TARGETS=gatling httpbench bindbench dl ioerr bench tlsgatling \
+@@ -14,12 +14,12 @@
+ all: $(ALLTARGETS)
+
+ CROSS=
+ #CROSS=i686-mingw32-
+ CC=$(CROSS)gcc
+-CFLAGS=-pipe -Wall
+-LDFLAGS=
++CFLAGS+=-pipe -Wall -I/usr/include/libowfat
++LDFLAGS+=
+
+ path = $(subst :, ,$(PATH))
+ diet_path = $(foreach dir,$(path),$(wildcard $(dir)/diet))
+ ifeq ($(strip $(diet_path)),)
+ ifneq ($(wildcard /opt/diet/bin/diet),)
+@@ -37,11 +37,10 @@
+ ifneq ($(DEBUG),)
+ CFLAGS+=-g
+ LDFLAGS+=-g
+ else
+ CFLAGS+=-O2 -fomit-frame-pointer -I/usr/local/include
+-LDFLAGS+=-s
+ ifneq ($(DIET),)
+ DIET+=-Os
+ endif
+ endif
+
diff --git a/www-servers/gatling/gatling-0.12.ebuild b/www-servers/gatling/gatling-0.12.ebuild
index 8f54891ea3a5..36ae4e88a61b 100644
--- a/www-servers/gatling/gatling-0.12.ebuild
+++ b/www-servers/gatling/gatling-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/gatling-0.12.ebuild,v 1.1 2010/05/03 18:05:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gatling/gatling-0.12.ebuild,v 1.2 2010/05/30 23:36:32 vostorga Exp $
inherit eutils
@@ -26,7 +26,7 @@ src_unpack() {
unpack $A
cd "${S}"
- epatch "${FILESDIR}/gentoo-vars.patch"
+ epatch "${FILESDIR}/${P}-FLAGS.patch"
}
src_compile() {