summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-09-20 08:37:34 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-09-20 08:37:34 +0000
commit045840083b15aa3ab8b445e4e0b8ad8dbba4b040 (patch)
tree5e0a91edeb94c4e69cd31e713cbff4ead36914b4 /www-servers
parentfix #277297 and #277298; convert to EAPI2 (diff)
downloadgentoo-2-045840083b15aa3ab8b445e4e0b8ad8dbba4b040.tar.gz
gentoo-2-045840083b15aa3ab8b445e4e0b8ad8dbba4b040.tar.bz2
gentoo-2-045840083b15aa3ab8b445e4e0b8ad8dbba4b040.zip
fix #285449, #277297 and #277298; convert to EAPI2
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog9
-rw-r--r--www-servers/apache/apache-2.2.11-r2.ebuild6
-rw-r--r--www-servers/apache/apache-2.2.11-r3.ebuild118
-rw-r--r--www-servers/apache/apache-2.2.13-r1.ebuild (renamed from www-servers/apache/apache-2.2.12.ebuild)8
-rw-r--r--www-servers/apache/apache-2.2.13.ebuild6
5 files changed, 18 insertions, 129 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 9c7cd70d2bb2..9b1cca59a850 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.117 2009/08/26 08:15:30 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.118 2009/09/20 08:37:34 hollow Exp $
+
+*apache-2.2.13-r1 (20 Sep 2009)
+
+ 20 Sep 2009; Benedikt Böhm <hollow@gentoo.org> apache-2.2.11-r2.ebuild,
+ -apache-2.2.11-r3.ebuild, -apache-2.2.12.ebuild, apache-2.2.13.ebuild,
+ +apache-2.2.13-r1.ebuild:
+ fix #285449, #277297 and #277298; convert to EAPI2
*apache-2.2.13 (26 Aug 2009)
diff --git a/www-servers/apache/apache-2.2.11-r2.ebuild b/www-servers/apache/apache-2.2.11-r2.ebuild
index 492d68b8c617..002d7854ff52 100644
--- a/www-servers/apache/apache-2.2.11-r2.ebuild
+++ b/www-servers/apache/apache-2.2.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.11-r2.ebuild,v 1.6 2009/07/11 19:08:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.11-r2.ebuild,v 1.7 2009/09/20 08:37:34 hollow Exp $
# latest gentoo apache files
GENTOO_PATCHSTAMP="20090707"
@@ -89,12 +89,12 @@ DEPEND="${DEPEND}
RDEPEND="${RDEPEND}
apache2_modules_mime? ( app-misc/mime-types )"
-src_unpack() {
+src_prepare() {
if ! use sni ; then
EPATCH_EXCLUDE="04_all_mod_ssl_tls_sni.patch"
fi
- apache-2_src_unpack
+ apache-2_src_prepare
}
pkg_preinst() {
diff --git a/www-servers/apache/apache-2.2.11-r3.ebuild b/www-servers/apache/apache-2.2.11-r3.ebuild
deleted file mode 100644
index 89ba093ebe28..000000000000
--- a/www-servers/apache/apache-2.2.11-r3.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.11-r3.ebuild,v 1.1 2009/07/24 18:38:38 hollow Exp $
-
-# latest gentoo apache files
-GENTOO_PATCHSTAMP="20090724"
-GENTOO_DEVELOPER="hollow"
-
-# IUSE/USE_EXPAND magic
-IUSE_MPMS_FORK="itk peruser prefork"
-IUSE_MPMS_THREAD="event worker"
-
-IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
-authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
-authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
-charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires
-ext_filter file_cache filter headers ident imagemap include info log_config
-log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp
-proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif speling
-status substitute unique_id userdir usertrack version vhost_alias"
-
-# inter-module dependencies
-# TODO: this may still be incomplete
-MODULE_DEPENDS="
- dav_fs:dav
- dav_lock:dav
- deflate:filter
- disk_cache:cache
- ext_filter:filter
- file_cache:cache
- log_forensic:log_config
- logio:log_config
- mem_cache:cache
- mime_magic:mime
- proxy_ajp:proxy
- proxy_balancer:proxy
- proxy_connect:proxy
- proxy_ftp:proxy
- proxy_http:proxy
- substitute:filter
-"
-
-# module<->define mappings
-MODULE_DEFINES="
- auth_digest:AUTH_DIGEST
- authnz_ldap:AUTHNZ_LDAP
- cache:CACHE
- dav:DAV
- dav_fs:DAV
- dav_lock:DAV
- disk_cache:CACHE
- file_cache:CACHE
- info:INFO
- ldap:LDAP
- mem_cache:CACHE
- proxy:PROXY
- proxy_ajp:PROXY
- proxy_balancer:PROXY
- proxy_connect:PROXY
- proxy_ftp:PROXY
- proxy_http:PROXY
- ssl:SSL
- status:STATUS
- suexec:SUEXEC
- userdir:USERDIR
-"
-
-# critical modules for the default config
-MODULE_CRITICAL="
- authz_host
- dir
- mime
-"
-
-inherit apache-2
-
-DESCRIPTION="The Apache Web Server."
-HOMEPAGE="http://httpd.apache.org/"
-
-# some helper scripts are Apache-1.1, thus both are here
-LICENSE="Apache-2.0 Apache-1.1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="sni peruser_dc"
-
-DEPEND="${DEPEND}
- apache2_modules_deflate? ( sys-libs/zlib )"
-
-RDEPEND="${RDEPEND}
- apache2_modules_mime? ( app-misc/mime-types )"
-
-src_unpack() {
- if ! use sni ; then
- EPATCH_EXCLUDE="${EPATCH_EXCLUDE} 04_all_mod_ssl_tls_sni.patch"
- fi
-
- if use peruser_dc ; then
- if ! use apache2_mpms_peruser ; then
- die "USE=peruser_dc requires APACHE2_MPMS=peruser"
- fi
- else
- EPATCH_EXCLUDE="${EPATCH_EXCLUDE} 22_all_peruser_0.3.0-dc3.patch"
- fi
-
- apache-2_src_unpack
-}
-
-pkg_preinst() {
- # note regarding IfDefine changes
- if has_version "<${CATEGORY}/${PN}-2.2.6-r1"; then
- elog
- elog "When upgrading from versions 2.2.6 or earlier, please be aware"
- elog "that the define for mod_authnz_ldap has changed from AUTH_LDAP"
- elog "to AUTHNZ_LDAP. Additionally mod_auth_digest needs to be enabled"
- elog "with AUTH_DIGEST now."
- elog
- fi
-}
diff --git a/www-servers/apache/apache-2.2.12.ebuild b/www-servers/apache/apache-2.2.13-r1.ebuild
index ee6bbe90c0cc..53024925e79a 100644
--- a/www-servers/apache/apache-2.2.12.ebuild
+++ b/www-servers/apache/apache-2.2.13-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.12.ebuild,v 1.1 2009/07/29 08:13:35 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.13-r1.ebuild,v 1.1 2009/09/20 08:37:34 hollow Exp $
# latest gentoo apache files
-GENTOO_PATCHSTAMP="20090729"
+GENTOO_PATCHSTAMP="20090920"
GENTOO_DEVELOPER="hollow"
# IUSE/USE_EXPAND magic
@@ -89,7 +89,7 @@ DEPEND="${DEPEND}
RDEPEND="${RDEPEND}
apache2_modules_mime? ( app-misc/mime-types )"
-src_unpack() {
+src_prepare() {
if use peruser_dc ; then
if ! use apache2_mpms_peruser ; then
die "USE=peruser_dc requires APACHE2_MPMS=peruser"
@@ -98,5 +98,5 @@ src_unpack() {
EPATCH_EXCLUDE="${EPATCH_EXCLUDE} 22_all_peruser_0.3.0-dc3.patch"
fi
- apache-2_src_unpack
+ apache-2_src_prepare
}
diff --git a/www-servers/apache/apache-2.2.13.ebuild b/www-servers/apache/apache-2.2.13.ebuild
index 3808a5c5b486..e1da6dc679a8 100644
--- a/www-servers/apache/apache-2.2.13.ebuild
+++ b/www-servers/apache/apache-2.2.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.13.ebuild,v 1.1 2009/08/26 08:15:30 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.13.ebuild,v 1.2 2009/09/20 08:37:34 hollow Exp $
# latest gentoo apache files
GENTOO_PATCHSTAMP="20090826"
@@ -89,7 +89,7 @@ DEPEND="${DEPEND}
RDEPEND="${RDEPEND}
apache2_modules_mime? ( app-misc/mime-types )"
-src_unpack() {
+src_prepare() {
if use peruser_dc ; then
if ! use apache2_mpms_peruser ; then
die "USE=peruser_dc requires APACHE2_MPMS=peruser"
@@ -98,5 +98,5 @@ src_unpack() {
EPATCH_EXCLUDE="${EPATCH_EXCLUDE} 22_all_peruser_0.3.0-dc3.patch"
fi
- apache-2_src_unpack
+ apache-2_src_prepare
}