summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-04-16 11:46:30 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-04-16 11:46:30 +0000
commitdba6ff8e80683792ed0b6e23701665752d7d903c (patch)
tree83706f9854a9be597d109b1789998c79b9c40a00 /www-servers/nginx
parentadd patch back (diff)
downloadgentoo-2-dba6ff8e80683792ed0b6e23701665752d7d903c.tar.gz
gentoo-2-dba6ff8e80683792ed0b6e23701665752d7d903c.tar.bz2
gentoo-2-dba6ff8e80683792ed0b6e23701665752d7d903c.zip
- outdated ebuild
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.271
-rw-r--r--www-servers/nginx/nginx-0.1.27.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/www-servers/nginx/files/digest-nginx-0.1.27 b/www-servers/nginx/files/digest-nginx-0.1.27
deleted file mode 100644
index d89ce32e9c80..000000000000
--- a/www-servers/nginx/files/digest-nginx-0.1.27
+++ /dev/null
@@ -1 +0,0 @@
-MD5 666ebc078355ef1172552df7f82bada8 nginx-0.1.27.tar.gz 295404
diff --git a/www-servers/nginx/nginx-0.1.27.ebuild b/www-servers/nginx/nginx-0.1.27.ebuild
deleted file mode 100644
index 34f3ba994c7e..000000000000
--- a/www-servers/nginx/nginx-0.1.27.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.27.ebuild,v 1.2 2005/04/11 08:14:07 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="ssl zlib threads"
-
-DEPEND="dev-lang/perl
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-
-src_compile() {
- local myconf
-
- use ssl && myconf="${myconf} --with-http_ssl_module"
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use zlib || myconf="${myconf} --without-http_gzip_module"
-
- cd ${S}
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm \
- ${myconf}
-
- emake || "failed to compile"
-}
-
-src_install() {
- cd ${S} || die
-
- dodir /var/log/${PN}
- keepdir /var/log/${PN}
-
- dodir /var/tmp/${PN}
-
- dodir /var/tmp/${PN}/client
- keepdir /var/tmp/${PN}/client
-
- dodir /var/tmp/${PN}/proxy
- keepdir /var/tmp/${PN}/proxy
-
- dodir /var/tmp/${PN}/fastcgi
- keepdir /var/tmp/${PN}/fastcgi
-
- dodir /etc/${PN}
-
- dosbin objs/nginx
- doinitd ${FILESDIR}/nginx
-
- insinto /etc/${PN}
- rm conf/nginx.conf
- doins -r conf/*
- doins ${FILESDIR}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-}