summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-27 15:36:37 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-27 15:36:37 +0000
commitff1ad482e37fedfbc8766d7973f176173fa4c9a9 (patch)
treeb39b1566bae3a4122766c335037b438e6cb85af6 /www-plugins
parentHopefully fix default mailbox for real now (diff)
downloadgentoo-2-ff1ad482e37fedfbc8766d7973f176173fa4c9a9.tar.gz
gentoo-2-ff1ad482e37fedfbc8766d7973f176173fa4c9a9.tar.bz2
gentoo-2-ff1ad482e37fedfbc8766d7973f176173fa4c9a9.zip
Version bump, bug #375727. Allow enabling of individual audio backends, bug #342763.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog11
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.8.1-allow-disabling-pulseaudio.patch24
-rw-r--r--www-plugins/lightspark/lightspark-0.5.0.ebuild (renamed from www-plugins/lightspark/lightspark-0.4.8.1.ebuild)23
-rw-r--r--www-plugins/lightspark/metadata.xml3
4 files changed, 28 insertions, 33 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 85d267161a29..2a04e495d327 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.32 2011/07/16 13:30:16 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.33 2011/07/27 15:36:37 chithanh Exp $
+
+*lightspark-0.5.0 (27 Jul 2011)
+
+ 27 Jul 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -lightspark-0.4.8.1.ebuild,
+ -files/lightspark-0.4.8.1-allow-disabling-pulseaudio.patch,
+ +lightspark-0.5.0.ebuild, metadata.xml:
+ Version bump, bug #375727. Allow enabling of individual audio backends, bug
+ #342763.
16 Jul 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
lightspark-0.4.8.1.ebuild, -files/lightspark-0.4.8.1-cmakelists.patch:
diff --git a/www-plugins/lightspark/files/lightspark-0.4.8.1-allow-disabling-pulseaudio.patch b/www-plugins/lightspark/files/lightspark-0.4.8.1-allow-disabling-pulseaudio.patch
deleted file mode 100644
index 9df28e873cf8..000000000000
--- a/www-plugins/lightspark/files/lightspark-0.4.8.1-allow-disabling-pulseaudio.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2011-05-27 14:02:19.000000000 +0200
-+++ b/CMakeLists.txt 2011-06-15 15:08:21.079714248 +0200
-@@ -122,6 +122,7 @@
- SET(COMPILE_LIGHTSPARK TRUE CACHE BOOL "Compile Lightspark?")
- SET(COMPILE_TIGHTSPARK TRUE CACHE BOOL "Compile Tightspark?")
- SET(COMPILE_PLUGIN TRUE CACHE BOOL "Compile the browser plugin?")
-+SET(AUDIO_BACKEND "pulse" CACHE STRING "Choose audio backend: none pulse alsa, default is pulse")
- SET(ENABLE_CURL TRUE CACHE BOOL "Enable CURL? (Required for Downloader functionality)")
- SET(ENABLE_LIBAVCODEC TRUE CACHE BOOL "Enable libavcodec and dependent functionality?")
- SET(ENABLE_RTMP FALSE CACHE BOOL "Enable librtmp and dependent functionality?")
-diff -ur a/src/CMakeLists.txt b/src/CMakeLists.txt
---- a/src/CMakeLists.txt 2011-06-15 15:07:47.375546914 +0200
-+++ b/src/CMakeLists.txt 2011-06-15 15:09:07.819945946 +0200
-@@ -140,6 +140,8 @@
- ADD_SUBDIRECTORY(plugin)
- ENDIF(COMPILE_PLUGIN)
-
--ADD_SUBDIRECTORY(backends/interfaces/audio/pulse)
-+IF(${AUDIO_BACKEND} MATCHES "pulse")
-+ ADD_SUBDIRECTORY(backends/interfaces/audio/pulse)
-+ENDIF(${AUDIO_BACKEND} MATCHES "pulse")
- #ADD_SUBDIRECTORY(backends/interfaces/audio/alsa)
- #ADD_SUBDIRECTORY(backends/interfaces/audio/openal)
diff --git a/www-plugins/lightspark/lightspark-0.4.8.1.ebuild b/www-plugins/lightspark/lightspark-0.5.0.ebuild
index 0ff04ede2b6a..07cfff473938 100644
--- a/www-plugins/lightspark/lightspark-0.4.8.1.ebuild
+++ b/www-plugins/lightspark/lightspark-0.5.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.8.1.ebuild,v 1.2 2011/07/16 13:30:16 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.5.0.ebuild,v 1.1 2011/07/27 15:36:36 chithanh Exp $
-EAPI=3
+EAPI=4
inherit cmake-utils nsplugins multilib versionator
DESCRIPTION="High performance flash player"
@@ -12,7 +12,7 @@ SRC_URI="http://launchpad.net/${PN}/trunk/${PN}-$(get_version_component_range 1-
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="nsplugin pulseaudio"
+IUSE="nsplugin openal profile pulseaudio rtmp sdl"
RDEPEND=">=dev-cpp/libxmlpp-2.33.1:2.6
>=dev-libs/boost-1.42
@@ -23,9 +23,15 @@ RDEPEND=">=dev-cpp/libxmlpp-2.33.1:2.6
media-libs/ftgl
>=media-libs/glew-1.5.3
media-libs/libsdl
+ openal? (
+ media-libs/openal
+ )
pulseaudio? (
media-sound/pulseaudio
)
+ rtmp? (
+ media-video/rtmpdump
+ )
net-misc/curl
>=sys-devel/gcc-4.4
>=sys-devel/llvm-2.8-r2
@@ -40,19 +46,20 @@ RDEPEND=">=dev-cpp/libxmlpp-2.33.1:2.6
DEPEND="${RDEPEND}
dev-lang/nasm
dev-util/pkgconfig"
+REQUIRED_USE="openal? ( pulseaudio )"
S=${WORKDIR}/${P/_rc*/}
-PATCHES=(
- "${FILESDIR}"/${PN}-0.4.8.1-allow-disabling-pulseaudio.patch
-)
-
src_configure() {
local audiobackends
- use pulseaudio && audiobackends=pulse
+ use openal && audiobackends+="openal"
+ use pulseaudio && audiobackends+="pulse"
+ use sdl && audiobackends+="sdl"
local mycmakeargs=(
$(cmake-utils_use nsplugin COMPILE_PLUGIN)
+ $(cmake-utils_use profile ENABLE_PROFILING)
+ $(cmake-utils_use rtmp ENABLE_RTMP)
-DAUDIO_BACKEND="${audiobackends}"
-DPLUGIN_DIRECTORY=/usr/$(get_libdir)/${PN}/plugins
)
diff --git a/www-plugins/lightspark/metadata.xml b/www-plugins/lightspark/metadata.xml
index 8fe9668040a6..81b683180fbd 100644
--- a/www-plugins/lightspark/metadata.xml
+++ b/www-plugins/lightspark/metadata.xml
@@ -6,5 +6,8 @@
<email>chithanh@gentoo.org</email>
<name>Chí-Thanh Christopher Nguyễn</name>
</maintainer>
+ <use>
+ <flag name='rtmp'>Enable Real Time Messaging Protocol using librtmp</flag>
+ </use>
</pkgmetadata>