summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-07-04 11:05:33 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-07-04 11:05:33 +0000
commit7c4fcb7b309f8fac5450562698ddc100ba0642d0 (patch)
tree3963042b37accf4db81b16dceb6413b46dda2d1c /www-plugins
parentRemove vulnerable. (diff)
downloadgentoo-2-7c4fcb7b309f8fac5450562698ddc100ba0642d0.tar.gz
gentoo-2-7c4fcb7b309f8fac5450562698ddc100ba0642d0.tar.bz2
gentoo-2-7c4fcb7b309f8fac5450562698ddc100ba0642d0.zip
Revision bump, add patch by Mario Kicherer to fix bug 553318
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/kpartsplugin/ChangeLog10
-rw-r--r--www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch21
-rw-r--r--www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild24
3 files changed, 53 insertions, 2 deletions
diff --git a/www-plugins/kpartsplugin/ChangeLog b/www-plugins/kpartsplugin/ChangeLog
index c48d48ac6b6f..e6b6883acbd0 100644
--- a/www-plugins/kpartsplugin/ChangeLog
+++ b/www-plugins/kpartsplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/kpartsplugin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/kpartsplugin/ChangeLog,v 1.19 2014/04/26 12:06:17 johu Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/kpartsplugin/ChangeLog,v 1.20 2015/07/04 11:05:33 dilfridge Exp $
+
+*kpartsplugin-20120723-r2 (04 Jul 2015)
+
+ 04 Jul 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +files/kpartsplugin-20120723-segfault.patch, +kpartsplugin-20120723-r2.ebuild:
+ Revision bump, add patch by Mario Kicherer to fix bug 553318
26 Apr 2014; Johannes Huber <johu@gentoo.org> -kpartsplugin-20120723.ebuild,
kpartsplugin-20120723-r1.ebuild:
diff --git a/www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch b/www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch
new file mode 100644
index 000000000000..9ac0aeef0d2a
--- /dev/null
+++ b/www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch
@@ -0,0 +1,21 @@
+commit e883f236c476830fec2306b6b4ad90ec27f643a1
+Author: Mario Kicherer <kicherer@kit.edu>
+Date: Fri Jun 26 11:34:21 2015 +0200
+
+ fix crash after kpart selection dialog
+
+diff --git a/src/kpartsplugin.cpp b/src/kpartsplugin.cpp
+index a9ee9df..56c4aa4 100644
+--- a/src/kpartsplugin.cpp
++++ b/src/kpartsplugin.cpp
+@@ -120,8 +120,8 @@ public:
+ dlg.exec();
+ rememberChoice = dlg.checkBoxRemember->checkState() == Qt::Checked;
+ /// fetch first (and only) selected item in list
+- QList<QListWidgetItem *>::ConstIterator it(dlg.listWidget->selectedItems().constBegin());
+- return (*it)->text();
++ QList<QListWidgetItem *> it(dlg.listWidget->selectedItems());
++ return it.at(0)->text();
+ }
+
+ };
diff --git a/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild b/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild
new file mode 100644
index 000000000000..de528b57ff95
--- /dev/null
+++ b/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild,v 1.1 2015/07/04 11:05:33 dilfridge Exp $
+
+EAPI=5
+
+inherit kde4-base nsplugins
+
+DESCRIPTION="Plugin using KDE's KParts technology to embed file viewers into non-KDE browsers"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin/"
+SRC_URI="http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin/${P}.tar.bz2"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug"
+
+PATCHES=( "${FILESDIR}/${P}-segfault.patch" )
+
+src_prepare() {
+ echo "set( PLUGIN_INSTALL_DIR \"/usr/$(get_libdir)/${PLUGINS_DIR}/\" )" >> CMakeLists.txt || die
+ kde4-base_src_prepare
+}