summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-11-11 11:49:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-11-11 11:49:23 +0000
commit5585531cf8b126af6bc91b20412e8fb3e6e819bd (patch)
treece67abb78e4cb945b46e8012d3d0b3fb16c54d84 /www-misc
parentDrop me from maint. (diff)
downloadgentoo-2-5585531cf8b126af6bc91b20412e8fb3e6e819bd.tar.gz
gentoo-2-5585531cf8b126af6bc91b20412e8fb3e6e819bd.tar.bz2
gentoo-2-5585531cf8b126af6bc91b20412e8fb3e6e819bd.zip
Version bump; new version is beta but solves some security issues.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/awstats/ChangeLog8
-rw-r--r--www-misc/awstats/awstats-7.1.ebuild110
-rw-r--r--www-misc/awstats/files/awstats-7.1-gentoo.diff21
3 files changed, 138 insertions, 1 deletions
diff --git a/www-misc/awstats/ChangeLog b/www-misc/awstats/ChangeLog
index e92b9c878e04..2e7f40bb13ed 100644
--- a/www-misc/awstats/ChangeLog
+++ b/www-misc/awstats/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/awstats
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/awstats/ChangeLog,v 1.21 2011/06/06 12:15:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/awstats/ChangeLog,v 1.22 2011/11/11 11:49:23 flameeyes Exp $
+
+*awstats-7.1 (11 Nov 2011)
+
+ 11 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> +awstats-7.1.ebuild,
+ +files/awstats-7.1-gentoo.diff:
+ Version bump; new version is beta but solves some security issues.
06 Jun 2011; Diego E. Pettenò <flameeyes@gentoo.org>
-files/postinst-en-r1.txt, -awstats-6.95.ebuild,
diff --git a/www-misc/awstats/awstats-7.1.ebuild b/www-misc/awstats/awstats-7.1.ebuild
new file mode 100644
index 000000000000..13101d38ad8c
--- /dev/null
+++ b/www-misc/awstats/awstats-7.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/awstats/awstats-7.1.ebuild,v 1.1 2011/11/11 11:49:23 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P=${PN}-${PV%_p*}
+
+DESCRIPTION="AWStats is short for Advanced Web Statistics."
+HOMEPAGE="http://www.awstats.org/"
+
+if [ ${MY_P} != ${P} ]; then
+ SRC_URI="http://dev.gentoo.org/~flameeyes/awstats/${P}.tar.gz"
+ # The following SRC_URI is useful only when fetching for the first time
+ # after bump; upstream does not bump the version when they change it, so
+ # we rename it to include the date and upload to our mirrors instead.
+ #SRC_URI="http://www.awstats.org/files/${MY_P}.tar.gz -> ${P}.tar.gz"
+else
+ SRC_URI="http://www.awstats.org/files/${P}.tar.gz"
+fi
+
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="geoip ipv6"
+
+SLOT="0"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ virtual/perl-Time-Local
+ dev-perl/URI
+ geoip? ( dev-perl/Geo-IP )
+ ipv6? ( dev-perl/Net-IP dev-perl/Net-DNS )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.1-gentoo.diff
+
+ # change default installation directory
+ find . -type f -exec sed \
+ -e "s#/usr/local/awstats/wwwroot#/usr/share/awstats/wwwroot#g" \
+ -i {} + || die "find/sed failed"
+
+ # set default values for directories; use apache log as an example
+ sed \
+ -e "s|^\(LogFile=\).*$|\1\"/var/log/apache2/access_log\"|" \
+ -e "s|^\(SiteDomain=\).*$|\1\"localhost\"|" \
+ -e "s|^\(DirIcons=\).*$|\1\"/awstats/icon\"|" \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+
+ # enable plugins
+
+ if use ipv6; then
+ sed -e "s|^#\(LoadPlugin=\"ipv6\"\)$|\1|" \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+ fi
+
+ if use geoip; then
+ sed -e '/LoadPlugin="geoip /aLoadPlugin="geoip GEOIP_STANDARD /usr/share/GeoIP/GeoIP.dat"' \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+ fi
+
+ find "${S}" '(' -type f -not -name '*.pl' ')' -exec chmod -x {} + || die
+}
+
+src_install() {
+ dohtml -r docs/*
+ dodoc README.TXT
+ newdoc wwwroot/cgi-bin/plugins/example/example.pm example_plugin.pm
+ dodoc -r tools/xslt
+
+ keepdir /var/lib/awstats
+
+ insinto /etc/awstats
+ doins "${S}"/wwwroot/cgi-bin/awstats.model.conf
+
+ # remove extra content that we don't want to install
+ rm -r "${S}"/wwwroot/cgi-bin/awstats.model.conf \
+ "${S}"/wwwroot/classes/src || die
+
+ insinto /usr/share/awstats
+ doins -r wwwroot || die
+ chmod +x "${D}"/usr/share/awstats/wwwroot/cgi-bin/*.pl
+
+ cd "${S}"/tools
+ dobin awstats_buildstaticpages.pl awstats_exportlib.pl \
+ awstats_updateall.pl
+ newbin logresolvemerge.pl awstats_logresolvemerge.pl
+ newbin maillogconvert.pl awstats_maillogconvert.pl
+ newbin urlaliasbuilder.pl awstats_urlaliasbuilder.pl
+
+ dosym ../share/awstats/wwwroot/cgi-bin/awstats.pl /usr/bin/awstats.pl || die
+}
+
+pkg_postinst() {
+ elog "The AWStats-Manual is available either inside"
+ elog "the /usr/share/doc/${PF} - folder, or at"
+ elog "http://awstats.sourceforge.net/docs/index.html ."
+ elog
+ elog "Copy the /etc/awstats/awstats.model.conf to"
+ elog "/etc/awstats/awstats.<yourdomain>.conf and edit it."
+ elog ""
+ ewarn "This ebuild does no longer use webapp-config to install"
+ ewarn "instead you should point your configuration to the stable"
+ ewarn "directory tree in the following path:"
+ ewarn " /usr/share/awstats"
+}
diff --git a/www-misc/awstats/files/awstats-7.1-gentoo.diff b/www-misc/awstats/files/awstats-7.1-gentoo.diff
new file mode 100644
index 000000000000..a58ed48bd548
--- /dev/null
+++ b/www-misc/awstats/files/awstats-7.1-gentoo.diff
@@ -0,0 +1,21 @@
+--- awstats-6.3.orig/tools/awstats_configure.pl 2005-01-24 09:28:43.980923725 -0500
++++ awstats-6.3/tools/awstats_configure.pl 2005-01-24 09:28:52.034571769 -0500
+@@ -658,6 +658,18 @@
+ print "\n-----> Restart Web server with '$command'\n";
+ my $ret=`$command`;
+ print "$ret";
++ } elsif (-f "/etc/gentoo-release") {
++ my $command;
++ if (-x "/etc/init.d/apache2") {
++ $command="/etc/init.d/apache2 graceful";
++ } else {
++ print "\n-----> Don't forget to restart manually your web server\n";
++ }
++ if ($command != "") {
++ print "\n-----> Restart Web server with '$command'\n";
++ my $ret=`$command`;
++ print "$ret";
++ }
+ } elsif (-x "/sbin/service") {
+ # We are not on debian
+ my $command="/sbin/service httpd restart";