summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-12 18:42:50 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-12 18:42:50 +0000
commit884c59260e95370777cbfad5983a7a1d68bf71c2 (patch)
tree0fc72b9da07f8a42365dc442b8ea767c313845a6 /www-client
parentRemoving Marien Zwart (marienz, #107204) from metadata.xml. (diff)
downloadgentoo-2-884c59260e95370777cbfad5983a7a1d68bf71c2.tar.gz
gentoo-2-884c59260e95370777cbfad5983a7a1d68bf71c2.tar.bz2
gentoo-2-884c59260e95370777cbfad5983a7a1d68bf71c2.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla-launcher/ChangeLog8
-rw-r--r--www-client/mozilla-launcher/mozilla-launcher-1.59.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/www-client/mozilla-launcher/ChangeLog b/www-client/mozilla-launcher/ChangeLog
index 9275ceb4eb24..de3da797f1cd 100644
--- a/www-client/mozilla-launcher/ChangeLog
+++ b/www-client/mozilla-launcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/mozilla-launcher
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/ChangeLog,v 1.73 2008/02/26 19:52:14 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/ChangeLog,v 1.74 2008/03/12 18:42:50 armin76 Exp $
+
+*mozilla-launcher-1.59 (12 Mar 2008)
+
+ 12 Mar 2008; Raúl Porcel <armin76@gentoo.org>
+ +mozilla-launcher-1.59.ebuild:
+ Version bump
26 Feb 2008; Richard Freeman <rich0@gentoo.org>
mozilla-launcher-1.58.ebuild:
diff --git a/www-client/mozilla-launcher/mozilla-launcher-1.59.ebuild b/www-client/mozilla-launcher/mozilla-launcher-1.59.ebuild
new file mode 100644
index 000000000000..e090d3575b84
--- /dev/null
+++ b/www-client/mozilla-launcher/mozilla-launcher-1.59.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.59.ebuild,v 1.1 2008/03/12 18:42:50 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE="http://sources.gentoo.org/viewcvs.py/gentoo-src/mozilla-launcher/"
+SRC_URI="mirror://gentoo/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="x11-apps/xdpyinfo"
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher || die
+}
+
+pkg_postinst() {
+ local f
+
+ find "${ROOT}/usr/bin" -maxdepth 1 -type l | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}