summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2012-05-21 14:09:22 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2012-05-21 14:09:22 +0000
commit5b5bddeb125a8cdcf0ee31acb3e5f84aa9c8125e (patch)
tree294ab45d1fcd81f129ba1c06c84524984bcd0c75 /www-client
parentRemove unnecessary definition, thanks to Arfrever for pointing out. (diff)
downloadgentoo-2-5b5bddeb125a8cdcf0ee31acb3e5f84aa9c8125e.tar.gz
gentoo-2-5b5bddeb125a8cdcf0ee31acb3e5f84aa9c8125e.tar.bz2
gentoo-2-5b5bddeb125a8cdcf0ee31acb3e5f84aa9c8125e.zip
Version bump for dev channel release. Fix bug #416393 by Alexander E. Patrakov. Remove old.
(Portage version: 2.1.10.49/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-20.0.1132.11.ebuild (renamed from www-client/chromium/chromium-20.0.1132.3.ebuild)18
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild4
3 files changed, 26 insertions, 6 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 219c18a6c3dd..d78d5fe63638 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.640 2012/05/19 18:56:18 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.641 2012/05/21 14:09:22 phajdan.jr Exp $
+
+*chromium-20.0.1132.11 (21 May 2012)
+
+ 21 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-20.0.1132.3.ebuild, +chromium-20.0.1132.11.ebuild,
+ chromium-9999-r1.ebuild:
+ Version bump for dev channel release. Fix bug #416393 by Alexander E.
+ Patrakov. Remove old.
19 May 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
chromium-20.0.1132.8.ebuild, chromium-9999-r1.ebuild:
diff --git a/www-client/chromium/chromium-20.0.1132.3.ebuild b/www-client/chromium/chromium-20.0.1132.11.ebuild
index 7cc241c3d649..d89faffb9481 100644
--- a/www-client/chromium/chromium-20.0.1132.3.ebuild
+++ b/www-client/chromium/chromium-20.0.1132.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-20.0.1132.3.ebuild,v 1.2 2012/05/15 06:44:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-20.0.1132.11.ebuild,v 1.1 2012/05/21 14:09:22 phajdan.jr Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -112,12 +112,14 @@ src_prepare() {
# Backport upstream fix for Gentoo bug #415601.
epatch "${FILESDIR}/${PN}-unistd-r0.patch"
+ # Fix build without tcmalloc. To be upstreamed.
+ epatch "${FILESDIR}/${PN}-tcmalloc-r0.patch"
+
epatch_user
# Remove most bundled libraries. Some are still needed.
find third_party -type f \! -iname '*.gyp*' \
\! -path 'third_party/WebKit/*' \
- \! -path 'third_party/adobe/*' \
\! -path 'third_party/angle/*' \
\! -path 'third_party/cacheinvalidation/*' \
\! -path 'third_party/cld/*' \
@@ -129,7 +131,6 @@ src_prepare() {
\! -path 'third_party/hunspell/*' \
\! -path 'third_party/iccjpeg/*' \
\! -path 'third_party/jsoncpp/*' \
- \! -path 'third_party/json_minify/*' \
\! -path 'third_party/khronos/*' \
\! -path 'third_party/launchpad_translations/*' \
\! -path 'third_party/leveldatabase/*' \
@@ -138,6 +139,7 @@ src_prepare() {
\! -path 'third_party/libsrtp/*' \
\! -path 'third_party/libusb/*' \
\! -path 'third_party/libvpx/*' \
+ \! -path 'third_party/libxml/chromium/*' \
\! -path 'third_party/libyuv/*' \
\! -path 'third_party/lss/*' \
\! -path 'third_party/mesa/*' \
@@ -153,7 +155,6 @@ src_prepare() {
\! -path 'third_party/smhasher/*' \
\! -path 'third_party/speex/speex.h' \
\! -path 'third_party/sqlite/*' \
- \! -path 'third_party/tcmalloc/*' \
\! -path 'third_party/tlslite/*' \
\! -path 'third_party/undoview/*' \
\! -path 'third_party/v8-i18n/*' \
@@ -189,6 +190,14 @@ src_configure() {
# additions, bug #336871.
myconf+=" -Ddisable_sse2=1"
+ # Disable tcmalloc, it causes problems with e.g. NVIDIA
+ # drivers, bug #413637.
+ myconf+=" -Dlinux_use_tcmalloc=0"
+
+ # Make it possible to remove third_party/adobe.
+ echo > "${T}/flapper_version.h" || die
+ myconf+=" -Dflapper_version_h_file=${T}/flapper_version.h"
+
# Use system-provided libraries.
# TODO: use_system_ffmpeg
# TODO: use_system_hunspell (upstream changes needed).
@@ -388,6 +397,7 @@ src_install() {
local mime_types="text/html;text/xml;application/xhtml+xml;"
mime_types+="x-scheme-handler/http;x-scheme-handler/https;" # bug #360797
mime_types+="x-scheme-handler/ftp;" # bug #412185
+ mime_types+="x-scheme-handler/mailto;x-scheme-handler/webcal;" # bug #416393
make_desktop_entry \
chromium-browser${CHROMIUM_SUFFIX} \
"Chromium${CHROMIUM_SUFFIX}" \
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 0d3566dffc54..c5b5e2bf192d 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.113 2012/05/19 18:56:18 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.114 2012/05/21 14:09:22 phajdan.jr Exp $
EAPI="4"
PYTHON_DEPEND="2:2.6"
@@ -187,6 +187,7 @@ src_prepare() {
\! -path 'third_party/libsrtp/*' \
\! -path 'third_party/libusb/*' \
\! -path 'third_party/libvpx/*' \
+ \! -path 'third_party/libxml/chromium/*' \
\! -path 'third_party/libyuv/*' \
\! -path 'third_party/lss/*' \
\! -path 'third_party/mesa/*' \
@@ -444,6 +445,7 @@ src_install() {
local mime_types="text/html;text/xml;application/xhtml+xml;"
mime_types+="x-scheme-handler/http;x-scheme-handler/https;" # bug #360797
mime_types+="x-scheme-handler/ftp;" # bug #412185
+ mime_types+="x-scheme-handler/mailto;x-scheme-handler/webcal;" # bug #416393
make_desktop_entry \
chromium-browser${CHROMIUM_SUFFIX} \
"Chromium${CHROMIUM_SUFFIX}" \