summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-07-05 22:20:33 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-07-05 22:20:33 +0000
commit331e024d5fc84895fe574e0bf89e24023b49c708 (patch)
tree91adc8363057741b3ea444fdd3991129fb24bb08 /www-client/xombrero
parentBump PHP_TARGETS to php5-4, as it should be always latest stable. (diff)
downloadgentoo-2-331e024d5fc84895fe574e0bf89e24023b49c708.tar.gz
gentoo-2-331e024d5fc84895fe574e0bf89e24023b49c708.tar.bz2
gentoo-2-331e024d5fc84895fe574e0bf89e24023b49c708.zip
Version bump to 1.6.1, EAPI 5, wrt bug #475890
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'www-client/xombrero')
-rw-r--r--www-client/xombrero/ChangeLog9
-rw-r--r--www-client/xombrero/xombrero-1.6.1.ebuild95
-rw-r--r--www-client/xombrero/xombrero-9999.ebuild7
3 files changed, 105 insertions, 6 deletions
diff --git a/www-client/xombrero/ChangeLog b/www-client/xombrero/ChangeLog
index 52e58078e755..984adcf90fc6 100644
--- a/www-client/xombrero/ChangeLog
+++ b/www-client/xombrero/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/xombrero
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/xombrero/ChangeLog,v 1.2 2013/01/31 03:25:16 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/xombrero/ChangeLog,v 1.3 2013/07/05 22:20:33 ago Exp $
+
+*xombrero-1.6.1 (05 Jul 2013)
+
+ 05 Jul 2013; Agostino Sarubbo <ago@gentoo.org> +xombrero-1.6.1.ebuild,
+ xombrero-9999.ebuild:
+ Version bump to 1.6.1, EAPI 5, wrt bug #475890
31 Jan 2013; Rafael G. Martins <rafaelmartins@gentoo.org>
xombrero-1.4.0.ebuild:
@@ -12,4 +18,3 @@
31 Jan 2013; Rafael G. Martins <rafaelmartins@gentoo.org>
+xombrero-1.4.0.ebuild, +xombrero-9999.ebuild, +metadata.xml:
Initial import. Renamed from www-client/xxxterm
-
diff --git a/www-client/xombrero/xombrero-1.6.1.ebuild b/www-client/xombrero/xombrero-1.6.1.ebuild
new file mode 100644
index 000000000000..2b398d5964fe
--- /dev/null
+++ b/www-client/xombrero/xombrero-1.6.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/xombrero/xombrero-1.6.1.ebuild,v 1.1 2013/07/05 22:20:33 ago Exp $
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS=git-2
+fi
+
+inherit eutils fdo-mime toolchain-funcs ${GIT_ECLASS}
+
+DESCRIPTION="A minimalist web browser with sophisticated security features designed-in"
+HOMEPAGE="http://opensource.conformal.com/wiki/xombrero"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://opensource.conformal.com/${PN}.git
+ https://opensource.conformal.com/git/${PN}.git"
+ EGIT_SOURCEDIR="${WORKDIR}/${P}"
+ KEYWORDS=""
+else
+ SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libbsd
+ dev-libs/libgcrypt
+ net-libs/libsoup
+ net-libs/gnutls
+ net-libs/webkit-gtk:3
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/groff
+ dev-libs/atk
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:0
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/pixman"
+
+S="${WORKDIR}/${P}/linux"
+
+src_prepare() {
+ sed -i \
+ -e 's/-O2//' \
+ -e 's/-ggdb3//' \
+ -e 's,install: all,install: all\n\tinstall -m 755 -d $(DESTDIR)$(PREFIX)/share/applications,g' \
+ Makefile || die 'sed Makefile failed.'
+ sed -i \
+ -e 's#https://www\.cyphertite\.com#http://www.gentoo.org/#' \
+ -e "s#/usr/local#/usr#" \
+ ../xombrero.h || die 'sed ../xombrero.c failed.'
+ sed -i \
+ "s#Icon=#Icon=/usr/share/${PN}/#" \
+ ../xombrero.desktop || die 'sed ../xombrero.desktop failed.'
+}
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDADD="${LDFLAGS}" emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ install
+
+ if use examples;then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins \
+ ../${PN}.conf \
+ ../playflash.sh \
+ ../favorites
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/www-client/xombrero/xombrero-9999.ebuild b/www-client/xombrero/xombrero-9999.ebuild
index 2b0795716098..7cc4b234a1be 100644
--- a/www-client/xombrero/xombrero-9999.ebuild
+++ b/www-client/xombrero/xombrero-9999.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/xombrero/xombrero-9999.ebuild,v 1.1 2013/01/31 00:25:39 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/xombrero/xombrero-9999.ebuild,v 1.2 2013/07/05 22:20:32 ago Exp $
-EAPI="4"
+EAPI="5"
-GIT_ECLASS=
if [[ ${PV} = *9999* ]]; then
GIT_ECLASS=git-2
fi
@@ -14,11 +13,11 @@ inherit eutils fdo-mime toolchain-funcs ${GIT_ECLASS}
DESCRIPTION="A minimalist web browser with sophisticated security features designed-in"
HOMEPAGE="http://opensource.conformal.com/wiki/xombrero"
-KEYWORDS=""
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://opensource.conformal.com/${PN}.git
https://opensource.conformal.com/git/${PN}.git"
EGIT_SOURCEDIR="${WORKDIR}/${P}"
+ KEYWORDS=""
else
SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
KEYWORDS="~amd64 ~x86"