summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-13 23:25:22 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-13 23:25:22 +0000
commit3e06a0c412c6917c6f392b4ef8a5d8727bca7d74 (patch)
treefffe2402297dcbbd53a304e31218e857ca17eae8 /www-client/w3m
parentdrop "imstt" from VIDEO_CARDS in all profiles (diff)
downloadgentoo-2-3e06a0c412c6917c6f392b4ef8a5d8727bca7d74.tar.gz
gentoo-2-3e06a0c412c6917c6f392b4ef8a5d8727bca7d74.tar.bz2
gentoo-2-3e06a0c412c6917c6f392b4ef8a5d8727bca7d74.zip
boehm-gc 7.2 support.
(Portage version: 2.1.7.13/cvs/Linux x86_64)
Diffstat (limited to 'www-client/w3m')
-rw-r--r--www-client/w3m/ChangeLog8
-rw-r--r--www-client/w3m/files/w3m-0.5.2-gc72.patch27
-rw-r--r--www-client/w3m/w3m-0.5.2-r3.ebuild121
3 files changed, 155 insertions, 1 deletions
diff --git a/www-client/w3m/ChangeLog b/www-client/w3m/ChangeLog
index c41004429e34..af9f5fb84c5e 100644
--- a/www-client/w3m/ChangeLog
+++ b/www-client/w3m/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/w3m
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/ChangeLog,v 1.49 2009/12/12 21:33:39 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/ChangeLog,v 1.50 2009/12/13 23:25:21 matsuu Exp $
+
+*w3m-0.5.2-r3 (13 Dec 2009)
+
+ 13 Dec 2009; MATSUU Takuto <matsuu@gentoo.org> +w3m-0.5.2-r3.ebuild,
+ +files/w3m-0.5.2-gc72.patch:
+ boehm-gc 7.2 support.
12 Dec 2009; Tiago Cunha <tcunha@gentoo.org> w3m-0.5.2-r2.ebuild:
stable sparc, bug 296051
diff --git a/www-client/w3m/files/w3m-0.5.2-gc72.patch b/www-client/w3m/files/w3m-0.5.2-gc72.patch
new file mode 100644
index 000000000000..f2df44f06b30
--- /dev/null
+++ b/www-client/w3m/files/w3m-0.5.2-gc72.patch
@@ -0,0 +1,27 @@
+diff -Naurb w3m-0.5.2.orig/main.c w3m-0.5.2/main.c
+--- w3m-0.5.2.orig/main.c 2007-05-31 10:19:50.000000000 +0900
++++ w3m-0.5.2/main.c 2009-11-09 08:20:02.184953443 +0900
+@@ -312,7 +312,11 @@
+ lock = 0;
+ }
+ }
++#if GC_VERSION_MAJOR >= 7 && GC_VERSION_MINOR >= 2
++ else if (orig_GC_warn_proc = GC_get_warn_proc())
++#else
+ else if (orig_GC_warn_proc)
++#endif
+ orig_GC_warn_proc(msg, arg);
+ else
+ fprintf(stderr, msg, (unsigned long)arg);
+@@ -842,7 +846,11 @@
+ mySignal(SIGPIPE, SigPipe);
+ #endif
+
++#if GC_VERSION_MAJOR >= 7 && GC_VERSION_MINOR >= 2
++ GC_set_warn_proc(wrap_GC_warn_proc);
++#else
+ orig_GC_warn_proc = GC_set_warn_proc(wrap_GC_warn_proc);
++#endif
+ err_msg = Strnew();
+ if (load_argc == 0) {
+ /* no URL specified */
diff --git a/www-client/w3m/w3m-0.5.2-r3.ebuild b/www-client/w3m/w3m-0.5.2-r3.ebuild
new file mode 100644
index 000000000000..6edfe5bbd780
--- /dev/null
+++ b/www-client/w3m/w3m-0.5.2-r3.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/w3m/w3m-0.5.2-r3.ebuild,v 1.1 2009/12/13 23:25:21 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Text based WWW browser, supports tables and frames"
+HOMEPAGE="http://w3m.sourceforge.net/"
+SRC_URI="mirror://sourceforge/w3m/${P}.tar.gz"
+
+LICENSE="w3m"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X fbcon gpm gtk imlib lynxkeymap migemo nls nntp ssl unicode xface linguas_ja"
+
+# We cannot build w3m with gtk+2 w/o X because gtk+2 ebuild doesn't
+# allow us to build w/o X, so we have to give up framebuffer w3mimg....
+DEPEND=">=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=dev-libs/boehm-gc-6.2
+ X? ( x11-libs/libXext x11-libs/libXdmcp )
+ gtk? ( >=x11-libs/gtk+-2 )
+ !gtk? ( imlib? ( >=media-libs/imlib2-1.1.0 ) )
+ xface? ( media-libs/compface )
+ gpm? ( >=sys-libs/gpm-1.19.3-r5 )
+ migemo? ( >=app-text/migemo-0.40 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+PROVIDE="virtual/w3m"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ambwidth.patch"
+ # http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html
+ epatch "${FILESDIR}/${P}-form.patch"
+ epatch "${FILESDIR}/${P}-gc72.patch"
+}
+
+src_compile() {
+
+ local myconf migemo_command imagelibval imageval
+
+ if use gtk ; then
+ imagelibval="gtk2"
+ elif use imlib ; then
+ imagelibval="imlib2"
+ fi
+
+ if [ ! -z "${imagelibval}" ] ; then
+ use X && imageval="${imageval}${imageval:+,}x11"
+ use X && use fbcon && imageval="${imageval}${imageval:+,}fb"
+ fi
+
+ if use migemo ; then
+ migemo_command="migemo -t egrep /usr/share/migemo/migemo-dict"
+ else
+ migemo_command="no"
+ fi
+
+ # emacs-w3m doesn't like "--enable-m17n --disable-unicode,"
+ # so we better enable or disable both. Default to enable
+ # m17n and unicode, see bug #47046.
+ if use linguas_ja ; then
+ if use unicode ; then
+ myconf="${myconf} --enable-japanese=U"
+ else
+ myconf="${myconf} --enable-japanese=E"
+ fi
+ elif use unicode ; then
+ myconf="${myconf} --with-charset=UTF-8"
+ else
+ myconf="${myconf} --with-charset=US-ASCII"
+ fi
+
+ # lynxkeymap IUSE flag. bug #49397
+ if use lynxkeymap ; then
+ myconf="${myconf} --enable-keymap=lynx"
+ else
+ myconf="${myconf} --enable-keymap=w3m"
+ fi
+
+ econf \
+ --with-editor=/usr/bin/vi \
+ --with-mailer=/bin/mail \
+ --with-browser=/usr/bin/firefox \
+ --with-termlib=curses \
+ --enable-image=${imageval:-no} \
+ --with-imagelib="${imagelibval:-no}" \
+ --with-migemo="${migemo_command}" \
+ --enable-m17n \
+ --enable-unicode \
+ $(use_enable gpm mouse) \
+ $(use_enable nls) \
+ $(use_enable nntp) \
+ $(use_enable ssl digest-auth) \
+ $(use_with ssl) \
+ $(use_enable xface) \
+ ${myconf} || die
+
+ # parallel make borks, bug #215394.
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200307.month/3944.html
+ insinto /etc/${PN}
+ newins "${FILESDIR}/${PN}.mailcap" mailcap
+
+ insinto /usr/share/${PN}/Bonus
+ doins Bonus/*
+ dodoc README NEWS TODO ChangeLog
+ docinto doc-en ; dodoc doc/*
+ if use linguas_ja ; then
+ docinto doc-jp ; dodoc doc-jp/*
+ else
+ rm -rf "${D}"/usr/share/man/ja
+ fi
+}