summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-04 14:52:10 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-04 14:52:10 +0000
commit65fa1743c089269bd72865f6b726b3a479740c0d (patch)
treebf4612ddd035b04484a88e7e2cb1ca2c416bf08b /www-client/surf/surf-9999.ebuild
parentduplicate comment, thanks to Gilles Dartiguelongue for noticing. (diff)
downloadgentoo-2-65fa1743c089269bd72865f6b726b3a479740c0d.tar.gz
gentoo-2-65fa1743c089269bd72865f6b726b3a479740c0d.tar.bz2
gentoo-2-65fa1743c089269bd72865f6b726b3a479740c0d.zip
Sync 0.6-r1 changes. Clean up 0.6-r1 some more.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/surf/surf-9999.ebuild')
-rw-r--r--www-client/surf/surf-9999.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index 3dbb5b83269e..7bc41252b0fc 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-9999.ebuild,v 1.1 2013/09/12 15:33:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-9999.ebuild,v 1.2 2013/10/04 14:52:10 jer Exp $
EAPI=5
inherit eutils git-2 savedconfig toolchain-funcs
@@ -13,18 +13,22 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-DEPEND="
+COMMON_DEPEND="
dev-libs/glib
net-libs/libsoup
net-libs/webkit-gtk:2
x11-libs/gtk+:2
x11-libs/libX11
"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
RDEPEND="
!sci-chemistry/surf
+ ${COMMON_DEPEND}
x11-apps/xprop
x11-misc/dmenu
- ${DEPEND}
"
pkg_setup() {
@@ -41,20 +45,13 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
epatch_user
- sed -i \
- -e 's|{|(|g;s|}|)|g' \
- -e 's|\t@|\t|g;s|echo|@&|g' \
- -e 's|^LIBS.*|LIBS = $(GTKLIB) -lgthread-2.0|g' \
- -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
- -e 's|^CC.*|CC ?= gcc|g' \
- -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
- config.mk Makefile || die
restore_config config.h
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
+ default
save_config config.h
}