summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-10-02 20:49:39 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-10-02 20:49:39 +0000
commit995dabfb9bfe576753af861e36850c6f19c29d1c (patch)
tree8d15f4568fce7eaf3c23b1b5004e968e92d74d0f /www-client/seamonkey/files
parentDrop DEPRECATED flags, bug #384815; drop old. (diff)
downloadgentoo-2-995dabfb9bfe576753af861e36850c6f19c29d1c.tar.gz
gentoo-2-995dabfb9bfe576753af861e36850c6f19c29d1c.tar.bz2
gentoo-2-995dabfb9bfe576753af861e36850c6f19c29d1c.zip
Revision bump to make use of new patchset. Removed old
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'www-client/seamonkey/files')
-rw-r--r--www-client/seamonkey/files/Copy_xpcshell_only_if_tests_are_enabled.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/www-client/seamonkey/files/Copy_xpcshell_only_if_tests_are_enabled.patch b/www-client/seamonkey/files/Copy_xpcshell_only_if_tests_are_enabled.patch
new file mode 100644
index 000000000000..342f7de80797
--- /dev/null
+++ b/www-client/seamonkey/files/Copy_xpcshell_only_if_tests_are_enabled.patch
@@ -0,0 +1,71 @@
+# HG changeset patch
+# User Takanori MATSUURA <t.matsuu@gmail.com>
+# Date 1311059208 -32400
+# Node ID 6d8318b1709e2259c1077ba1f80374bfc45af9ba
+# Parent 6596041bb85c5106dc474767bc481c6522f926f3
+Bug 672286 - Copy xpcshell.ini only if ENABLE_TESTS is set; r=Standard8
+
+diff --git a/mail/app/Makefile.in b/mail/app/Makefile.in
+--- a/mail/app/Makefile.in
++++ b/mail/app/Makefile.in
+@@ -252,24 +252,27 @@ LIBS += -lphexlib
+ endif
+
+ libs:: $(srcdir)/profile/prefs.js
+ $(INSTALL) $(IFLAGS1) $^ $(DIST)/bin/defaults/profile
+
+ libs:: blocklist.xml
+ $(INSTALL) $(IFLAGS1) $^ $(DIST)/bin
+
++ifdef ENABLE_TESTS
+ # XXX This is a hack to ensure that we get the right xpcshell.ini for our tests
+ # and that we can share the core mozilla-central xpcshell.ini.
+ # mozilla-central does this in testing/xpcshell-tests which means that it is
+ # very hard for anyone to specify anything else.
+ libs::
++ $(NSINSTALL) -D $(MOZDEPTH)/_tests/xpcshell
+ cp $(MOZILLA_SRCDIR)/testing/xpcshell/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell/xpcshell-core.ini
+ $(INSTALL) $(topsrcdir)/mail/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell
+ cp $(topsrcdir)/mail/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell/all-test-dirs.list
++endif
+
+ ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
+
+ AB := $(firstword $(subst -, ,$(AB_CD)))
+
+ APP_NAME = $(MOZ_APP_DISPLAYNAME)
+
+ LOWER_APP_NAME = $(shell echo $(APP_NAME) | tr '[A-Z]' '[a-z]')
+diff --git a/suite/app/Makefile.in b/suite/app/Makefile.in
+--- a/suite/app/Makefile.in
++++ b/suite/app/Makefile.in
+@@ -216,24 +216,27 @@ ifeq ($(OS_ARCH),WINNT)
+ $(PERL) -pe 's/(?<!\r)\n/\r\n/g;' < $(topsrcdir)/suite/installer/license.txt > $(DIST)/bin/license.txt
+ else
+ $(INSTALL) $(topsrcdir)/suite/installer/license.txt $(DIST)/bin/
+ endif
+
+ libs:: blocklist.xml
+ $(INSTALL) $(IFLAGS1) $^ $(DIST)/bin
+
++ifdef ENABLE_TESTS
+ # XXX This is a hack to ensure that we get the right xpcshell.ini for our tests
+ # and that we can share the core mozilla-central xpcshell.ini.
+ # mozilla-central does this in testing/xpcshell-tests which means that it is
+ # very hard for anyone to specify anything else.
+ libs::
++ $(NSINSTALL) -D $(MOZDEPTH)/_tests/xpcshell
+ cp $(MOZILLA_SRCDIR)/testing/xpcshell/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell/xpcshell-core.ini
+ $(INSTALL) $(topsrcdir)/suite/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell
+ cp $(topsrcdir)/suite/test/xpcshell.ini $(MOZDEPTH)/_tests/xpcshell/all-test-dirs.list
++endif
+
+ ifdef MOZ_OMNIJAR
+ # Make extensions end up as XPIs instead of flat chrome when doing omni.jar.
+ # APP_EXTENSIONS exist only bundled with the application,
+ # PROFILE_EXTENSIONS will be copied to the profile in installed builds.
+ # NOTE: This is a hack to run this at the end of compilation, would be nicer
+ # if this was done right away for built-in extensions in omnijar mode.
+ # Listed extension GUIDs:
+
+