summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-03 21:46:26 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-03 21:46:26 +0000
commite766a352c70024ace18e84976a7c49c2f18c51e4 (patch)
tree27ca05e6cb1db2d1c04d4722e91c4cd76a735f37 /www-client/seamonkey-bin
parentVersion bump wrt #200909 (diff)
downloadgentoo-2-e766a352c70024ace18e84976a7c49c2f18c51e4.tar.gz
gentoo-2-e766a352c70024ace18e84976a7c49c2f18c51e4.tar.bz2
gentoo-2-e766a352c70024ace18e84976a7c49c2f18c51e4.zip
Version bump wrt #200909
(Portage version: 2.1.3.19)
Diffstat (limited to 'www-client/seamonkey-bin')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.73
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.7.ebuild71
3 files changed, 81 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 21c75e8cdafd..74d2d679bd40 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.33 2007/11/12 21:24:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.34 2007/12/03 21:46:26 armin76 Exp $
+
+*seamonkey-bin-1.1.7 (03 Dec 2007)
+
+ 03 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-1.1.7.ebuild:
+ Version bump wrt #200909
12 Nov 2007; Raúl Porcel <armin76@gentoo.org>
-seamonkey-bin-1.1.4.ebuild, -seamonkey-bin-1.1.5.ebuild:
diff --git a/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.7 b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.7
new file mode 100644
index 000000000000..d7955529413d
--- /dev/null
+++ b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.7
@@ -0,0 +1,3 @@
+MD5 3be35b6eb3a292d45a9fce10d5521fb8 seamonkey-1.1.7.en-US.linux-i686.tar.gz 14802665
+RMD160 f3b3417674969bfba18f3447742bd641d03489bf seamonkey-1.1.7.en-US.linux-i686.tar.gz 14802665
+SHA256 41e3032b01c90584dc3e4aa93806650044ce0ab0a7915e8836509c14fc2253c8 seamonkey-1.1.7.en-US.linux-i686.tar.gz 14802665
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.7.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.7.ebuild
new file mode 100644
index 000000000000..bcc10af365b0
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.7.ebuild,v 1.1 2007/12/03 21:46:26 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/seamonkey/"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.56"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon ${FILESDIR}/icon/${PN}.png
+ domenu ${FILESDIR}/icon/${PN}.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}