summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-17 23:17:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-17 23:17:49 +0000
commitc0d468b0641bbf2835872407c7c7e817af4421f2 (patch)
tree7ad799c4d86ce7c4550ae5a228d2c5d852d45219 /www-client/epiphany-extensions
parentSecurity update, bug #210317 (diff)
downloadgentoo-2-c0d468b0641bbf2835872407c7c7e817af4421f2.tar.gz
gentoo-2-c0d468b0641bbf2835872407c7c7e817af4421f2.tar.bz2
gentoo-2-c0d468b0641bbf2835872407c7c7e817af4421f2.zip
fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-client/epiphany-extensions')
-rw-r--r--www-client/epiphany-extensions/ChangeLog6
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild26
2 files changed, 29 insertions, 3 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index 742fdc3c81e7..e602dc58f9ce 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.71 2008/01/30 14:58:14 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.72 2008/02/17 23:17:49 eva Exp $
+
+ 17 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ epiphany-extensions-2.20.3.ebuild:
+ fix python eclass use, bug #207667
30 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
epiphany-extensions-2.20.3.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild
index 0f78f2d5d30f..52be9f4a9335 100644
--- a/www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild,v 1.2 2008/01/30 14:58:14 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.20.3.ebuild,v 1.3 2008/02/17 23:17:49 eva Exp $
WANT_AUTOMAKE="1.10"
-inherit eutils gnome2 autotools
+inherit eutils gnome2 autotools python versionator
DESCRIPTION="Extensions for the Epiphany web browser"
HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog HACKING NEWS README"
+MY_MAJORV=$(get_version_component_range 1-2)
+
src_unpack() {
gnome2_src_unpack
@@ -42,6 +44,10 @@ src_unpack() {
echo "extensions/epilicious/progress.py" >> po/POTFILES.in
echo "extensions/sessionsaver/ephy-sessionsaver-extension.c" >> po/POTFILES.in
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
AT_M4DIR="m4" eautoreconf
}
@@ -70,3 +76,19 @@ pkg_setup() {
G2CONF="${G2CONF} --with-gecko=firefox"
fi
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/epiphany/${MY_MAJORV}/extensions
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ if use python; then
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/epiphany/${MY_MAJORV}/extensions
+ fi
+}