summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-11 01:45:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-11 01:45:13 +0000
commitd1939bf1f5ee10cd2cc99dde8ca1450148162825 (patch)
tree1c5584306f02263c3529ea7640028bfe4eee3ccc /www-apps
parentThe puppetmasterd is no longer provided by puppet 3.x so there's no need to r... (diff)
downloadgentoo-2-d1939bf1f5ee10cd2cc99dde8ca1450148162825.tar.gz
gentoo-2-d1939bf1f5ee10cd2cc99dde8ca1450148162825.tar.bz2
gentoo-2-d1939bf1f5ee10cd2cc99dde8ca1450148162825.zip
Version bump, bug #426690
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/viewvc/ChangeLog8
-rw-r--r--www-apps/viewvc/viewvc-1.1.17.ebuild118
2 files changed, 124 insertions, 2 deletions
diff --git a/www-apps/viewvc/ChangeLog b/www-apps/viewvc/ChangeLog
index b4467738be38..2ea2a512b8ba 100644
--- a/www-apps/viewvc/ChangeLog
+++ b/www-apps/viewvc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/viewvc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.85 2012/06/07 13:12:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.86 2012/11/11 01:45:13 blueness Exp $
+
+*viewvc-1.1.17 (11 Nov 2012)
+
+ 11 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +viewvc-1.1.17.ebuild:
+ Version bump, bug #426690
07 Jun 2012; Tomáš Chvátal <scarabeus@gentoo.org> -viewvc-1.1.11.ebuild,
-viewvc-1.1.12-r1.ebuild:
@@ -331,4 +336,3 @@
+viewvc-1.0.3.ebuild:
Version bump from www-apps/viewcvs. Fixes bugs #107033, #108367, #110020,
#111767, #113767, #114487, #116504, #129395, #136552, #142377, 155144.
-
diff --git a/www-apps/viewvc/viewvc-1.1.17.ebuild b/www-apps/viewvc/viewvc-1.1.17.ebuild
new file mode 100644
index 000000000000..9a2ac8d20394
--- /dev/null
+++ b/www-apps/viewvc/viewvc-1.1.17.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.17.ebuild,v 1.1 2012/11/11 01:45:13 blueness Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit confutils eutils python webapp
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
+HOMEPAGE="http://viewvc.org/"
+DOWNLOAD_NUMBER="49243"
+SRC_URI="http://viewvc.tigris.org/files/documents/3330/${DOWNLOAD_NUMBER}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cvs cvsgraph mod_python mod_wsgi mysql pygments +subversion"
+
+DEPEND=""
+RDEPEND="
+ cvs? ( dev-vcs/rcs )
+ subversion? ( >=dev-vcs/subversion-1.3.1[python] )
+
+ mod_python? ( www-apache/mod_python )
+ mod_wsgi? ( www-apache/mod_wsgi )
+ !mod_python? ( !mod_wsgi? ( virtual/httpd-cgi ) )
+
+ cvsgraph? ( >=dev-vcs/cvsgraph-1.5.0 )
+ mysql? ( >=dev-python/mysql-python-0.9.0 )
+ pygments? (
+ dev-python/pygments
+ app-misc/mime-types
+ )
+"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+
+ confutils_require_any cvs subversion
+}
+
+src_prepare() {
+ find bin/ -type f -print0 | xargs -0 sed -i \
+ -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir -f)/${PN}\"|g" \
+ -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
+
+ sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
+ lib/config.py
+
+ sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
+ sed -i -e "s|^#mime_types_files =.*|mime_types_files = /etc/mime.types|" conf/viewvc.conf.dist
+ mv conf/viewvc.conf{.dist,}
+ mv conf/cvsgraph.conf{.dist,}
+
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ webapp_src_preinst
+
+ newbin bin/standalone.py viewvc-standalone-server || die "newbin failed"
+
+ dodoc CHANGES COMMITTERS INSTALL README || die "dodoc failed"
+
+ installation() {
+ insinto $(python_get_sitedir)/${PN}
+ doins -r lib/*
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r templates/ || die "doins failed"
+ doins -r templates-contrib/ || die "doins failed"
+
+ if use mysql; then
+ exeinto "${MY_HOSTROOTDIR}/bin"
+ doexe bin/{*dbadmin,make-database,loginfo-handler} || die "doexe failed"
+ fi
+
+ insinto "${MY_HOSTROOTDIR}/conf"
+ doins conf/{viewvc,cvsgraph}.conf
+
+ if use mod_python; then
+ insinto "${MY_HTDOCSDIR}"
+ doins bin/mod_python/viewvc.py || die "doins failed"
+ doins bin/mod_python/handler.py || die "doins failed"
+ doins bin/mod_python/.htaccess || die "doins failed"
+ if use mysql; then
+ doins bin/mod_python/query.py || die "doins failed"
+ fi
+ else
+ exeinto "${MY_CGIBINDIR}"
+ doexe bin/cgi/viewvc.cgi || die "doexe failed"
+ if use mysql; then
+ doexe bin/cgi/query.cgi || die "doexe failed"
+ fi
+ fi
+
+ webapp_configfile "${MY_HOSTROOTDIR}/conf/"{viewvc,cvsgraph}.conf
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize viewvc
+ webapp_pkg_postinst
+ elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup viewvc
+}