summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-02 22:13:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-02 22:13:04 +0000
commitc34a4f9bef66c62245b2bf03a7f125d0c6e29334 (patch)
tree516aaa77a0dc0693a0de75d3f99bbf11927b1735 /www-apps
parentRemove useless blank line. (diff)
downloadgentoo-2-c34a4f9bef66c62245b2bf03a7f125d0c6e29334.tar.gz
gentoo-2-c34a4f9bef66c62245b2bf03a7f125d0c6e29334.tar.bz2
gentoo-2-c34a4f9bef66c62245b2bf03a7f125d0c6e29334.zip
Version bump (bug #290824). Set SUPPORT_PYTHON_ABIS.
(Portage version: 15156-svn/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/roundup/ChangeLog10
-rw-r--r--www-apps/roundup/roundup-1.4.11.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/www-apps/roundup/ChangeLog b/www-apps/roundup/ChangeLog
index f291804e2148..cd63abe1142b 100644
--- a/www-apps/roundup/ChangeLog
+++ b/www-apps/roundup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/roundup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.34 2009/09/27 10:46:13 a3li Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.35 2010/01/02 22:13:04 arfrever Exp $
+
+*roundup-1.4.11 (02 Jan 2010)
+
+ 02 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +roundup-1.4.11.ebuild:
+ Version bump (bug #290824). Set SUPPORT_PYTHON_ABIS.
27 Sep 2009; Alex Legler <a3li@gentoo.org> roundup-1.4.4-r1.ebuild,
roundup-1.4.6.ebuild, roundup-1.4.8.ebuild, roundup-1.4.8-r1.ebuild:
diff --git a/www-apps/roundup/roundup-1.4.11.ebuild b/www-apps/roundup/roundup-1.4.11.ebuild
new file mode 100644
index 000000000000..6c058ba11f74
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-1.4.11.ebuild,v 1.1 2010/01/02 22:13:04 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_install() {
+ distutils_src_install
+ dodoc CHANGES.txt doc/*.txt
+ dohtml doc/*.html
+ dobin "${FILESDIR}/roundup" || die "dobin failed"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.py file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}