summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-03-14 02:10:01 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-03-14 02:10:01 +0000
commit3092b16113f5f9fe776491a20f5fe69088007d0d (patch)
tree4e3d3ed7a111c1b6429f9b11dbd9714376ea2e01 /www-apps
parentBeta channel bump. (diff)
downloadgentoo-2-3092b16113f5f9fe776491a20f5fe69088007d0d.tar.gz
gentoo-2-3092b16113f5f9fe776491a20f5fe69088007d0d.tar.bz2
gentoo-2-3092b16113f5f9fe776491a20f5fe69088007d0d.zip
Version bump, bug #421761
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gallery/ChangeLog8
-rw-r--r--www-apps/gallery/files/postinstall-en.txt24
-rw-r--r--www-apps/gallery/files/postupgrade-en.txt19
-rw-r--r--www-apps/gallery/gallery-3.0.5.ebuild86
4 files changed, 136 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index f7a86d907264..79426f5010e5 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/gallery
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.189 2013/01/23 17:12:01 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.190 2013/03/14 02:10:01 blueness Exp $
+
+*gallery-3.0.5 (14 Mar 2013)
+
+ 14 Mar 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/postinstall-en.txt, +files/postupgrade-en.txt, +gallery-3.0.5.ebuild:
+ Version bump, bug #421761
23 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> gallery-2.3.1.ebuild:
Change homepage, wrt bug #421761
diff --git a/www-apps/gallery/files/postinstall-en.txt b/www-apps/gallery/files/postinstall-en.txt
new file mode 100644
index 000000000000..45a45bf9752f
--- /dev/null
+++ b/www-apps/gallery/files/postinstall-en.txt
@@ -0,0 +1,24 @@
+For new installations:
+
+1. Install the webapp using
+
+ webapp-config -I -h <VHOST_HOSTNAME> -d <VHOST_APPDIR> gallery X.Y.Z
+
+where either the VHOST_HOSTNAME or VHOST_APPDIR are optional and X.Y.Z
+is the version of gallery you just emerged.
+
+2. Create a mysql database for Gallery 3.
+
+ mysqladmin -u root -p create gallery3
+ mysql gallery3 -u root -p -e \
+ "GRANT ALL ON gallery3.* TO username@localhost IDENTIFIED BY 'password'"
+
+3. Now browse to http://<VHOST_HOSTNAME>/<VHOST_APPDIR>/install. Make sure
+the database name, user and password match what you created in step 2.
+
+4. Enjoy!
+
+
+The Gallery 3 user's guide can be found at
+
+ http://codex.galleryproject.org/Gallery3:User_guide:Gallery3:Installing_and_upgrading#Upgrading
diff --git a/www-apps/gallery/files/postupgrade-en.txt b/www-apps/gallery/files/postupgrade-en.txt
new file mode 100644
index 000000000000..4721021a195a
--- /dev/null
+++ b/www-apps/gallery/files/postupgrade-en.txt
@@ -0,0 +1,19 @@
+To upgreade:
+
+1. Upgrade the webapp using
+
+ webapp-config -U -h <VHOST_HOSTNAME> -d <VHOST_APPDIR> gallery X.Y.Z
+
+2. Direct your browser to
+
+ http://<VHOST_HOSTNAME>/<VHOST_APPDIR>/index.php/upgrader
+
+or alternatively, at a shell prompt, run
+
+ php index.php upgrade
+
+3. Enjoy!
+
+The Gallery 3 user's guide can be found at
+
+ http://codex.galleryproject.org/Gallery3:User_guide:Gallery3:Installing_and_upgrading#Upgrading
diff --git a/www-apps/gallery/gallery-3.0.5.ebuild b/www-apps/gallery/gallery-3.0.5.ebuild
new file mode 100644
index 000000000000..73e229aeda63
--- /dev/null
+++ b/www-apps/gallery/gallery-3.0.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-3.0.5.ebuild,v 1.1 2013/03/14 02:10:01 blueness Exp $
+
+EAPI="5"
+
+inherit webapp
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.menalto.com/"
+SRC_URI="mirror://sourceforge/gallery/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg +gd imagemagick mysql mysqli"
+
+# Build depend is on unzip
+DEPEND="app-arch/unzip"
+
+#PHP flags
+PHP_REQUIRED_FLAGS="ctype,filter,iconv,json,simplexml,tokenizer,unicode"
+PHP_OPTIONAL_FLAGS="gd?,mysql?,mysqli?"
+
+# No forced dependency on
+# mysql? ( virtual/mysql )
+# which may live on another server
+RDEPEND="
+ imagemagick? ( || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ ) )
+ ffmpeg? ( virtual/ffmpeg )
+ >=dev-lang/php-5.2.3[${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}]
+ virtual/httpd-php"
+
+REQUIRED_USE="
+ || ( gd imagemagick )
+ || ( mysql mysqli )"
+
+S="${WORKDIR}/${PN}3"
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ keepdir "${MY_HTDOCSDIR}"/var
+ webapp_serverowned "${MY_HTDOCSDIR}"/var
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "\033[1;33m**************************************************\033[00m"
+ ewarn
+ ewarn "gallery3 requires short_open_tag to be enabled."
+ ewarn "You need to edit \"/etc/php/apache2-php5.?/php.ini\","
+ ewarn "set short_open_tag to \"On\" and then restart apache."
+ ewarn
+ ewarn "This ebuild does not depend on mysql or mariadb,"
+ ewarn "because the database may run on different host. But"
+ ewarn "you will need to run a database server somewhere."
+ ewarn
+ ewarn "\033[1;33m**************************************************\033[00m"
+ ewarn
+
+ einfo
+ einfo "\033[1;32m**************************************************\033[00m"
+ einfo
+ einfo "To see the post install instructions, do"
+ einfo
+ einfo " webapp-config --show-postinst ${PN} ${PVR}"
+ einfo
+ einfo "or for the post upgrade instructions, do"
+ einfo
+ einfo " webapp-config --show-postupgrade ${PN} ${PVR}"
+ einfo
+ einfo "\033[1;32m**************************************************\033[00m"
+ einfo
+}