summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-09 21:43:08 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-09 21:43:08 +0000
commit0996782330f6e5a59b3863da34a2b145072cfbc1 (patch)
treeba61f58fdbf02c1e2ec20df7299c903563f9e089 /www-apps
parentalpha/sparc/x86 stable wrt #249960 (diff)
downloadgentoo-2-0996782330f6e5a59b3863da34a2b145072cfbc1.tar.gz
gentoo-2-0996782330f6e5a59b3863da34a2b145072cfbc1.tar.bz2
gentoo-2-0996782330f6e5a59b3863da34a2b145072cfbc1.zip
Version bump.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.6.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 3e3fb5734808..c9c2e0b5e9b6 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.76 2008/11/28 14:47:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.77 2008/12/09 21:43:08 pva Exp $
+
+*mantisbt-1.1.6 (09 Dec 2008)
+
+ 09 Dec 2008; Peter Volkov <pva@gentoo.org> +mantisbt-1.1.6.ebuild:
+ Version bump.
*mantisbt-1.1.5 (28 Nov 2008)
diff --git a/www-apps/mantisbt/mantisbt-1.1.6.ebuild b/www-apps/mantisbt/mantisbt-1.1.6.ebuild
new file mode 100644
index 000000000000..6b6c1d986897
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.6.ebuild,v 1.1 2008/12/09 21:43:08 pva Exp $
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ dev-php/adodb"
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use pcre
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -r "${S}/core/adodb/" # We use external adodb
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/*
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}/config_inc.php"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ elog "Note, that this branch of mantisbt does not work with PostgreSQL."
+ elog "If really need mantisbt to work with PostgreSQL you'll have to"
+ elog "install it manually from upstream svn repository:"
+ elog "https://sourceforge.net/svn/?group_id=14963"
+}