summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-04 08:38:19 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-04 08:38:19 +0000
commit2c2d1b9538ced781b5bb41edb347b6b94523123b (patch)
treeb697064021a7a14111c9c60cda97f3b4b06295f0 /www-apps/xoops
parentmerge from webapps overlay wrt #208584 (diff)
downloadgentoo-2-2c2d1b9538ced781b5bb41edb347b6b94523123b.tar.gz
gentoo-2-2c2d1b9538ced781b5bb41edb347b6b94523123b.tar.bz2
gentoo-2-2c2d1b9538ced781b5bb41edb347b6b94523123b.zip
merge from webapps overlay wrt #208584
(Portage version: 2.1.4)
Diffstat (limited to 'www-apps/xoops')
-rw-r--r--www-apps/xoops/ChangeLog10
-rw-r--r--www-apps/xoops/xoops-2.2.4.ebuild33
2 files changed, 31 insertions, 12 deletions
diff --git a/www-apps/xoops/ChangeLog b/www-apps/xoops/ChangeLog
index a9a7f1b016d5..aa69a82c593b 100644
--- a/www-apps/xoops/ChangeLog
+++ b/www-apps/xoops/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/xoops
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/xoops/ChangeLog,v 1.16 2007/07/29 17:42:53 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/xoops/ChangeLog,v 1.17 2008/02/04 08:38:19 hollow Exp $
+
+ 04 Feb 2008; Benedikt Böhm <hollow@gentoo.org> xoops-2.2.4.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> xoops-2.2.4.ebuild:
+ Remove apache dependency wrt Bug 208584, check for required PHP features.
29 Jul 2007; Christian Heim <phreak@gentoo.org> xoops-2.2.4.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to
diff --git a/www-apps/xoops/xoops-2.2.4.ebuild b/www-apps/xoops/xoops-2.2.4.ebuild
index dac064365115..83beab37be22 100644
--- a/www-apps/xoops/xoops-2.2.4.ebuild
+++ b/www-apps/xoops/xoops-2.2.4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/xoops/xoops-2.2.4.ebuild,v 1.5 2007/07/29 17:42:53 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/xoops/xoops-2.2.4.ebuild,v 1.6 2008/02/04 08:38:19 hollow Exp $
-inherit webapp
+inherit webapp depend.php
-DESCRIPTION="eXtensible Object Oriented Portal System (xoops) is an open-source Content Management System, including various portal features and supplemental modules."
+DESCRIPTION="eXtensible Object Oriented Portal System (xoops) is an open-source
+Content Management System, including various portal features and supplemental modules."
HOMEPAGE="http://www.xoops.org/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-2.2.3a-Final.tar.gz
mirror://sourceforge/${PN}/xoops-2.2.3a-to-2.2.4.tgz"
@@ -15,28 +16,40 @@ S=${WORKDIR}
IUSE=""
-RDEPEND="virtual/php
- www-servers/apache"
+RDEPEND="virtual/httpd-cgi"
+need_php
+
+pkg_setup() {
+ if ! PHPCHECKNODIE="yes" require_php_with_use mysql || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use apache2 cgi ; then
+ die "Re-install ${PHP_PKG} with mysql and at least one of apache2 or cgi flags."
+ fi
+ webapp_pkg_setup
+}
src_unpack() {
- unpack ${A} && cd ${S}
+ unpack ${A}
+ cd "${S}"
cp -f xoops-2.2.3a-to-2.2.4/docs/* docs/ || die
cp -Rf xoops-2.2.3a-to-2.2.4/html/* html/ || die
}
src_install() {
webapp_src_preinst
+
dodir ${MY_HOSTROOTDIR}/${PF}
dodoc docs/changelog.txt
dohtml docs/INSTALL.html docs/UPDATE.html
- cp -R docs/images ${D}/usr/share/doc/${PF}/html
+ cp -R docs/images "${D}"/usr/share/doc/${PF}/html
cp -pPR html/* "${D}/${MY_HTDOCSDIR}"
- cp -pPR extras/* ${D}/${MY_HOSTROOTDIR}/${PF}
+ cp -pPR extras/* "${D}"/${MY_HOSTROOTDIR}/${PF}
+
webapp_serverowned ${MY_HTDOCSDIR}/uploads
webapp_serverowned ${MY_HTDOCSDIR}/cache
webapp_serverowned ${MY_HTDOCSDIR}/templates_c
webapp_configfile ${MY_HTDOCSDIR}/mainfile.php
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
webapp_src_install
}