summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-02-14 07:43:28 +0000
committerBen de Groot <yngwin@gentoo.org>2013-02-14 07:43:28 +0000
commiteb9f879b908ea47e495b64c1edd0d65a5e3e197c (patch)
treede6bd62784470a32c3d4df2e52d9f906eeda8753 /www-apps/nikola
parentVersion bump (bug 424207) (diff)
downloadgentoo-2-eb9f879b908ea47e495b64c1edd0d65a5e3e197c.tar.gz
gentoo-2-eb9f879b908ea47e495b64c1edd0d65a5e3e197c.tar.bz2
gentoo-2-eb9f879b908ea47e495b64c1edd0d65a5e3e197c.zip
version bump; drop old
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-apps/nikola')
-rw-r--r--www-apps/nikola/ChangeLog8
-rw-r--r--www-apps/nikola/nikola-4.0.1.ebuild35
-rw-r--r--www-apps/nikola/nikola-4.0.3.ebuild35
-rw-r--r--www-apps/nikola/nikola-5.2.ebuild55
4 files changed, 62 insertions, 71 deletions
diff --git a/www-apps/nikola/ChangeLog b/www-apps/nikola/ChangeLog
index 61d1ad9bfd07..93bf0189672d 100644
--- a/www-apps/nikola/ChangeLog
+++ b/www-apps/nikola/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/nikola
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/ChangeLog,v 1.8 2013/02/02 11:17:46 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/ChangeLog,v 1.9 2013/02/14 07:43:28 yngwin Exp $
+
+*nikola-5.2 (14 Feb 2013)
+
+ 14 Feb 2013; Ben de Groot <yngwin@gentoo.org> +nikola-5.2.ebuild,
+ -nikola-4.0.1.ebuild, -nikola-4.0.3.ebuild:
+ version bump; drop old
*nikola-5.1 (02 Feb 2013)
diff --git a/www-apps/nikola/nikola-4.0.1.ebuild b/www-apps/nikola/nikola-4.0.1.ebuild
deleted file mode 100644
index 27e0aa036a37..000000000000
--- a/www-apps/nikola/nikola-4.0.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-4.0.1.ebuild,v 1.2 2012/08/26 17:19:13 yngwin Exp $
-
-EAPI=4
-PYTHON_COMPAT="python2_6 python2_7"
-
-inherit python-distutils-ng
-
-DESCRIPTION="A static website and blog generator"
-HOMEPAGE="http://nikola.ralsina.com.ar/"
-SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-python/docutils
- dev-python/doit
- dev-python/imaging
- dev-python/lxml
- >=dev-python/mako-0.6
- dev-python/pygments
- dev-python/unidecode"
-
-src_install() {
- python-distutils-ng_src_install
-
- # hackish way to remove docs that ended up in the wrong place
- rm "${D}"/usr/*.txt
-
- dodoc README.md docs/*
-}
diff --git a/www-apps/nikola/nikola-4.0.3.ebuild b/www-apps/nikola/nikola-4.0.3.ebuild
deleted file mode 100644
index 1806903fd3b8..000000000000
--- a/www-apps/nikola/nikola-4.0.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-4.0.3.ebuild,v 1.1 2012/10/02 15:25:31 yngwin Exp $
-
-EAPI=4
-PYTHON_COMPAT="python2_6 python2_7"
-
-inherit python-distutils-ng
-
-DESCRIPTION="A static website and blog generator"
-HOMEPAGE="http://nikola.ralsina.com.ar/"
-SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-python/docutils
- dev-python/doit
- dev-python/imaging
- dev-python/lxml
- >=dev-python/mako-0.6
- dev-python/pygments
- dev-python/unidecode"
-
-src_install() {
- python-distutils-ng_src_install
-
- # hackish way to remove docs that ended up in the wrong place
- rm "${D}"/usr/*.txt
-
- dodoc README.md docs/*
-}
diff --git a/www-apps/nikola/nikola-5.2.ebuild b/www-apps/nikola/nikola-5.2.ebuild
new file mode 100644
index 000000000000..e38a2d231b49
--- /dev/null
+++ b/www-apps/nikola/nikola-5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-5.2.ebuild,v 1.1 2013/02/14 07:43:28 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} ) # 3_2 should be possible now, but untested
+inherit distutils-r1
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://nikola.ralsina.com.ar/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ralsina/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="jinja markdown"
+
+DEPEND="dev-python/docutils" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ =dev-python/configparser-3.2.0*
+ >=dev-python/doit-0.20.0
+ dev-python/imaging
+ dev-python/lxml
+ >=dev-python/mako-0.6
+ >=dev-python/mock-1.0.0
+ dev-python/pygments
+ dev-python/PyRSS2Gen
+ dev-python/requests
+ dev-python/unidecode
+ dev-python/yapsy
+ jinja? ( dev-python/jinja )
+ markdown? ( dev-python/markdown )"
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc AUTHORS.txt CHANGES.txt README.md docs/*.txt
+}
+
+pkg_postinst() {
+ if has_version '<www-apps/nikola-5.0'; then
+ elog 'Nikola has changed quite a lot since the previous major version.'
+ elog 'Please make sure to read the updated documentation.'
+ fi
+}