summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2013-12-01 22:53:59 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2013-12-01 22:53:59 +0000
commit76016bcc969fef22f7a79e32b0d7243d6632beb3 (patch)
treed3b4875c6d49da43626b539b24a72b2a1d52c538 /www-apps/drupal
parentAdd unit file, bug #492698 by Christian Strahl (diff)
downloadgentoo-2-76016bcc969fef22f7a79e32b0d7243d6632beb3.tar.gz
gentoo-2-76016bcc969fef22f7a79e32b0d7243d6632beb3.tar.bz2
gentoo-2-76016bcc969fef22f7a79e32b0d7243d6632beb3.zip
Version bump to 6.29 - bug 491858.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/ChangeLog8
-rw-r--r--www-apps/drupal/drupal-6.29.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/www-apps/drupal/ChangeLog b/www-apps/drupal/ChangeLog
index a539c40b5136..53126d366073 100644
--- a/www-apps/drupal/ChangeLog
+++ b/www-apps/drupal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/drupal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.99 2013/11/29 18:42:01 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.100 2013/12/01 22:53:59 jmbsvicetto Exp $
+
+*drupal-6.29 (01 Dec 2013)
+
+ 01 Dec 2013; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +drupal-6.29.ebuild:
+ Version bump to 6.29 - bug 491858.
*drupal-7.24 (29 Nov 2013)
diff --git a/www-apps/drupal/drupal-6.29.ebuild b/www-apps/drupal/drupal-6.29.ebuild
new file mode 100644
index 000000000000..f6aee4c2dc9c
--- /dev/null
+++ b/www-apps/drupal/drupal-6.29.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-6.29.ebuild,v 1.1 2013/12/01 22:53:59 jmbsvicetto Exp $
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+mysql postgres"
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[gd,pdo,postgres?,xml]
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt
+
+ cp sites/default/{default.settings.php,settings.php}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ ewarn
+}