summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-09-18 12:05:30 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-09-18 12:05:30 +0000
commitbda7c8532194e9f1a3321258d41fcbd6a2268a25 (patch)
treed7a4f5ff4d9c7251acc4a3e51ca9e59b1a8089a2 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-bda7c8532194e9f1a3321258d41fcbd6a2268a25.tar.gz
gentoo-2-bda7c8532194e9f1a3321258d41fcbd6a2268a25.tar.bz2
gentoo-2-bda7c8532194e9f1a3321258d41fcbd6a2268a25.zip
version bump
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_nufw/ChangeLog8
-rw-r--r--www-apache/mod_auth_nufw/mod_auth_nufw-2.2.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/www-apache/mod_auth_nufw/ChangeLog b/www-apache/mod_auth_nufw/ChangeLog
index d0a935abe606..3fec13988954 100644
--- a/www-apache/mod_auth_nufw/ChangeLog
+++ b/www-apache/mod_auth_nufw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_auth_nufw
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.8 2009/07/05 18:42:59 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/ChangeLog,v 1.9 2009/09/18 12:05:30 hollow Exp $
+
+*mod_auth_nufw-2.2.2 (18 Sep 2009)
+
+ 18 Sep 2009; Benedikt Böhm <hollow@gentoo.org>
+ +mod_auth_nufw-2.2.2.ebuild:
+ version bump
05 Jul 2009; Benedikt Böhm <hollow@gentoo.org>
-files/mod_auth_nufw-2.2.0-configure_in.patch,
diff --git a/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.2.ebuild b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.2.ebuild
new file mode 100644
index 000000000000..70fbea2c9688
--- /dev/null
+++ b/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_nufw/mod_auth_nufw-2.2.2.ebuild,v 1.1 2009/09/18 12:05:30 hollow Exp $
+
+EAPI="2"
+
+inherit autotools confutils apache-module
+
+DESCRIPTION="A NuFW authentication module for Apache."
+HOMEPAGE="http://software.inl.fr/trac/wiki/EdenWall/mod_auth_nufw"
+SRC_URI="http://software.inl.fr/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_FILE="mod_auth_nufw.so"
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="AUTH_NUFW"
+
+DOCFILES="doc/mod_auth_nufw.html"
+
+need_apache2_2
+
+pkg_setup() {
+ confutils_require_one mysql postgres
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) ${CPPFLAGS}" \
+ econf \
+ --with-apache22 \
+ $(use_with mysql) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}