summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-05-13 13:31:43 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-05-13 13:31:43 +0000
commit54f2498d898f88733ac1207dd60d9e149e4a3b90 (patch)
treecba3d0dcf0710bb68a863d7fa2cfc4ed52968084 /www-apache
parentSupport sys-devel/automake:1.13 by replacing obsolete macro. Fixes bug #469322. (diff)
downloadgentoo-2-54f2498d898f88733ac1207dd60d9e149e4a3b90.tar.gz
gentoo-2-54f2498d898f88733ac1207dd60d9e149e4a3b90.tar.bz2
gentoo-2-54f2498d898f88733ac1207dd60d9e149e4a3b90.zip
Conditionally apply 2.4 compatibility patch to avoid build failures against 2.2; with thanks to Agostino "ago" Sarubbo for implementation suggestion.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_radius/ChangeLog6
-rw-r--r--www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild16
2 files changed, 14 insertions, 8 deletions
diff --git a/www-apache/mod_auth_radius/ChangeLog b/www-apache/mod_auth_radius/ChangeLog
index 816153e71963..d430212419d7 100644
--- a/www-apache/mod_auth_radius/ChangeLog
+++ b/www-apache/mod_auth_radius/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_auth_radius
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_radius/ChangeLog,v 1.1 2013/05/08 13:52:15 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_radius/ChangeLog,v 1.2 2013/05/13 13:31:43 chainsaw Exp $
+
+ 13 May 2013; Tony Vroon <chainsaw@gentoo.org> mod_auth_radius-1.5.8.ebuild:
+ Conditionally apply 2.4 compatibility patch to avoid build failures against
+ 2.2; with thanks to Agostino "ago" Sarubbo for implementation suggestion.
*mod_auth_radius-1.5.8 (08 May 2013)
diff --git a/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild b/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
index 8783784e4046..a95b054750c1 100644
--- a/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
+++ b/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild,v 1.1 2013/05/08 13:52:15 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild,v 1.2 2013/05/13 13:31:43 chainsaw Exp $
EAPI="5"
-inherit apache-module base
+inherit apache-module eutils
DESCRIPTION="Radius authentication for Apache."
HOMEPAGE="http://freeradius.org/mod_auth_radius/"
@@ -20,15 +20,17 @@ APACHE2_MOD_DEFINE="AUTH_RADIUS"
APXS2_ARGS="-c ${PN}-2.0.c"
-PATCHES=(
- "${FILESDIR}/${PV}-includes.patch"
- "${FILESDIR}/${PV}-remote_ip-obsolete.patch"
-)
-
DOCFILES="README"
need_apache2
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-includes.patch"
+ if has_version ">=www-servers/apache-2.4"; then
+ epatch "${FILESDIR}/${PV}-remote_ip-obsolete.patch"
+ fi
+}
+
src_compile() {
apache-module_src_compile
}