summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-07-01 05:57:50 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-07-01 05:57:50 +0000
commit44859d69e833e11dabe039222b591c908cc642a3 (patch)
tree785db104ebea19bc9e0677a3553e6efbe9a6c007 /www-apache
parentRemoved www-misc/zoneminder-1.22.0 (diff)
downloadgentoo-2-44859d69e833e11dabe039222b591c908cc642a3.tar.gz
gentoo-2-44859d69e833e11dabe039222b591c908cc642a3.tar.bz2
gentoo-2-44859d69e833e11dabe039222b591c908cc642a3.zip
Version bump (bug #138576).
(Portage version: 2.1)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_survey/ChangeLog8
-rw-r--r--www-apache/mod_survey/files/digest-mod_survey-3.2.46
-rw-r--r--www-apache/mod_survey/mod_survey-3.2.4.ebuild101
3 files changed, 114 insertions, 1 deletions
diff --git a/www-apache/mod_survey/ChangeLog b/www-apache/mod_survey/ChangeLog
index 0ae1a22e1756..dc3d466e790f 100644
--- a/www-apache/mod_survey/ChangeLog
+++ b/www-apache/mod_survey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_survey
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_survey/ChangeLog,v 1.12 2006/01/31 22:06:14 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_survey/ChangeLog,v 1.13 2006/07/01 05:57:50 rl03 Exp $
+
+*mod_survey-3.2.4 (01 Jul 2006)
+
+ 01 Jul 2006; Renat Lumpau <rl03@gentoo.org> -mod_survey-3.2.3-r2.ebuild,
+ +mod_survey-3.2.4.ebuild:
+ Version bump (bug #138576).
*mod_survey-3.2.3-r2 (31 Jan 2006)
diff --git a/www-apache/mod_survey/files/digest-mod_survey-3.2.4 b/www-apache/mod_survey/files/digest-mod_survey-3.2.4
new file mode 100644
index 000000000000..37a4d21734d5
--- /dev/null
+++ b/www-apache/mod_survey/files/digest-mod_survey-3.2.4
@@ -0,0 +1,6 @@
+MD5 1b060199cc6ffb4d3b4785410e7fa825 modsurvey-3.2.4.tgz 496604
+RMD160 46027f08ddcb581dceb52121c1c37b177d6fde24 modsurvey-3.2.4.tgz 496604
+SHA256 6130501fb6f39817fe842a613f9b2770519c59fed060b16447f1d75345aa14af modsurvey-3.2.4.tgz 496604
+MD5 22539cf7493c5d362d2f7a2384b9a641 modsurvey-docs-3.2.4.tgz 678356
+RMD160 507b89416cc1f39cc19d90c3f795191c8ca7a4b6 modsurvey-docs-3.2.4.tgz 678356
+SHA256 53c0e0d4335ded221c30fa52c4202793b86aef370d7b92341fb4fcaac12c1fd6 modsurvey-docs-3.2.4.tgz 678356
diff --git a/www-apache/mod_survey/mod_survey-3.2.4.ebuild b/www-apache/mod_survey/mod_survey-3.2.4.ebuild
new file mode 100644
index 000000000000..6e62e35d80f0
--- /dev/null
+++ b/www-apache/mod_survey/mod_survey-3.2.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_survey/mod_survey-3.2.4.ebuild,v 1.1 2006/07/01 05:57:50 rl03 Exp $
+
+inherit webapp
+
+WEBAPP_MANUAL_SLOT="yes"
+SLOT="0"
+
+DESCRIPTION="XML-defined web questionnaires as a plug-in module for Apache"
+HOMEPAGE="http://www.modsurvey.org"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE="apache2 doc mysql nls postgres"
+MY_PN=${PN/_/}
+MY_PV=${PV/_/-}
+S=${WORKDIR}/${PN}
+SRC_URI="http://www.modsurvey.org/download/tarballs/${MY_PN}-${MY_PV}.tgz
+doc? ( http://www.modsurvey.org/download/tarballs/${MY_PN}-docs-${MY_PV}.tgz )"
+
+DEPEND=">=dev-lang/perl-5.6.1"
+RDEPEND="${DEPEND}
+ apache2? ( >=net-www/apache-2 >=www-apache/mod_perl-1.99 )
+ !apache2? ( >=net-www/apache-1 <www-apache/mod_perl-1.99 )
+ postgres? ( >=dev-perl/DBI-1.38 dev-perl/DBD-Pg )
+ mysql? ( >=dev-perl/DBI-1.38 dev-perl/DBD-mysql )
+ >=perl-core/CGI-3.0.0"
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ # stolen from app-admin/webalizer
+ # USE=nls has no real meaning if LINGUAS isn't set
+ if use nls && [ -z "${LINGUAS}" ]; then
+ ewarn "you must set LINGUAS in /etc/make.conf"
+ ewarn "if you want to USE=nls"
+ die "please either set LINGUAS or do not use nls"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -f docs/LICENSE.txt
+ sed -i "s|/usr/local/mod_survey/|${D}/usr/lib/mod_survey/|g" installer.pl
+ use doc && unpack ${MY_PN}-docs-${PV}.tgz
+
+ # unfortunatly, this program only allows for one lang, so only the first
+ # entry in LINGUAS is used
+ if use nls; then
+ local locallang
+ if ! grep -q ${LINGUAS:0:2} ${FILESDIR}/language-list.txt; then
+ ewarn "Language ${LINGUAS:0:2} is not supported, using English"
+ else
+ einfo "Using language ${LINGUAS:0:2}"
+ locallang="$(grep ^${LINGUAS:0:2} ${FILESDIR}/language-list.txt)"
+ sed "s|\$lang = \"en\"|\$lang = \"${locallang}\"|" -i installer.pl
+ fi
+ fi
+
+ if ! use apache2; then
+ sed "s|\$isa2 = \"Off\"|\$isa2 = \"On\"|" -i installer.pl
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodir /usr/lib/mod_survey
+ dodir /var/lib/mod_survey/data
+ dodir ${MY_HOSTROOTDIR}/${PN}
+
+ dodoc README.txt docs/*
+
+ perl installer.pl < /dev/null > /dev/null 2>&1
+ dosed /usr/lib/mod_survey/survey.conf
+ sed -i "s|/usr/lib/mod_survey/data/|/var/lib/mod_survey/data/|" ${D}/usr/lib/mod_survey/survey.conf
+ mv ${D}/usr/lib/mod_survey/survey.conf ${D}/${MY_HOSTROOTDIR}/${PN}
+
+ rm -rf ${D}/usr/lib/mod_survey/webroot ${D}/usr/lib/mod_survey/data
+ cp -R webroot/* ${D}/${MY_HTDOCSDIR}
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_src_install
+ fowners apache:apache /var/lib/mod_survey/data
+}
+
+pkg_postinst(){
+ if [ ${#LINGUAS} -gt 2 ] && use nls; then
+ ewarn
+ ewarn "You have more than one language in LINGUAS"
+ ewarn "Due to the limitations of this package, it was built"
+ ewarn "only with ${LINGUAS:0:2} support. If this is not what"
+ ewarn "you intended, please place the language you desire"
+ ewarn "_first_ in the list of LINGUAS in /etc/make.conf"
+ ewarn
+ fi
+ webapp_pkg_postinst
+}