summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 21:58:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 21:58:50 +0000
commit60b46fa08f299470edf1ca0240898fae38830912 (patch)
tree883d42e784efa5b96be1c55e80f651aa10fe00a9 /www-apache/mod_security
parentVersion bump. (diff)
downloadgentoo-2-60b46fa08f299470edf1ca0240898fae38830912.tar.gz
gentoo-2-60b46fa08f299470edf1ca0240898fae38830912.tar.bz2
gentoo-2-60b46fa08f299470edf1ca0240898fae38830912.zip
Version bump.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_security')
-rw-r--r--www-apache/mod_security/ChangeLog8
-rw-r--r--www-apache/mod_security/mod_security-2.5.13.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index 753e0878ae3f..a7c206fea009 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_security
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.46 2010/10/24 17:45:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.47 2010/12/01 21:58:50 flameeyes Exp $
+
+*mod_security-2.5.13 (01 Dec 2010)
+
+ 01 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +mod_security-2.5.13.ebuild:
+ Version bump.
24 Oct 2010; Raúl Porcel <armin76@gentoo.org>
mod_security-2.5.12-r1.ebuild:
diff --git a/www-apache/mod_security/mod_security-2.5.13.ebuild b/www-apache/mod_security/mod_security-2.5.13.ebuild
new file mode 100644
index 000000000000..b1564dd65713
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.5.13.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.5.13.ebuild,v 1.1 2010/12/01 21:58:50 flameeyes Exp $
+
+EAPI=2
+
+inherit apache-module autotools
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+MY_P=${MY_P/_rc/-rc}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="lua"
+
+DEPEND="dev-libs/libxml2
+ lua? ( >=dev-lang/lua-5.1 )
+ www-servers/apache[apache2_modules_unique_id]"
+RDEPEND="${DEPEND}"
+PDEPEND="www-apache/modsecurity-crs"
+
+S="${WORKDIR}/${MY_P}"
+
+APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
+APACHE2_MOD_CONF="2.5.10/99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.5.10-as-needed.patch
+
+ cd apache2
+ eautoreconf
+}
+
+src_configure() {
+ cd apache2
+
+ econf --with-apxs="${APXS}" \
+ --without-curl \
+ $(use_with lua) \
+ || die "econf failed"
+}
+
+src_compile() {
+ cd apache2
+
+ APXS_FLAGS=
+ for flag in ${CFLAGS}; do
+ APXS_FLAGS="${APXS_FLAGS} -Wc,${flag}"
+ done
+
+ # Yes we need to prefix it _twice_
+ for flag in ${LDFLAGS}; do
+ APXS_FLAGS="${APXS_FLAGS} -Wl,${flag}"
+ done
+
+ emake \
+ APXS_CFLAGS="${CFLAGS}" \
+ APXS_LDFLAGS="${LDFLAGS}" \
+ APXS_EXTRA_CFLAGS="${APXS_FLAGS}" \
+ || die "emake failed"
+}
+
+src_test() {
+ cd apache2
+ emake test || die
+}
+
+src_install() {
+ apache-module_src_install
+
+ # install documentation
+ dodoc CHANGES || die
+ dohtml -r doc/* || die
+
+ keepdir /var/cache/mod_security || die
+ fowners apache:apache /var/cache/mod_security || die
+ fperms 0770 /var/cache/mod_security || die
+}