summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-03-15 16:56:16 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-03-15 16:56:16 +0000
commit000ebe2ee4c2a4d727cb59ec317516ba8a135e45 (patch)
tree5ca5926dac02199342a5ee4a93bc975fef3f2d44 /www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
parentVersion bump. Redo LINGUAS patch. Add patch to respect LDFLAGS/CFLAGS. (diff)
downloadgentoo-2-000ebe2ee4c2a4d727cb59ec317516ba8a135e45.tar.gz
gentoo-2-000ebe2ee4c2a4d727cb59ec317516ba8a135e45.tar.bz2
gentoo-2-000ebe2ee4c2a4d727cb59ec317516ba8a135e45.zip
Version bump, bug 355303, fixes also bug 352724.
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch')
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch b/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
new file mode 100644
index 000000000000..1c7828b48949
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.5-bundled-Apache-Test.patch
@@ -0,0 +1,78 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index ca80816..4196f8e 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -24,7 +24,7 @@ BEGIN {
+
+ }
+
+-use lib qw(lib Apache-Test/lib);
++use lib qw(lib);
+
+ use Config;
+ use File::Spec::Functions;
+@@ -116,16 +116,6 @@ sub get_DEFINE {
+ }
+
+ sub configure {
+-
+- # mod_perl test suite relies on having Apache-Test bundled with
+- # the mod_perl source, since any pre-installed version may not do
+- # the right thing
+- unless (-d "Apache-Test") {
+- error "Can't find a sub-directory Apache-Test. " .
+- "Make sure that you are using a complete source distribution";
+- exit 1;
+- }
+-
+ set_modperl_version();
+
+ if ($old_modperl_version) {
+@@ -794,47 +784,11 @@ run_tests : test_clean
+ run_subtests ::
+ $(MAKE) -C ModPerl-Registry test
+
+-run_subtests ::
+- $(MAKE) -C Apache-Reload test
+-
+-run_subtests ::
+- $(MAKE) -C Apache-SizeLimit test
+-
+ test :: pure_all run_tests test_clean
+ EOF
+
+ }
+
+-sub MY::postamble {
+- my $self = shift;
+-
+- my $string = $self->ModPerl::BuildMM::MY::postamble;
+-
+- $string .= <<'EOF';
+-mydist : Apache-Test/META.yml mod_perl.spec manifest tardist
+-
+-rpm: dist
+- @[ -d $(PWD)/rpm ] || mkdir $(PWD)/rpm
+- rpmbuild -ta --define "_rpmdir $(PWD)/rpm" \
+- --define "_srcrpmdir $(PWD)/rpm" \
+- $(DISTVNAME).tar.gz
+- @mv $(PWD)/rpm/*/*.rpm $(PWD)/rpm/
+- @rm -rf $(PWD)/rpm/*/
+-
+-mod_perl.spec: build/make_rpm_spec
+- $(PERL) build/make_rpm_spec
+-
+-Apache-Test/META.yml:
+- cd Apache-Test && make metafile
+-
+-tag :
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/branches/release/$(VERSION_SYM) https://svn.apache.org/repos/asf/perl/modperl/tags/$(VERSION_SYM)
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/docs/trunk https://svn.apache.org/repos/asf/perl/modperl/docs/tags/$(VERSION_SYM)
+-EOF
+-
+- return $string;
+-}
+-
+ # this is a workaround so that ModPerl::MM will move MY::constants
+ # away, and Apache-Test/Makefile.PL which has its own MY::constants
+ # won't get complaints on MY::constants redefined