summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-06 20:17:49 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-06 20:17:49 +0000
commitd3b647aa4561966f632f9001b2adabfeb1611eab (patch)
tree2db4056528c3cf8b41fd7bf56da4a41d81143686 /www-apache/anyterm
parentCleanup old versions. (diff)
downloadgentoo-2-d3b647aa4561966f632f9001b2adabfeb1611eab.tar.gz
gentoo-2-d3b647aa4561966f632f9001b2adabfeb1611eab.tar.bz2
gentoo-2-d3b647aa4561966f632f9001b2adabfeb1611eab.zip
fix #203928; cleanup
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-apache/anyterm')
-rw-r--r--www-apache/anyterm/ChangeLog13
-rw-r--r--www-apache/anyterm/anyterm-1.1.15.ebuild28
-rw-r--r--www-apache/anyterm/anyterm-1.1.8-r2.ebuild102
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch28
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch71
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch26
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch14
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.8-postinst-en.txt59
-rw-r--r--www-apache/anyterm/files/digest-anyterm-1.1.8-r23
9 files changed, 24 insertions, 320 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index f934e29ef695..77c826ce397b 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-apache/anyterm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.8 2007/09/08 16:30:43 hollow Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.9 2008/01/06 20:17:49 hollow Exp $
+
+ 06 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ -files/anyterm-1.1.8-apachemod-Makefile.patch,
+ -files/anyterm-1.1.8-browser-gentoo.patch,
+ -files/anyterm-1.1.8-common-extern.patch,
+ -files/anyterm-1.1.8-libpbe-no-pg_config.patch,
+ -files/anyterm-1.1.8-postinst-en.txt, -anyterm-1.1.8-r2.ebuild,
+ anyterm-1.1.15.ebuild:
+ fix #203928; cleanup
*anyterm-1.1.15 (08 Sep 2007)
diff --git a/www-apache/anyterm/anyterm-1.1.15.ebuild b/www-apache/anyterm/anyterm-1.1.15.ebuild
index 52a4e304ff26..883111dac1e5 100644
--- a/www-apache/anyterm/anyterm-1.1.15.ebuild
+++ b/www-apache/anyterm/anyterm-1.1.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.15.ebuild,v 1.1 2007/09/08 16:30:43 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.15.ebuild,v 1.2 2008/01/06 20:17:49 hollow Exp $
inherit apache-module eutils toolchain-funcs webapp
@@ -29,11 +29,10 @@ DOCFILES="CHANGELOG README"
WEBAPP_MANUAL_SLOT="yes"
-need_apache2
+need_apache2_2
pkg_setup() {
webapp_pkg_setup
-
apache-module_pkg_setup
if use ssl && ! built_with_use www-servers/apache ssl; then
@@ -41,7 +40,7 @@ pkg_setup() {
die
fi
- if ! built_with_use dev-libs/boost threads; then
+ if ! built_with_use --missing true dev-libs/boost threads; then
eerror "Build dev-libs/boost with USE=threads."
die
fi
@@ -50,12 +49,14 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-browser-gentoo.patch"
- sed -i -e "s:apr-config:$(apr_config):g" apachemod/Makefile
+ epatch "${FILESDIR}"/${P}-browser-gentoo.patch
+ sed -i -e "s:apr-config:apr-1-config:g" apachemod/Makefile
}
src_compile() {
- ( cd apachemod && emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "Apachemod make failed" )
+ cd apachemod
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "Apachemod make failed"
+ cd ..
# Modify browser files to reflect USE flags.
for flag in opera pam ssl ; do
@@ -74,25 +75,22 @@ src_install() {
webapp_src_preinst
cp -f browser/{*,.htaccess} "${D}/${MY_HTDOCSDIR}"
- webapp_postinst_txt en "${FILESDIR}/${P}-postinst-en.txt"
+ webapp_postinst_txt en "${FILESDIR}"/${P}-postinst-en.txt
webapp_src_install
}
pkg_postinst() {
webapp_pkg_postinst
-
apache-module_pkg_postinst
if ! use ssl ; then
- ewarn "USE=-ssl: Anyterm without SSL is very insecure!"
+ ewarn "USE=-ssl: Anyterm without SSL is very insecure!"
fi
if ! use pam ; then
- ewarn "USE=-pam: You will have to add your own authentication"
- ewarn " mechanism."
+ ewarn "USE=-pam: You will have to add your own authentication mechanism."
fi
if use opera ; then
- ewarn "USE=opera: Be sure to disable some logging in your Apache"
- ewarn " configuration files!"
+ ewarn "USE=opera: Be sure to disable some logging in your Apache configuration files!"
fi
if ! use ssl || ! use pam || use opera ; then
ewarn "For more information see http://anyterm.org/security.html"
diff --git a/www-apache/anyterm/anyterm-1.1.8-r2.ebuild b/www-apache/anyterm/anyterm-1.1.8-r2.ebuild
deleted file mode 100644
index 2428d4831170..000000000000
--- a/www-apache/anyterm/anyterm-1.1.8-r2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.8-r2.ebuild,v 1.4 2007/07/29 17:13:50 phreak Exp $
-
-inherit apache-module eutils toolchain-funcs webapp
-
-KEYWORDS="~x86"
-
-DESCRIPTION="A terminal anywhere."
-HOMEPAGE="http://anyterm.org/"
-SRC_URI="http://anyterm.org/download/${P}.tbz2"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="opera pam ssl"
-
-DEPEND="dev-libs/boost
- >=dev-libs/rote-0.2.8
- >=sys-devel/gcc-3
- virtual/ssh
- pam? ( www-apache/mod_auth_pam )"
-RDEPEND="${DEPEND}"
-
-APACHE2_MOD_CONF="50_${PN}"
-APACHE2_MOD_DEFINE="ANYTERM"
-use pam && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D AUTH_PAM"
-use ssl && APACHE2_MOD_DEFINE="${APACHE2_MOD_DEFINE} -D SSL"
-APACHE2_MOD_FILE="${S}/apachemod/.libs/${PN}.so"
-DOCFILES="CHANGELOG README"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-need_apache2
-
-pkg_setup() {
- webapp_pkg_setup
-
- apache-module_pkg_setup
-
- use ssl && ! built_with_use www-servers/apache ssl && \
- eerror "Build www-servers/apache with USE=ssl."
-}
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}/${P}-apachemod-Makefile.patch"
- epatch "${FILESDIR}/${P}-common-extern.patch"
- epatch "${FILESDIR}/${P}-browser-gentoo.patch"
-
- # The bundled libpbe causes lots of problems because it links to various
- # assorted packages, without any checks. These packages may or not be
- # installed. Here we disable all packages which are not required.
- epatch "${FILESDIR}/${P}-libpbe-no-pg_config.patch"
- for f in Database Recoder jpegsize ; do
- rm -f "${S}"/libpbe/src/${f}.{cc,hh}
- done
-}
-
-src_compile() {
- ( cd apachemod && emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ) || die "Apachemod make failed"
-
- # Modify browser files to reflect USE flags.
- for flag in opera pam ssl ; do
- if use ${flag} ; then
- sed -i -e "s/^#USE=${flag}#//" browser/{*,.htaccess}
- sed -i -e "/^#USE=-${flag}#/D" browser/{*,.htaccess}
- else
- sed -i -e "s/^#USE=-${flag}#//" browser/{*,.htaccess}
- sed -i -e "/^#USE=${flag}#/D" browser/{*,.htaccess}
- fi
- done
-}
-
-src_install() {
- apache-module_src_install
-
- webapp_src_preinst
- cp -f browser/{*,.htaccess} "${D}/${MY_HTDOCSDIR}"
- webapp_postinst_txt en "${FILESDIR}/${P}-postinst-en.txt"
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- apache-module_pkg_postinst
-
- if ! use ssl ; then
- ewarn "USE=-ssl: Anyterm without SSL is very insecure!"
- fi
- if ! use pam ; then
- ewarn "USE=-pam: You will have to add your own authentication"
- ewarn " mechanism."
- fi
- if use opera ; then
- ewarn "USE=opera: Be sure to disable some logging in your Apache"
- ewarn " configuration files!"
- fi
- if ! use ssl || ! use pam || use opera ; then
- ewarn "For more information see http://anyterm.org/security.html"
- fi
-}
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch b/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch
deleted file mode 100644
index 680d5f9c5975..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.8-apachemod-Makefile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- anyterm-1.1.8/apachemod/Makefile 2005-10-31 22:20:05.000000000 +0100
-+++ anyterm/apachemod/Makefile 2006-01-23 16:45:26.000000000 +0100
-@@ -60,10 +60,10 @@
- cd $(COMMON_DIR); $(MAKE)
-
- %.lo: %.cc
-- $(LIBTOOL) --mode=compile g++ $(CC_COMPILE_FLAGS) -o $@ -c $<
-+ $(LIBTOOL) --mode=compile $(CXX) $(CC_COMPILE_FLAGS) -o $@ -c $<
-
- %.lo: %.c
-- $(LIBTOOL) --mode=compile gcc $(C_COMPILE_FLAGS) -o $@ -c $<
-+ $(LIBTOOL) --mode=compile $(CC) $(C_COMPILE_FLAGS) -o $@ -c $<
-
-
- compile: $(OBJS) $(COMMON_LIB)
-@@ -73,10 +73,10 @@
- $(APXS2) -n anyterm -i anyterm.la
-
- %.d: %.cc
-- g++ -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
-+ $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
-
- %.d: %.c
-- gcc -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
-+ $(CC) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
-
- DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
-
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch b/www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch
deleted file mode 100644
index d2f203d8ce71..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.8-browser-gentoo.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-diff -Naur anyterm-1.1.8/browser/anyterm.js anyterm/browser/anyterm.js
---- anyterm-1.1.8/browser/anyterm.js 2005-11-24 19:54:15.000000000 +0100
-+++ anyterm/browser/anyterm.js 2006-01-25 16:52:46.000000000 +0100
-@@ -26,16 +26,21 @@
- var open=false;
- var session;
-
--//var post_method="POST";
--var post_method="GET";
-+#USE=opera#//var post_method="POST";
-+#USE=opera#var post_method="GET";
-+#USE=-opera#var post_method="POST";
-+#USE=-opera#//var post_method="GET";
-
- // Random sequence numbers are needed to prevent Opera from caching
- // replies
-
- var is_opera = navigator.userAgent.toLowerCase().indexOf("opera") != -1;
--if (is_opera) {
-- post_method="GET";
--}
-+#USE=opera#if (is_opera) {
-+#USE=opera# post_method="GET";
-+#USE=opera#}
-+#USE=-opera#//if (is_opera) {
-+#USE=-opera#// post_method="GET";
-+#USE=-opera#//}
-
- var seqnum_val=Math.round(Math.random()*100000);
- function cachebust() {
-diff -Naur anyterm-1.1.8/browser/.htaccess anyterm/browser/.htaccess
---- anyterm-1.1.8/browser/.htaccess 2005-09-05 00:49:44.000000000 +0200
-+++ anyterm/browser/.htaccess 2006-01-25 17:03:29.000000000 +0100
-@@ -6,6 +6,8 @@
- # will be ignored if the anyterm module has not been loaded.
-
- <IfModule anyterm>
-+#USE=ssl#<IfModule mod_ssl.c>
-+#USE=pam#<IfModule mod_auth_pam.c>
-
- # Use an anyterm_command directive to specify the command to run
- # inside the terminal:
-@@ -24,6 +26,16 @@
- # Example:
- # anyterm_command '/path/to/anygetty --remotehost "Anyterm: %h" --autologin=%u'
-
-+# twp: Use ssh to avoid problems with Gentoo's /bin/login.
-+anyterm_command '/usr/bin/ssh %u@localhost'
-+
-+#USE=ssl#SSLRequireSSL
-+#USE=ssl#
-+#USE=pam#AuthPAM_Enabled on
-+#USE=pam#AuthType Basic
-+#USE=pam#AuthName "Anyterm"
-+#USE=pam#Require valid-user
-+#USE=pam#
- <Files anyterm-module>
- SetHandler anyterm
-
-@@ -34,7 +46,10 @@
- # CustomLog /path/to/logfile combined env=!DONTLOG
- # See the Apache documentation for details. Note "=!" not "!=" !
-
-- # SetEnv DONTLOG
-+#USE=opera# SetEnv DONTLOG
-+#USE=-opera# # SetEnv DONTLOG
- </Files>
-
-+#USE=pam#</IfModule>
-+#USE=ssl#</IfModule>
- </IfModule>
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch b/www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch
deleted file mode 100644
index 77705ead99ce..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.8-common-extern.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur anyterm-1.1.8/common/html.hh anyterm/common/html.hh
---- anyterm-1.1.8/common/html.hh 2005-09-05 09:50:28.000000000 +0200
-+++ anyterm/common/html.hh 2006-01-23 16:52:24.000000000 +0100
-@@ -31,7 +31,9 @@
-
- #include <string>
-
-+extern "C" {
- #include <rote/rote.h>
-+}
-
- #include "Screen.hh"
-
-diff -Naur anyterm-1.1.8/common/Screen.hh anyterm/common/Screen.hh
---- anyterm-1.1.8/common/Screen.hh 2005-09-03 15:27:05.000000000 +0200
-+++ anyterm/common/Screen.hh 2006-01-23 16:52:35.000000000 +0100
-@@ -24,7 +24,9 @@
- #define Screen_hh
-
- #include <vector>
-+extern "C" {
- #include <rote/rote.h>
-+}
-
-
- class Screen: public std::vector<RoteCell> {
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch b/www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch
deleted file mode 100644
index 47e1888b46ee..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.8-libpbe-no-pg_config.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur anyterm-1.1.8/libpbe/src/Makefile anyterm/libpbe/src/Makefile
---- anyterm-1.1.8/libpbe/src/Makefile 2005-10-25 18:07:39.000000000 +0200
-+++ anyterm/libpbe/src/Makefile 2006-01-23 16:46:56.000000000 +0100
-@@ -42,9 +42,7 @@
-
- DEBUG_FLAGS=
-
--PG_INC_FLAGS=-I$(shell pg_config --includedir)
--
--INC_FLAGS=$(PG_INC_FLAGS)
-+INC_FLAGS=
-
- COMPILE_FLAGS=$(WARN_FLAGS) $(OPTIMISE_FLAGS) $(DEBUG_FLAGS) $(INC_FLAGS) -D_REENTRANT
-
diff --git a/www-apache/anyterm/files/anyterm-1.1.8-postinst-en.txt b/www-apache/anyterm/files/anyterm-1.1.8-postinst-en.txt
deleted file mode 100644
index f96f0dcef3e9..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.8-postinst-en.txt
+++ /dev/null
@@ -1,59 +0,0 @@
-DEFAULT GENTOO INSTALLATION
-
-The default Gentoo installation is designed to work and be as secure as
-possible out-of-the box as long as you have USE="ssl pam -opera".
-
-
-USE FLAGS
-
-+ssl forces anyterm to only run over secure (HTTPS) connections.
--ssl disables secure connections, all data will pass over the network in
- plain text, including passwords!
-+pam enables PAM authentication, so anyone with an account on your computer
- can use anyterm without any further configuration.
--pam means that you will have to configure your own authentication
- mechanism.
-+opera Enables a workaround for a bug in the Opera browser, but you will have
- to modify apache's logging behaviour to prevent snooping by local
- users.
--opera Disables the Opera bug workaround.
-
-
-INSTALLATION INSTRUCTIONS
-
-1. Add the following flags to APACHE2_OPTS in /etc/init.d/apache2:
- -D ANYTERM
- -D SSL # if USE=ssl
- -D SSL_DEFAULT_VHOST # if USE="ssl -vhosts"
- -D AUTH_PAM # if USE=pam
-
-2. If you have USE=vhosts then you need to add the following directives to
- each virtual host's configuration file:
- <Directory "${MY_INSTALLDIR}">
- AllowOverride All
- </Directory>
-
-3. If you have USE=opera then you should disable logging of some requests. In
- each apache configuration file add env=!DONTLOG to each CustomLog
- directive. For example:
- USE="ssl -vhosts":
- Edit /etc/apache2/modules.d/41_mod_ssl.default-vhost.conf:
- CustomLog logs/ssl_request_log \
- "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b" \
- env=!DONTLOG
- USE="-ssl -vhosts":
- Edit /etc/apache2/httpd.conf:
- CustomLog logs/access_log common env=!DONTLOG
-
-4. Restart apache2:
- /etc/init.d/apache2 restart
-
-5. Browse to:
- https://${VHOST_HOSTNAME}${VHOST_APPDIR}/${PN}.html # if USE=ssl
- http://${VHOST_HOSTNAME}${VHOST_APPDIR}/${PN}.html # if USE=-ssl
-
-
-MORE INFORMATION
-
-http://anyterm.org/
-http://anyterm.org/security.html
diff --git a/www-apache/anyterm/files/digest-anyterm-1.1.8-r2 b/www-apache/anyterm/files/digest-anyterm-1.1.8-r2
deleted file mode 100644
index d95bbe335179..000000000000
--- a/www-apache/anyterm/files/digest-anyterm-1.1.8-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5ad8d6127680122e8f5c45f39093bd58 anyterm-1.1.8.tbz2 75137
-RMD160 8e2ba675b0697214579524a19d10bc7791a4834e anyterm-1.1.8.tbz2 75137
-SHA256 06c3896597cc9353c3d1fdcd33aab071f31b5fe7305561ba03372feeb92913ff anyterm-1.1.8.tbz2 75137