summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-07 08:10:42 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-07 08:10:42 +0000
commitda076b79851ce9bc9f42f87d4f3ea774737c3b84 (patch)
tree0f04e7439f733b18c4dc6773bdce7d113dbd48f8 /virtual
parentAdd ruby20 support. (diff)
downloadgentoo-2-da076b79851ce9bc9f42f87d4f3ea774737c3b84.tar.gz
gentoo-2-da076b79851ce9bc9f42f87d4f3ea774737c3b84.tar.bz2
gentoo-2-da076b79851ce9bc9f42f87d4f3ea774737c3b84.zip
Add ruby20 support.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rubygems/ChangeLog8
-rw-r--r--virtual/rubygems/rubygems-6.ebuild45
2 files changed, 51 insertions, 2 deletions
diff --git a/virtual/rubygems/ChangeLog b/virtual/rubygems/ChangeLog
index e631b2a0e863..b4795fba5c3f 100644
--- a/virtual/rubygems/ChangeLog
+++ b/virtual/rubygems/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/rubygems
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/ChangeLog,v 1.44 2013/03/24 17:49:43 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/ChangeLog,v 1.45 2013/07/07 08:10:42 graaff Exp $
+
+*rubygems-6 (07 Jul 2013)
+
+ 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +rubygems-6.ebuild:
+ Add ruby20 support.
24 Mar 2013; Julian Ospald <hasufell@gentoo.org> Manifest:
fix Manifest
@@ -76,4 +81,3 @@
+rubygems-2.ebuild, +rubygems-3.ebuild, +rubygems-4.ebuild, +metadata.xml:
Add back virtual/rubygems since we cannot support unbundled rubygems for all
ruby targets.
-
diff --git a/virtual/rubygems/rubygems-6.ebuild b/virtual/rubygems/rubygems-6.ebuild
new file mode 100644
index 000000000000..867a42a33813
--- /dev/null
+++ b/virtual/rubygems/rubygems-6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/rubygems-6.ebuild,v 1.1 2013/07/07 08:10:42 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for rubygems"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="dev-ruby/rubygems[ruby_targets_ruby20]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.