summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-20 17:32:13 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-20 17:32:13 +0000
commit49d656bbf5fefeffb5818039db2b26c4f7f430b5 (patch)
tree306154d10a1340462af689c2efd50980f9329b73 /virtual/rubygems
parentAdd missing pkgconfig dep (bug #386913) (diff)
downloadgentoo-2-49d656bbf5fefeffb5818039db2b26c4f7f430b5.tar.gz
gentoo-2-49d656bbf5fefeffb5818039db2b26c4f7f430b5.tar.bz2
gentoo-2-49d656bbf5fefeffb5818039db2b26c4f7f430b5.zip
Add back virtual/rubygems since we cannot support unbundled rubygems for all ruby targets.
(Portage version: 2.1.10.11/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'virtual/rubygems')
-rw-r--r--virtual/rubygems/ChangeLog14
-rw-r--r--virtual/rubygems/metadata.xml5
-rw-r--r--virtual/rubygems/rubygems-1.ebuild45
-rw-r--r--virtual/rubygems/rubygems-2.ebuild45
-rw-r--r--virtual/rubygems/rubygems-3.ebuild45
-rw-r--r--virtual/rubygems/rubygems-4.ebuild45
6 files changed, 199 insertions, 0 deletions
diff --git a/virtual/rubygems/ChangeLog b/virtual/rubygems/ChangeLog
new file mode 100644
index 000000000000..2a5505809f3a
--- /dev/null
+++ b/virtual/rubygems/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for virtual/rubygems
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/ChangeLog,v 1.24 2011/10/20 17:32:13 graaff Exp $
+
+*rubygems-4 (20 Oct 2011)
+*rubygems-3 (20 Oct 2011)
+*rubygems-2 (20 Oct 2011)
+*rubygems-1 (20 Oct 2011)
+
+ 20 Oct 2011; Hans de Graaff <graaff@gentoo.org> +rubygems-1.ebuild,
+ +rubygems-2.ebuild, +rubygems-3.ebuild, +rubygems-4.ebuild, +metadata.xml:
+ Add back virtual/rubygems since we cannot support unbundled rubygems for all
+ ruby targets.
+
diff --git a/virtual/rubygems/metadata.xml b/virtual/rubygems/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/virtual/rubygems/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/virtual/rubygems/rubygems-1.ebuild b/virtual/rubygems/rubygems-1.ebuild
new file mode 100644
index 000000000000..a1e8aead1c6b
--- /dev/null
+++ b/virtual/rubygems/rubygems-1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/rubygems-1.ebuild,v 1.1 2011/10/20 17:32:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for rubygems"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 s390 ~sh sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-ruby/rubygems[ruby_targets_ruby18]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/rubygems/rubygems-2.ebuild b/virtual/rubygems/rubygems-2.ebuild
new file mode 100644
index 000000000000..7acb5d2b3c0c
--- /dev/null
+++ b/virtual/rubygems/rubygems-2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/rubygems-2.ebuild,v 1.1 2011/10/20 17:32:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="jruby"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for rubygems"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ruby/rubygems[ruby_targets_jruby]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/rubygems/rubygems-3.ebuild b/virtual/rubygems/rubygems-3.ebuild
new file mode 100644
index 000000000000..d0880cbf5190
--- /dev/null
+++ b/virtual/rubygems/rubygems-3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/rubygems-3.ebuild,v 1.1 2011/10/20 17:32:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ree18"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for rubygems"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ruby/rubygems[ruby_targets_ree18]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.
diff --git a/virtual/rubygems/rubygems-4.ebuild b/virtual/rubygems/rubygems-4.ebuild
new file mode 100644
index 000000000000..5a6f50b07e6e
--- /dev/null
+++ b/virtual/rubygems/rubygems-4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/rubygems/rubygems-4.ebuild,v 1.1 2011/10/20 17:32:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for rubygems"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~amd64 ~hppa ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-ruby/rubygems[ruby_targets_ruby19]"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.