summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 05:43:26 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 05:43:26 +0000
commite15be2ce5ad9643a9ae706ec25edba9ff66c5d0c (patch)
tree6f9460cbff5af494f621e8a7ee5eac2c3d785f10 /sys-process
parentVersion bump. Set RDEPEND. (diff)
downloadgentoo-2-e15be2ce5ad9643a9ae706ec25edba9ff66c5d0c.tar.gz
gentoo-2-e15be2ce5ad9643a9ae706ec25edba9ff66c5d0c.tar.bz2
gentoo-2-e15be2ce5ad9643a9ae706ec25edba9ff66c5d0c.zip
Version bump.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/runit/ChangeLog9
-rw-r--r--sys-process/runit/runit-2.1.1.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/sys-process/runit/ChangeLog b/sys-process/runit/ChangeLog
index ea2c789b6fd8..d340c7f3ca2a 100644
--- a/sys-process/runit/ChangeLog
+++ b/sys-process/runit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/runit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.30 2008/12/25 22:24:45 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.31 2011/06/15 05:43:26 jer Exp $
+
+*runit-2.1.1 (15 Jun 2011)
+
+ 15 Jun 2011; Jeroen Roovers <jer@gentoo.org> +runit-2.1.1.ebuild:
+ Version bump.
*runit-2.0.0 (25 Dec 2008)
diff --git a/sys-process/runit/runit-2.1.1.ebuild b/sys-process/runit/runit-2.1.1.ebuild
new file mode 100644
index 000000000000..0ca0be3d979b
--- /dev/null
+++ b/sys-process/runit/runit-2.1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-2.1.1.ebuild,v 1.1 2011/06/15 05:43:26 jer Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="http://smarden.org/runit/"
+SRC_URI="http://smarden.org/runit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+S=${WORKDIR}/admin/${P}
+
+src_prepare() {
+ # we either build everything or nothing static
+ sed -i -e 's:-static: :' src/Makefile
+}
+
+src_configure() {
+ cd src
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ dodir /var
+ keepdir /etc/runit{,/runsvdir{,/default,/all}}
+ dosym default /etc/runit/runsvdir/current
+ dosym ../etc/runit/runsvdir/current /var/service
+
+ cd src
+ dobin $(<../package/commands) || die "dobin"
+ dodir /sbin
+ mv "${D}"/usr/bin/{runit-init,runit,utmpset} "${D}"/sbin/ || die "dosbin"
+
+ cd "${S}"
+ dodoc package/{CHANGES,README,THANKS,TODO}
+ dohtml doc/*.html
+ doman man/*.[18]
+
+ exeinto /etc/runit
+ doexe "${FILESDIR}"/{1,2,ctrlaltdel} || die
+ newexe "${FILESDIR}"/3-1.4 3 || die
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/runit/runsvdir/all/getty-$tty/
+ for script in run finish; do
+ newexe "${FILESDIR}"/$script.getty $script
+ dosed "s:TTY:${tty}:g" /etc/runit/runsvdir/all/getty-$tty/$script
+ done
+ dosym ../all/getty-$tty /etc/runit/runsvdir/default/getty-$tty
+ done
+}