summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-05-10 08:23:34 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-05-10 08:23:34 +0000
commitcefcbfc2fa78167eaf429a586a3b8359fccbc75e (patch)
tree44855e95897431b6fda6bba731785060b4e9d9a2 /sys-process
parentBug # 221101 : re-adding KEYWORDS from cunit-2.0 (diff)
downloadgentoo-2-cefcbfc2fa78167eaf429a586a3b8359fccbc75e.tar.gz
gentoo-2-cefcbfc2fa78167eaf429a586a3b8359fccbc75e.tar.bz2
gentoo-2-cefcbfc2fa78167eaf429a586a3b8359fccbc75e.zip
version bump
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/htop-0.8.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 64a4343a931d..6d55000a5ac3 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.53 2008/02/14 01:11:20 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.54 2008/05/10 08:23:34 wschlich Exp $
+
+*htop-0.8 (09 May 2008)
+
+ 09 May 2008; Wolfram Schlich <wschlich@gentoo.org> +htop-0.8.ebuild:
+ version bump
14 Feb 2008; Wolfram Schlich <wschlich@gentoo.org> -htop-0.6.5.ebuild:
removed old version
diff --git a/sys-process/htop/htop-0.8.ebuild b/sys-process/htop/htop-0.8.ebuild
new file mode 100644
index 000000000000..074fe8616cf2
--- /dev/null
+++ b/sys-process/htop/htop-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.ebuild,v 1.1 2008/05/10 08:23:34 wschlich Exp $
+
+inherit flag-o-matic
+
+IUSE="debug"
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+DEPEND="sys-libs/ncurses"
+
+pkg_setup() {
+ if use elibc_FreeBSD ; then
+ elog
+ elog "htop needs /proc mounted to work, to mount it type"
+ elog "mount -t linprocfs none /proc"
+ elog "or uncomment the example in /etc/fstab"
+ elog
+ fi
+}
+
+src_compile() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}