summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-04-07 15:11:02 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-04-07 15:11:02 +0000
commit7533d931d8645e7778dbbed9fc54d2125f2253ea (patch)
tree572af6153944a0088320a277c1e7ba78da7b7c26 /sys-process
parentarm stable, bug #410867 (diff)
downloadgentoo-2-7533d931d8645e7778dbbed9fc54d2125f2253ea.tar.gz
gentoo-2-7533d931d8645e7778dbbed9fc54d2125f2253ea.tar.bz2
gentoo-2-7533d931d8645e7778dbbed9fc54d2125f2253ea.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/incron/ChangeLog7
-rw-r--r--sys-process/incron/incron-0.5.10.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-process/incron/ChangeLog b/sys-process/incron/ChangeLog
index 177538437107..2cae3ef7d930 100644
--- a/sys-process/incron/ChangeLog
+++ b/sys-process/incron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/incron
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.17 2012/01/09 19:05:54 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.18 2012/04/07 15:11:02 idl0r Exp $
+
+*incron-0.5.10 (07 Apr 2012)
+
+ 07 Apr 2012; Christian Ruppert <idl0r@gentoo.org> +incron-0.5.10.ebuild:
+ Version bump.
09 Jan 2012; Brent Baude <ranger@gentoo.org> incron-0.5.9-r1.ebuild:
Marking incron-0.5.9-r1 ppc for bug 361099
diff --git a/sys-process/incron/incron-0.5.10.ebuild b/sys-process/incron/incron-0.5.10.ebuild
new file mode 100644
index 000000000000..0fa7f450a2b4
--- /dev/null
+++ b/sys-process/incron/incron-0.5.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.10.ebuild,v 1.1 2012/04/07 15:11:02 idl0r Exp $
+
+EAPI="4"
+
+inherit eutils linux-info toolchain-funcs
+
+DESCRIPTION="inotify based cron daemon"
+HOMEPAGE="http://incron.aiken.cz/"
+SRC_URI="http://inotify.aiken.cz/download/incron/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# < 2.6.18 => INOTIFY, >= 2.6.18 => INOTIFY_USER
+# It should be ok to expect at least 2.6.18
+CONFIG_CHECK="~INOTIFY_USER"
+
+src_compile() {
+ emake CXX=$(tc-getCXX)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCDIR=/usr/share/doc/${PF} install
+
+ newinitd "${FILESDIR}/incrond.init" incrond
+
+ dodoc CHANGELOG README TODO
+}