summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-05-24 13:10:40 +0000
committerRichard Yao <ryao@gentoo.org>2012-05-24 13:10:40 +0000
commit31fd937ac42ea0d6f9d65e26063fe876a3a69802 (patch)
tree9b03f2765ab083405dabc3a0aafc73c8ea1ba8ce /sys-process
parentVersion bump to the latest. Make tests work. Per bug#417257. Patch done by Ia... (diff)
downloadgentoo-2-31fd937ac42ea0d6f9d65e26063fe876a3a69802.tar.gz
gentoo-2-31fd937ac42ea0d6f9d65e26063fe876a3a69802.tar.bz2
gentoo-2-31fd937ac42ea0d6f9d65e26063fe876a3a69802.zip
Fix patch to avoid undefined behavior, bug \#417181
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/pidof-bsd/ChangeLog8
-rw-r--r--sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch4
-rw-r--r--sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild (renamed from sys-process/pidof-bsd/pidof-bsd-20050501-r3.ebuild)2
3 files changed, 10 insertions, 4 deletions
diff --git a/sys-process/pidof-bsd/ChangeLog b/sys-process/pidof-bsd/ChangeLog
index 4e98065d694f..4a478c572331 100644
--- a/sys-process/pidof-bsd/ChangeLog
+++ b/sys-process/pidof-bsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/pidof-bsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/pidof-bsd/ChangeLog,v 1.9 2012/04/26 14:27:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/pidof-bsd/ChangeLog,v 1.10 2012/05/24 13:10:40 ryao Exp $
+
+*pidof-bsd-20050501-r4 (24 May 2012)
+
+ 24 May 2012; Richard Yao <ryao@gentoo.org> +pidof-bsd-20050501-r4.ebuild,
+ -pidof-bsd-20050501-r3.ebuild, files/pidof-bsd-20050501-pname.patch:
+ Fix patch to avoid undefined behavior, bug \#417181
26 Apr 2012; Alexis Ballier <aballier@gentoo.org>
pidof-bsd-20050501-r3.ebuild:
diff --git a/sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch b/sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch
index 66095f51e637..13e890c6a37c 100644
--- a/sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch
+++ b/sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch
@@ -7,10 +7,10 @@
+ char *pname = NULL;
+
+ if (process_name == NULL)
-+ return;
++ return 0;
+
+ if ((pname = strdup(basename(process_name))) == NULL)
-+ return;
++ return 0;
- if ((kd = kvm_open("/dev/null", "/dev/null", "/dev/null", O_RDONLY, "kvm_open")) == NULL)
- (void)errx(1, "%s", kvm_geterr(kd));
diff --git a/sys-process/pidof-bsd/pidof-bsd-20050501-r3.ebuild b/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild
index 89e4f8bb20c9..e4b180a9bfd6 100644
--- a/sys-process/pidof-bsd/pidof-bsd-20050501-r3.ebuild
+++ b/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/pidof-bsd/pidof-bsd-20050501-r3.ebuild,v 1.6 2012/04/26 14:27:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild,v 1.1 2012/05/24 13:10:40 ryao Exp $
inherit base bsdmk