summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-04-09 09:54:57 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-04-09 09:54:57 +0000
commitf514efbf3c78b8381e8c40f906ac173c92c8c0b5 (patch)
tree27649237adb675687d04f7d387cb8e3fc69cc34c /sys-process/vixie-cron
parentRe-commit samba-init since brought back from attic. (diff)
downloadgentoo-2-f514efbf3c78b8381e8c40f906ac173c92c8c0b5.tar.gz
gentoo-2-f514efbf3c78b8381e8c40f906ac173c92c8c0b5.tar.bz2
gentoo-2-f514efbf3c78b8381e8c40f906ac173c92c8c0b5.zip
Fixes bash iteration
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-process/vixie-cron')
-rw-r--r--sys-process/vixie-cron/ChangeLog6
-rw-r--r--sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/sys-process/vixie-cron/ChangeLog b/sys-process/vixie-cron/ChangeLog
index ae360d453a1f..314fbb9b12c1 100644
--- a/sys-process/vixie-cron/ChangeLog
+++ b/sys-process/vixie-cron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/vixie-cron
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/ChangeLog,v 1.44 2007/04/08 21:50:44 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/ChangeLog,v 1.45 2007/04/09 09:54:57 falco Exp $
+
+ 09 Apr 2007; Raphael Marichez <falco@gentoo.org>
+ vixie-cron-4.1-r10.ebuild:
+ Fixes bash iteration in chown, thanks to phreak
*vixie-cron-4.1-r10 (08 Apr 2007)
diff --git a/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild b/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild
index 2ce0e0070d94..f9bc75b693e9 100644
--- a/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild
+++ b/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild,v 1.1 2007/04/08 21:50:44 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild,v 1.2 2007/04/09 09:54:57 falco Exp $
inherit cron toolchain-funcs pam
@@ -115,7 +115,7 @@ pkg_postinst() {
chgrp -R crontab "${ROOT}/var/spool/cron/crontabs" || die "chgrp failed"
cd "${ROOT}/var/spool/cron/crontabs/"
for cronfile in * ; do
- [[ $cronfile == ".keep" ]] || chown "$cronfile:crontab" "$cronfile" \
+ [[ ! -f $cronfile ]] || chown "$cronfile:crontab" "$cronfile" \
|| ewarn "chown failed on $cronfile, you probably have an orphan file."
done
fi