summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-18 04:25:36 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-18 04:25:36 +0000
commitd1e025d0b89da4b59f85a654cd29055c20a5cd02 (patch)
tree659fa4f1c47d3697b1c598dddbc3a49edc5e646b /sys-process/procps
parentbump (diff)
downloadgentoo-2-d1e025d0b89da4b59f85a654cd29055c20a5cd02.tar.gz
gentoo-2-d1e025d0b89da4b59f85a654cd29055c20a5cd02.tar.bz2
gentoo-2-d1e025d0b89da4b59f85a654cd29055c20a5cd02.zip
Add fix from upstream when running tests w/out a tty on stdin #461302 by Roman Žilka.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/ChangeLog7
-rw-r--r--sys-process/procps/files/procps-3.3.10-tests-no-tty.patch122
-rw-r--r--sys-process/procps/procps-3.3.10-r1.ebuild10
3 files changed, 133 insertions, 6 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 6dea75b4d880..8d58dce124bc 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/procps
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.138 2015/05/18 04:19:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.139 2015/05/18 04:25:36 vapier Exp $
+
+ 18 May 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/procps-3.3.10-tests-no-tty.patch, procps-3.3.10-r1.ebuild:
+ Add fix from upstream when running tests w/out a tty on stdin #461302 by Roman
+ Žilka.
18 May 2015; Mike Frysinger <vapier@gentoo.org>
+files/procps-3.3.10-pmap-unreadable.patch, procps-3.3.10-r1.ebuild:
diff --git a/sys-process/procps/files/procps-3.3.10-tests-no-tty.patch b/sys-process/procps/files/procps-3.3.10-tests-no-tty.patch
new file mode 100644
index 000000000000..7a774e5f2ef1
--- /dev/null
+++ b/sys-process/procps/files/procps-3.3.10-tests-no-tty.patch
@@ -0,0 +1,122 @@
+https://bugs.gentoo.org/461302
+
+From 4050148a4533e8a79cef0d7dcd0c058d78c48a31 Mon Sep 17 00:00:00 2001
+From: Craig Small <csmall@enc.com.au>
+Date: Sat, 9 May 2015 17:48:12 +1000
+Subject: [PATCH] Fix some sched and tty tests
+
+The ps sched test has been disabled. There are too many
+odd build farms this fails in strange ways.
+
+Other odd build farms have no tty and so some tests check
+for no tty and skip if not found.
+---
+ testsuite/config/unix.exp | 9 +++++++++
+ testsuite/pgrep.test/pgrep.exp | 11 +++++++----
+ testsuite/pkill.test/pkill.exp | 3 +--
+ testsuite/ps.test/ps_output.exp | 2 --
+ testsuite/ps.test/ps_sched_batch.exp | 16 +++++++++-------
+ 5 files changed, 26 insertions(+), 15 deletions(-)
+
+diff --git a/testsuite/config/unix.exp b/testsuite/config/unix.exp
+index 522efb1..1318e9a 100644
+--- a/testsuite/config/unix.exp
++++ b/testsuite/config/unix.exp
+@@ -146,3 +146,12 @@ proc kill_testproc { } {
+ kill_process $testproc2_pid
+ file delete $testproc_path
+ }
++
++proc get_tty {} {
++ if { [catch { set raw_tty [ exec tty ] } msg]} {
++ warning "No TTY found"
++ return ""
++ }
++ regexp "/dev/(.+)" $raw_tty > tty
++ return $tty
++}
+diff --git a/testsuite/pgrep.test/pgrep.exp b/testsuite/pgrep.test/pgrep.exp
+index 152b6ec..1c6cec6 100644
+--- a/testsuite/pgrep.test/pgrep.exp
++++ b/testsuite/pgrep.test/pgrep.exp
+@@ -9,8 +9,7 @@ set not_uid [ expr { $uid + 1 } ]
+ set gid [ exec id -g ]
+ set not_gid [ expr { $gid + 1 } ]
+ set ps "${topdir}ps/pscommand"
+-set raw_tty [ exec tty ]
+-regexp "/dev/(.+)" $raw_tty > tty
++set tty [ get_tty ]
+
+ set test "pgprep with no arguments"
+ spawn $pgrep
+@@ -80,8 +79,12 @@ spawn $pgrep -s 1 $testproc_comm
+ expect_blank "$test"
+
+ set test "pgrep matches on tty"
+-spawn $pgrep -t $tty $testproc_comm
+-expect_pass "$test" "^$testproc1_pid\\s+$testproc2_pid\\s*$"
++if { $tty == "" } {
++ untested "$test"
++} else {
++ spawn $pgrep -t $tty $testproc_comm
++ expect_pass "$test" "^$testproc1_pid\\s+$testproc2_pid\\s*$"
++}
+
+ set test "pgrep doesn't match with bogus tty"
+ spawn $pgrep -t glass $testproc_comm
+diff --git a/testsuite/pkill.test/pkill.exp b/testsuite/pkill.test/pkill.exp
+index 5eece7d..c583cbe 100644
+--- a/testsuite/pkill.test/pkill.exp
++++ b/testsuite/pkill.test/pkill.exp
+@@ -9,8 +9,7 @@ set not_uid [ expr { $uid + 1 } ]
+ set gid [ exec id -g ]
+ set not_gid [ expr { $gid + 1 } ]
+ set ps "${topdir}ps/pscommand"
+-set raw_tty [ exec tty ]
+-regexp "/dev/(.+)" $raw_tty > tty
++set tty [ get_tty ]
+
+ set test "pkill with no arguments"
+ spawn $pkill
+diff --git a/testsuite/ps.test/ps_output.exp b/testsuite/ps.test/ps_output.exp
+index 3a6f3d8..1b2c097 100644
+--- a/testsuite/ps.test/ps_output.exp
++++ b/testsuite/ps.test/ps_output.exp
+@@ -9,8 +9,6 @@ set uid [ exec id -u ]
+ set not_uid [ expr { $uid + 1 } ]
+ set gid [ exec id -g ]
+ set not_gid [ expr { $gid + 1 } ]
+-set raw_tty [ exec tty ]
+-regexp "/dev/(.+)" $raw_tty > tty
+
+ # All the fields
+ # Cannot do args,cmd,comm
+diff --git a/testsuite/ps.test/ps_sched_batch.exp b/testsuite/ps.test/ps_sched_batch.exp
+index e0c31ff..c58b9a2 100644
+--- a/testsuite/ps.test/ps_sched_batch.exp
++++ b/testsuite/ps.test/ps_sched_batch.exp
+@@ -1,12 +1,14 @@
+ #
+ # check the ps SCHED_BATCH scheduler policy output
+ #
+-set ps "${topdir}ps/pscommand"
+-set schedbatch "${topdir}testsuite/test-schedbatch"
+-
+-spawn $schedbatch 18
+-
++# This is too flaky on certain build systems to be
++# reliable - CS
++#set ps "${topdir}ps/pscommand"
++#set schedbatch "${topdir}testsuite/test-schedbatch"
++#
++#spawn $schedbatch 18
++#
+ set test "ps SCHED_BATCH scheduler"
+-spawn $ps --no-header -o comm,cls,nice -a
+-expect_pass "$test" "\\s+test-schedbatch\\s+B\\s+18"
++#spawn $ps --no-header -o comm,cls,nice -a
++#expect_pass "$test" "\\s+test-schedbatch\\s+B\\s+18"
+ untested "$test"
+--
+2.4.0
+
diff --git a/sys-process/procps/procps-3.3.10-r1.ebuild b/sys-process/procps/procps-3.3.10-r1.ebuild
index 8201bebf296c..19e4f64fd864 100644
--- a/sys-process/procps/procps-3.3.10-r1.ebuild
+++ b/sys-process/procps/procps-3.3.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.10-r1.ebuild,v 1.2 2015/05/18 04:19:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.10-r1.ebuild,v 1.3 2015/05/18 04:25:36 vapier Exp $
EAPI="4"
@@ -31,9 +31,9 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-ng-${PV}
src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.3.8-kill-neg-pid.patch \
- "${FILESDIR}"/${P}-pmap-unreadable.patch
+ epatch "${FILESDIR}"/${PN}-3.3.8-kill-neg-pid.patch # http://crbug.com/255209
+ epatch "${FILESDIR}"/${P}-pmap-unreadable.patch #404389
+ epatch "${FILESDIR}"/${P}-tests-no-tty.patch #461302
sed -i -e 's:systemd-login:systemd:' configure || die #501306
}
@@ -51,7 +51,7 @@ src_configure() {
}
src_test() {
- emake check </dev/null
+ emake check </dev/null #461302
}
src_install() {