summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-30 11:40:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-30 11:40:58 +0000
commitc3917fa216ef2b75ff42cc1ab68e5e824656a988 (patch)
tree63112b3b728f3db0ae1465998a12d6d07f890260 /sys-process/incron
parentFix building with GCC 4.4 wrt #277668. (diff)
downloadgentoo-2-c3917fa216ef2b75ff42cc1ab68e5e824656a988.tar.gz
gentoo-2-c3917fa216ef2b75ff42cc1ab68e5e824656a988.tar.bz2
gentoo-2-c3917fa216ef2b75ff42cc1ab68e5e824656a988.zip
Fix building with GCC 4.4 and GLIBC 2.10+ wrt #277175.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/incron')
-rw-r--r--sys-process/incron/ChangeLog6
-rw-r--r--sys-process/incron/files/incron-0.5.8-gcc44.patch58
-rw-r--r--sys-process/incron/incron-0.5.8.ebuild5
3 files changed, 66 insertions, 3 deletions
diff --git a/sys-process/incron/ChangeLog b/sys-process/incron/ChangeLog
index 0ff758e7579f..e804ac855a64 100644
--- a/sys-process/incron/ChangeLog
+++ b/sys-process/incron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/incron
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.6 2009/07/26 20:10:29 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.7 2009/07/30 11:40:58 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> incron-0.5.8.ebuild,
+ +files/incron-0.5.8-gcc44.patch:
+ Fix building with GCC 4.4 and GLIBC 2.10+ wrt #277175.
26 Jul 2009; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd> tag
diff --git a/sys-process/incron/files/incron-0.5.8-gcc44.patch b/sys-process/incron/files/incron-0.5.8-gcc44.patch
new file mode 100644
index 000000000000..b46b54d391e4
--- /dev/null
+++ b/sys-process/incron/files/incron-0.5.8-gcc44.patch
@@ -0,0 +1,58 @@
+diff -ur incron-0.5.8.orig/appargs.cpp incron-0.5.8/appargs.cpp
+--- incron-0.5.8.orig/appargs.cpp 2008-12-29 18:31:09.000000000 +0200
++++ incron-0.5.8/appargs.cpp 2009-07-30 14:40:39.000000000 +0300
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#include <stdio.h>
+
+ #include <cstring>
+
+diff -ur incron-0.5.8.orig/icd-main.cpp incron-0.5.8/icd-main.cpp
+--- incron-0.5.8.orig/icd-main.cpp 2008-12-29 18:31:09.000000000 +0200
++++ incron-0.5.8/icd-main.cpp 2009-07-30 14:38:36.000000000 +0300
+@@ -13,6 +13,7 @@
+ *
+ */
+
++#include <stdio.h>
+ #include <map>
+ #include <signal.h>
+ #include <wait.h>
+diff -ur incron-0.5.8.orig/incroncfg.cpp incron-0.5.8/incroncfg.cpp
+--- incron-0.5.8.orig/incroncfg.cpp 2008-12-29 18:31:09.000000000 +0200
++++ incron-0.5.8/incroncfg.cpp 2009-07-30 14:41:31.000000000 +0300
+@@ -181,7 +181,7 @@
+
+ bool IncronCfg::IsComment(const char* s)
+ {
+- char* sx = strchr(s, '#');
++ const char* sx = strchr(s, '#');
+ if (sx == NULL)
+ return false;
+
+diff -ur incron-0.5.8.orig/inotify-cxx.cpp incron-0.5.8/inotify-cxx.cpp
+--- incron-0.5.8.orig/inotify-cxx.cpp 2008-12-29 18:31:09.000000000 +0200
++++ incron-0.5.8/inotify-cxx.cpp 2009-07-30 14:39:06.000000000 +0300
+@@ -19,7 +19,7 @@
+ *
+ */
+
+-
++#include <stdio.h>
+ #include <errno.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+diff -ur incron-0.5.8.orig/usertable.cpp incron-0.5.8/usertable.cpp
+--- incron-0.5.8.orig/usertable.cpp 2008-12-29 18:31:09.000000000 +0200
++++ incron-0.5.8/usertable.cpp 2009-07-30 14:38:50.000000000 +0300
+@@ -16,7 +16,7 @@
+ *
+ */
+
+-
++#include <stdio.h>
+ #include <pwd.h>
+ #include <syslog.h>
+ #include <errno.h>
diff --git a/sys-process/incron/incron-0.5.8.ebuild b/sys-process/incron/incron-0.5.8.ebuild
index 31ed53b0b653..28efbf927963 100644
--- a/sys-process/incron/incron-0.5.8.ebuild
+++ b/sys-process/incron/incron-0.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.8.ebuild,v 1.1 2009/03/24 09:10:08 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.8.ebuild,v 1.2 2009/07/30 11:40:58 ssuominen Exp $
EAPI="2"
@@ -22,7 +22,8 @@ CONFIG_CHECK="INOTIFY"
ERROR_INOTIFY="Recompile your kernel with inotify support - CONFIG_INOTIFY"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
}
src_compile() {