summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-01-14 18:26:43 +0000
committerThilo Bangert <bangert@gentoo.org>2010-01-14 18:26:43 +0000
commit3e06d0e9794c6674a47454a05ac4d957696691f0 (patch)
tree0b8e3efa5304090cc75a3745c362a1c35ae8db97 /sys-process/bcron
parentTransfer Prefix keywords (diff)
downloadgentoo-2-3e06d0e9794c6674a47454a05ac4d957696691f0.tar.gz
gentoo-2-3e06d0e9794c6674a47454a05ac4d957696691f0.tar.bz2
gentoo-2-3e06d0e9794c6674a47454a05ac4d957696691f0.zip
EAPI2, fix parallel build (bug #278459), multilib ready
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'sys-process/bcron')
-rw-r--r--sys-process/bcron/ChangeLog10
-rw-r--r--sys-process/bcron/bcron-0.09-r1.ebuild117
-rw-r--r--sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch19
3 files changed, 144 insertions, 2 deletions
diff --git a/sys-process/bcron/ChangeLog b/sys-process/bcron/ChangeLog
index 035e55cef070..047c8cbeaeb0 100644
--- a/sys-process/bcron/ChangeLog
+++ b/sys-process/bcron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/bcron
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/ChangeLog,v 1.13 2009/09/23 21:06:51 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/ChangeLog,v 1.14 2010/01/14 18:26:42 bangert Exp $
+
+*bcron-0.09-r1 (14 Jan 2010)
+
+ 14 Jan 2010; Thilo Bangert <bangert@gentoo.org> +bcron-0.09-r1.ebuild,
+ +files/bcron-0.09-fix-parallel-build.patch:
+ EAPI2, fix parallel build (bug #278459), multilib ready
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> bcron-0.09.ebuild:
Remove virtual/libc
diff --git a/sys-process/bcron/bcron-0.09-r1.ebuild b/sys-process/bcron/bcron-0.09-r1.ebuild
new file mode 100644
index 000000000000..c9dc51e8f39e
--- /dev/null
+++ b/sys-process/bcron/bcron-0.09-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/bcron/bcron-0.09-r1.ebuild,v 1.1 2010/01/14 18:26:42 bangert Exp $
+
+EAPI="2"
+
+inherit cron eutils toolchain-funcs multilib
+DESCRIPTION="A new cron system designed with secure operations in mind by Bruce Guenter"
+
+HOMEPAGE="http://untroubled.org/bcron/"
+SRC_URI="http://untroubled.org/bcron/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.106"
+RDEPEND="!virtual/cron
+ >=sys-process/cronbase-0.3.2
+ virtual/mta
+ sys-apps/ucspi-unix
+ sys-process/daemontools"
+PROVIDE="virtual/cron"
+
+CRON_SYSTEM_CRONTAB="yes"
+
+src_prepare() {
+ epatch "${FILESDIR}/bcron-0.09-fix-parallel-build.patch"
+}
+
+src_configure() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+ echo "${D}/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ einstall || die
+
+ #fix permissions of crontab
+ fperms o-rwx /usr/bin/bcrontab
+ fowners root:cron /usr/bin/bcrontab
+
+ doman bcrontab.1 crontab.5 bcron-update.8 bcron-start.8
+ doman bcron-spool.8 bcron-sched.8 bcron-exec.8
+
+ dodoc ANNOUNCEMENT NEWS README TODO
+
+ keepdir /etc/cron.d
+
+ keepdir /var/spool/cron/crontabs
+ keepdir /var/spool/cron/tmp
+
+ for i in crontabs tmp;
+ do
+ fowners cron:cron /var/spool/cron/$i
+ fperms go-rwx /var/spool/cron/$i
+ done
+
+ dodir /etc/bcron
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+
+ insinto /var/lib/supervise/bcron
+ doins bcron-sched.run
+
+ insinto /var/lib/supervise/bcron/log
+ doins bcron-sched-log.run
+
+ insinto /var/lib/supervise/bcron-spool
+ doins bcron-spool.run
+
+ insinto /var/lib/supervise/bcron-update
+ doins bcron-update.run
+}
+
+pkg_config() {
+ cd "${ROOT}"var/lib/supervise/bcron
+ [ -e run ] && cp run bcron-sched.run.`date +%Y%m%d%H%M%S`
+ cp bcron-sched.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron/log
+ [ -e run ] && cp run bcron-sched-log.run.`date +%Y%m%d%H%M%S`
+ cp bcron-sched-log.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron-spool
+ [ -e run ] && cp run bcron-spool.run.`date +%Y%m%d%H%M%S`
+ cp bcron-spool.run run
+ chmod u+x run
+
+ cd "${ROOT}"/var/lib/supervise/bcron-update
+ [ -e run ] && cp run bcron-update.run.`date +%Y%m%d%H%M%S`
+ cp bcron-update.run run
+ chmod u+x run
+
+ [ ! -e "${ROOT}"/var/spool/cron/trigger ] && mkfifo "${ROOT}"var/spool/cron/trigger
+ chown cron:cron /var/spool/cron/trigger
+ chmod go-rwx /var/spool/cron/trigger
+}
+
+pkg_postinst() {
+ echo
+ elog "Run "
+ elog "emerge --config =${PF}"
+ elog "to create or update your run files (backups are created) in"
+ elog " /var/lib/supervise/bcron (bcron daemon) and"
+ elog " /var/lib/supervise/bcron-spool (crontab receiver) and"
+ elog " /var/lib/supervise/bcron-update (system crontab updater)"
+
+ cron_pkg_postinst
+}
diff --git a/sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch b/sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch
new file mode 100644
index 000000000000..987b302abe4f
--- /dev/null
+++ b/sys-process/bcron/files/bcron-0.09-fix-parallel-build.patch
@@ -0,0 +1,19 @@
+--- Makefile.orig 2010-01-14 15:39:07.000000000 +0100
++++ Makefile 2010-01-14 15:39:40.000000000 +0100
+@@ -96,14 +96,14 @@
+ ./load insthier -lbg-installer -lbg
+ mv insthier installer
+
+-instcheck: load insthier.o
++instcheck: load insthier.o installer instshow
+ ./load insthier -lbg-instcheck -lbg
+ mv insthier instcheck
+
+ insthier.o: compile insthier.c conf_bin.c
+ ./compile insthier.c
+
+-instshow: load insthier.o
++instshow: load insthier.o installer
+ ./load insthier -lbg-instshow -lbg
+ mv insthier instshow
+