summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-29 23:46:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-29 23:46:08 +0000
commit988abcbec83f0b3b531990dc46446f393335517e (patch)
tree54990f595d84d4317cfad1ae52fad1a96013f649 /sys-power
parentFix deprecated knob. (diff)
downloadgentoo-2-988abcbec83f0b3b531990dc46446f393335517e.tar.gz
gentoo-2-988abcbec83f0b3b531990dc46446f393335517e.tar.bz2
gentoo-2-988abcbec83f0b3b531990dc46446f393335517e.zip
Version bump, with new version of build cleanup patch.
(Portage version: 2.1_rc3)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/iasl/ChangeLog8
-rw-r--r--sys-power/iasl/files/acpica-unix-20060512-buildfixup.patch177
-rw-r--r--sys-power/iasl/files/digest-iasl-200605123
-rw-r--r--sys-power/iasl/iasl-20060512.ebuild40
4 files changed, 227 insertions, 1 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 45516e0ca1c1..170018feb966 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/iasl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.7 2006/02/20 04:04:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.8 2006/05/29 23:46:08 robbat2 Exp $
+
+*iasl-20060512 (29 May 2006)
+
+ 29 May 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +files/acpica-unix-20060512-buildfixup.patch, +iasl-20060512.ebuild:
+ Version bump, with new version of build cleanup patch.
*iasl-20060127 (20 Feb 2006)
diff --git a/sys-power/iasl/files/acpica-unix-20060512-buildfixup.patch b/sys-power/iasl/files/acpica-unix-20060512-buildfixup.patch
new file mode 100644
index 000000000000..5a08da4f5aa6
--- /dev/null
+++ b/sys-power/iasl/files/acpica-unix-20060512-buildfixup.patch
@@ -0,0 +1,177 @@
+Patches by Robin H. Johnson <robbat2@gentoo.org> - 2006/05/29
+
+Previously using GCC you had to do make clean between making each of the
+seperate utilities. This was due to the fact that depending on what compiler
+defines were passed, the output was different.
+The following patch makes the output files reflect which utility they are
+compiled for, so they don't conflict, and no make clean is needed.
+
+This patch also adds a top level Makefile to allow quick building of the entire
+package.
+
+Also fixes parallel build issues in compiler/, where the yacc generated data
+might used before it was ready.
+
+diff -Nuar --exclude '*~' acpica-unix-20060512.orig/Makefile acpica-unix-20060512/Makefile
+--- acpica-unix-20060512.orig/Makefile 1969-12-31 16:00:00.000000000 -0800
++++ acpica-unix-20060512/Makefile 2006-05-29 16:28:55.560238471 -0700
+@@ -0,0 +1,31 @@
++PROGS= compiler/iasl tools/acpiexec/acpiexec tools/acpixtract/acpixtract tools/acpisrc/acpisrc
++ifndef CFLAGS
++CFLAGS= -O2 -g
++endif
++# warnings always important
++CFLAGS += -Wall -Wstrict-prototypes
++
++all: $(PROGS)
++
++iasl: compiler
++acpiexec: tools/acpiexec
++acpixtract: tools/acpixtract
++acpisrc: tools/acpisrc
++
++SUBDIRS = $(dir $(PROGS))
++.PHONY: $(SUBDIRS) all
++
++compiler: compiler/iasl
++tools/acpiexec: tools/acpiexec/acpiexec
++tools/acpixtract: tools/acpixtract/acpixtract
++tools/acpisrc: tools/acpisrc/acpisrc
++
++
++$(PROGS):
++ CFLAGS="$(CFLAGS)" $(MAKE) -C $(dir $(@))
++
++clean: clean-subdirs
++clean-subdirs:
++ for dir in $(SUBDIRS); do \
++ $(MAKE) -C $$dir clean; \
++ done
+diff -Nuar --exclude '*~' acpica-unix-20060512.orig/compiler/Makefile acpica-unix-20060512/compiler/Makefile
+--- acpica-unix-20060512.orig/compiler/Makefile 2006-05-12 14:13:31.000000000 -0700
++++ acpica-unix-20060512/compiler/Makefile 2006-05-29 16:34:25.050744637 -0700
+@@ -87,7 +87,7 @@
+ ../osunixxf.c
+
+ NOMAN= YES
+-CFLAGS+= -Wall -O2 -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
++CFLAGS+= -D_LINUX -DACPI_ASL_COMPILER -I../include
+
+ #YACC= yacc
+ YACC= bison
+@@ -101,14 +101,22 @@
+ #CFLAGS+= -D_USE_BERKELEY_YACC
+ #.endif
+
+-aslmain : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) \
+- $(LOADLIBES) $(LDLIBS) -o iasl
++OBJNAME = iasl
++OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
++%.$(OBJNAME).o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
++
++$(PROG) : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) \
++ $(LOADLIBES) $(LDLIBS) -o $(PROG)
+
+ CLEANFILES= y.output y.tab.c y.tab.h aslcompiler.y.h \
+- aslcompilerparse.c aslcompilerlex.c iasl
++ aslcompilerparse.c aslcompilerlex.c $(PROG)
+
+-aslcompilerparse.c: aslcompiler.y
++# force the YACC work to be done before any sources
++# as they all depend on it.
++$(SRCS): aslcompiler.y.h
++aslcompiler.y.h: aslcompiler.y
+ ${YACC} ${YFLAGS} aslcompiler.y
+ cp y.tab.c aslcompilerparse.c
+ cp y.tab.h aslcompiler.y.h
+@@ -117,5 +125,5 @@
+ ${LEX} ${LFLAGS} -PAslCompiler -oaslcompilerlex.c aslcompiler.l
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
+diff -Nuar --exclude '*~' acpica-unix-20060512.orig/tools/acpiexec/Makefile acpica-unix-20060512/tools/acpiexec/Makefile
+--- acpica-unix-20060512.orig/tools/acpiexec/Makefile 2006-05-12 14:13:43.000000000 -0700
++++ acpica-unix-20060512/tools/acpiexec/Makefile 2006-05-29 16:33:43.551484557 -0700
+@@ -131,14 +131,19 @@
+ ../../osunixxf.c
+
+
+-CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../include
++CFLAGS+= -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -I../../include
+
++OBJNAME = acpiexec
++OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
+
+-acpiexec : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
++%.$(OBJNAME).o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
++
++$(PROG): $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
+
+ CLEANFILES= $(PROG)
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
+diff -Nuar --exclude '*~' acpica-unix-20060512.orig/tools/acpisrc/Makefile acpica-unix-20060512/tools/acpisrc/Makefile
+--- acpica-unix-20060512.orig/tools/acpisrc/Makefile 2006-05-12 14:13:44.000000000 -0700
++++ acpica-unix-20060512/tools/acpisrc/Makefile 2006-05-29 16:33:03.300322581 -0700
+@@ -4,14 +4,19 @@
+ SRCS= ascase.c asconvrt.c asfile.c asmain.c asremove.c astable.c \
+ asutils.c osunixdir.c ../../common/getopt.c
+
+-CFLAGS+= -Wall -O2 -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
++CFLAGS+= -D_LINUX -DACPI_APPLICATION -I../../include
+
++OBJNAME = acpi_application
++OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
+
+-aslmain : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
++%.$(OBJNAME).o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
++
++$(PROG) : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
+
+ CLEANFILES= $(PROG)
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
+diff -Nuar --exclude '*~' acpica-unix-20060512.orig/tools/acpixtract/Makefile acpica-unix-20060512/tools/acpixtract/Makefile
+--- acpica-unix-20060512.orig/tools/acpixtract/Makefile 2006-05-12 14:13:44.000000000 -0700
++++ acpica-unix-20060512/tools/acpixtract/Makefile 2006-05-29 16:32:50.047281484 -0700
+@@ -3,14 +3,19 @@
+ PROG= acpixtract
+ SRCS= acpixtract.c
+
+-CFLAGS+= -Wall -O2 -D_LINUX -DACPI_APPLICATION -Wstrict-prototypes -I../../include
++CFLAGS+= -D_LINUX -DACPI_APPLICATION -I../../include
+
++OBJNAME = acpi_application
++OBJS= $(patsubst %.c,%.$(OBJNAME).o, $(SRCS))
+
+-acpixtract : $(patsubst %.c,%.o, $(SRCS))
+- $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG)
++%.$(OBJNAME).o: %.c
++ $(COMPILE.c) $(OUTPUT_OPTION) $<
++
++$(PROG) : $(OBJS)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG)
+
+ CLEANFILES= $(PROG)
+
+ clean :
+- rm -f $(CLEANFILES) $(patsubst %.c,%.o, $(SRCS))
++ rm -f $(CLEANFILES) $(OBJS)
+
diff --git a/sys-power/iasl/files/digest-iasl-20060512 b/sys-power/iasl/files/digest-iasl-20060512
new file mode 100644
index 000000000000..a41ce607b35e
--- /dev/null
+++ b/sys-power/iasl/files/digest-iasl-20060512
@@ -0,0 +1,3 @@
+MD5 a1431c0be209b02b4d117c814aad8b44 acpica-unix-20060512.tar.gz 839039
+RMD160 2ea95f7f46038c41cdf5cb56149c6a3207c45532 acpica-unix-20060512.tar.gz 839039
+SHA256 29d35ce1f22c93983b91c07cc6c39ad522e77a9153cbb321fd32a9838e21eb3b acpica-unix-20060512.tar.gz 839039
diff --git a/sys-power/iasl/iasl-20060512.ebuild b/sys-power/iasl/iasl-20060512.ebuild
new file mode 100644
index 000000000000..4ab01da5fdeb
--- /dev/null
+++ b/sys-power/iasl/iasl-20060512.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060512.ebuild,v 1.1 2006/05/29 23:46:08 robbat2 Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.intel.com/technology/iapc/acpi/downloads/${MY_P}.tar.gz"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+IUSE=""
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20060512-buildfixup.patch
+}
+
+src_compile() {
+ # fix stupid flex 2.5.31 bug
+ emake -C compiler aslcompilerlex.c || die "emake aslcompilerlex.c failed"
+ sed -i.orig -e '/#define unput/s,yytext_ptr,AslCompilertext,' \
+ ${S}/compiler/aslcompilerlex.c || die "sed failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin compiler/iasl tools/acpixtract/acpixtract tools/acpiexec/acpiexec tools/acpisrc/acpisrc
+ dodoc README changes.txt
+}