summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-04-18 12:39:27 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-04-18 12:39:27 +0000
commit46576a4335217370a46d8ac41e2e9973e3b91dfd (patch)
tree514fa9fab946fda9259275a0195c235d9dfbe73e /sys-power
parentppc stable #295947 (diff)
downloadgentoo-2-46576a4335217370a46d8ac41e2e9973e3b91dfd.tar.gz
gentoo-2-46576a4335217370a46d8ac41e2e9973e3b91dfd.tar.bz2
gentoo-2-46576a4335217370a46d8ac41e2e9973e3b91dfd.zip
Revision bump for new patches: fixes bug #279067.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog8
-rw-r--r--sys-power/hibernate-script/hibernate-script-2.0-r2.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 1111e451e0ca..cd710a6baa61 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.87 2010/03/29 22:31:19 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.88 2010/04/18 12:39:27 nelchael Exp $
+
+*hibernate-script-2.0-r2 (18 Apr 2010)
+
+ 18 Apr 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +hibernate-script-2.0-r2.ebuild:
+ Revision bump for new patches: fixes bug #279067.
29 Mar 2010; Krzysztof Pawlik <nelchael@gentoo.org> metadata.xml:
Update my first name.
diff --git a/sys-power/hibernate-script/hibernate-script-2.0-r2.ebuild b/sys-power/hibernate-script/hibernate-script-2.0-r2.ebuild
new file mode 100644
index 000000000000..f80036a27282
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-2.0-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-2.0-r2.ebuild,v 1.1 2010/04/18 12:39:27 nelchael Exp $
+
+EAPI=2
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_prepare() {
+ epatch "${WORKDIR}/${PV}/"*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}