summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-10 22:09:09 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-10 22:09:09 +0000
commit0eb8bcc5dc60dd2a8cb80e2d81ec7cf361937f9e (patch)
tree2e53d8aeede429299d9505a21724329764023139 /sys-power
parentRemove old. (diff)
downloadgentoo-2-0eb8bcc5dc60dd2a8cb80e2d81ec7cf361937f9e.tar.gz
gentoo-2-0eb8bcc5dc60dd2a8cb80e2d81ec7cf361937f9e.tar.bz2
gentoo-2-0eb8bcc5dc60dd2a8cb80e2d81ec7cf361937f9e.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/ChangeLog8
-rw-r--r--sys-power/powertop/powertop-1.97-r1.ebuild56
-rw-r--r--sys-power/powertop/powertop-2.0.ebuild (renamed from sys-power/powertop/powertop-1.98.ebuild)20
-rw-r--r--sys-power/powertop/powertop-9999.ebuild20
4 files changed, 19 insertions, 85 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index 7d2f7a7a4c41..7c2815505046 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.50 2012/04/20 21:41:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.51 2012/05/10 22:09:09 vapier Exp $
+
+*powertop-2.0 (10 May 2012)
+
+ 10 May 2012; Mike Frysinger <vapier@gentoo.org> +powertop-2.0.ebuild,
+ -powertop-1.97-r1.ebuild, -powertop-1.98.ebuild, powertop-9999.ebuild:
+ Version bump.
20 Apr 2012; Mike Frysinger <vapier@gentoo.org> powertop-1.98.ebuild,
powertop-9999.ebuild:
diff --git a/sys-power/powertop/powertop-1.97-r1.ebuild b/sys-power/powertop/powertop-1.97-r1.ebuild
deleted file mode 100644
index 71ddb5df0004..000000000000
--- a/sys-power/powertop/powertop-1.97-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-1.97-r1.ebuild,v 1.4 2011/10/27 16:21:54 jer Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="http://www.lesswatts.org/projects/powertop/"
-SRC_URI="mirror://kernel/linux/status/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="unicode"
-
-DEPEND="
- dev-libs/libnl:1.1
- sys-apps/pciutils
- sys-devel/gettext
- sys-libs/ncurses[unicode?]
- sys-libs/zlib
-"
-RDEPEND="
- ${DEPEND}
- net-wireless/bluez
- x11-apps/xset
-"
-
-src_prepare() {
- use unicode || sed -i 's:-lncursesw:-lncurses:' Makefile
- # fix ldflags
- sed -i \
- -e '/-o powertop/s:g++:$(CXX) $(CFLAGS) $(LDFLAGS):' \
- -e 's: -O2 -g -fno-omit-frame-pointer -fstack-protector::g' \
- -e 's:gcc:$(CC) $(CFLAGS):' \
- Makefile || die
-}
-
-src_configure() {
- tc-export CC CXX
-}
-
-src_install() {
- emake install DESTDIR="${ED}"
- dodoc TODO README
- keepdir /var/cache/powertop
-}
-
-pkg_postinst() {
- echo
- einfo "For PowerTOP to work best, use a Linux kernel with the"
- einfo "tickless idle (NO_HZ) feature enabled (version 2.6.21 or later)"
- echo
-}
diff --git a/sys-power/powertop/powertop-1.98.ebuild b/sys-power/powertop/powertop-2.0.ebuild
index a1f6d7984654..ae672a946061 100644
--- a/sys-power/powertop/powertop-1.98.ebuild
+++ b/sys-power/powertop/powertop-2.0.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-1.98.ebuild,v 1.5 2012/04/20 21:41:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.0.ebuild,v 1.1 2012/05/10 22:09:09 vapier Exp $
EAPI="4"
-inherit eutils toolchain-funcs
+inherit eutils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
inherit git-2
SRC_URI=""
else
- SRC_URI="mirror://kernel/linux/status/${PN}/${P}.tar.bz2"
+ SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="http://www.lesswatts.org/projects/powertop/"
+HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
LICENSE="GPL-2"
SLOT="0"
@@ -30,22 +30,14 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- net-wireless/bluez
x11-apps/xset
"
DOCS=( TODO README )
-src_prepare() {
- use unicode || sed -i 's:-lncursesw:-lncurses:' Makefile
- epatch "${FILESDIR}"/${PN}-1.98-build.patch
- epatch "${FILESDIR}"/${PN}-1.98-build-cc.patch
- epatch "${FILESDIR}"/${PN}-1.98-build-libnl-3.patch
- epatch "${FILESDIR}"/${PN}-1.98-gcc-4.7.patch
-}
-
src_configure() {
- tc-export BUILD_CC CC CXX
+ export ac_cv_search_delwin=$(usex unicode -lncursesw no)
+ default
}
src_install() {
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 808e6b6090b5..8c2966a7c1ee 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.10 2012/04/20 21:41:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.11 2012/05/10 22:09:09 vapier Exp $
EAPI="4"
-inherit eutils toolchain-funcs
+inherit eutils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
inherit git-2
SRC_URI=""
else
- SRC_URI="mirror://kernel/linux/status/${PN}/${P}.tar.bz2"
+ SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="tool that helps you find what software is using the most power"
-HOMEPAGE="http://www.lesswatts.org/projects/powertop/"
+HOMEPAGE="https://01.org/powertop/ http://www.lesswatts.org/projects/powertop/"
LICENSE="GPL-2"
SLOT="0"
@@ -30,22 +30,14 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- net-wireless/bluez
x11-apps/xset
"
DOCS=( TODO README )
-src_prepare() {
- use unicode || sed -i 's:-lncursesw:-lncurses:' Makefile
- epatch "${FILESDIR}"/${PN}-1.98-build.patch
- epatch "${FILESDIR}"/${PN}-1.98-build-cc.patch
- epatch "${FILESDIR}"/${PN}-1.98-build-libnl-3.patch
- epatch "${FILESDIR}"/${PN}-1.98-gcc-4.7.patch
-}
-
src_configure() {
- tc-export BUILD_CC CC CXX
+ export ac_cv_search_delwin=$(usex unicode -lncursesw no)
+ default
}
src_install() {