summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-07-22 00:33:48 +0000
committerChristian Heim <phreak@gentoo.org>2006-07-22 00:33:48 +0000
commited7a170e4328601796bbe5a72ed8cb7363c213c0 (patch)
tree3cad9bff9a6bd8423523fd1f124ebabe864c4703 /sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild
parentlibchipcard bump (diff)
downloadgentoo-2-ed7a170e4328601796bbe5a72ed8cb7363c213c0.tar.gz
gentoo-2-ed7a170e4328601796bbe5a72ed8cb7363c213c0.tar.bz2
gentoo-2-ed7a170e4328601796bbe5a72ed8cb7363c213c0.zip
Revision bump. Moving the patches to a seperate tarball. Backporting some changes from UPSTREAM svn. Finally fixing the last-return error, adding new ERROR messages for newer kernels. Fixing bug #141204 (thanks to Stefan Becker <schtefan at gmx.net> for the initial patch), restart 855resolution after resume.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild')
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild b/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild
new file mode 100644
index 000000000000..91bf7fe14676
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild,v 1.1 2006/07/22 00:33:48 phreak Exp $
+
+inherit eutils
+
+PATCH_VERSION="0.1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+ "${S}"/install.sh
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should run the following command to invalidate"
+ einfo "suspend images on a clean boot."
+ einfo
+ einfo " # rc-update add hibernate-cleanup boot"
+ einfo
+ einfo "See /usr/share/doc/${PF}/README.gz for further details."
+ einfo
+ einfo "Please note that you will need to manually emerge any utilities"
+ einfo "(radeontool, vbetool, ...) enabled in the configuration files,"
+ einfo "should you wish to use them."
+ einfo
+ einfo "Starting with hibernate-script-1.90 the configuration files have"
+ einfo "been reordered and split into method specific files. Make sure you"
+ einfo "update your /etc/hibernate/ configuration files accordingly."
+ einfo
+}