summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-18 16:21:03 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-18 16:21:03 +0000
commitff4885906cf4ec60643a470a0c3aaeac925dfee9 (patch)
treed90dca88e38612fb78e533919b4586bdcf949fe8 /sys-libs
parentremoving junk (diff)
downloadgentoo-2-ff4885906cf4ec60643a470a0c3aaeac925dfee9.tar.gz
gentoo-2-ff4885906cf4ec60643a470a0c3aaeac925dfee9.tar.bz2
gentoo-2-ff4885906cf4ec60643a470a0c3aaeac925dfee9.zip
some more warnings #137134 by Ryan Hill
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-build.patch46
1 files changed, 45 insertions, 1 deletions
diff --git a/sys-libs/pwdb/files/pwdb-0.62-build.patch b/sys-libs/pwdb/files/pwdb-0.62-build.patch
index 78bd15caed8d..a1f3e15d253d 100644
--- a/sys-libs/pwdb/files/pwdb-0.62-build.patch
+++ b/sys-libs/pwdb/files/pwdb-0.62-build.patch
@@ -1,4 +1,5 @@
- drop ldconfig junk
+ - fix types used in socket functions (socklen_t, not int)
http://bugs.gentoo.org/126977
- respect user LDFLAGS
@@ -7,6 +8,20 @@ http://bugs.gentoo.org/126695
- add missing headers
- add missing comma to supp_entry
+http://bugs.gentoo.org/137134
+ - don't show traditional warnings
+
+--- Makefile
++++ Makefile
+@@ -71,7 +71,7 @@
+
+ WARNINGS += -ansi -D_POSIX_SOURCE -Wall -Wwrite-strings \
+ -Wcast-qual -Wcast-align \
+- -Wtraditional -Wstrict-prototypes -Wmissing-prototypes \
++ -Wstrict-prototypes -Wmissing-prototypes \
+ -Wnested-externs -Winline -Wshadow
+ INCLUDEDIR=-I$(CRTDIR)/include
+
--- libpwdb/Makefile
+++ libpwdb/Makefile
@@ -50,7 +50,7 @@
@@ -18,7 +33,7 @@ http://bugs.gentoo.org/126695
@ln -sf $(LIBFILENAME) $@
$(LIBSTATIC): $(LIBOBJ)
-@@ -69,7 +69,7 @@
+@@ -68,7 +68,7 @@
$(INSTALL) -m 644 radius.h $(INCLUDED)/radius.h
$(INSTALL) -m 644 _pwdb_macros.h $(INCLUDED)/_pwdb_macros.h
$(INSTALL) -m 755 $(LIBFILENAME) $(LIBDIR)
@@ -68,3 +83,32 @@ http://bugs.gentoo.org/126695
"groups", /* these are serviced by requests */
NULL
};
+--- libpwdb/radius/radius.c
++++ libpwdb/radius/radius.c
+@@ -145,7 +145,7 @@
+ const char* password,
+ RADIUS_RESULT *rad_result)
+ {
+- int salen;
++ socklen_t salen;
+ int sockfd;
+ struct sockaddr saremote;
+ struct sockaddr_in *s_in;
+@@ -333,7 +333,7 @@
+ const char* new_password,
+ RADIUS_RESULT *rad_result)
+ {
+- int salen;
++ socklen_t salen;
+ int sockfd;
+ struct sockaddr saremote;
+ struct sockaddr_in *s_in;
+@@ -535,7 +535,7 @@
+ int sense,
+ int session_time)
+ {
+- int salen;
++ socklen_t salen;
+ int sockfd;
+ struct sockaddr saremote;
+ struct sockaddr_in *s_in;