summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-10-11 23:55:21 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-10-11 23:55:21 +0000
commit0a3753c42d0f74ab81d63fe1846b1750ff82f684 (patch)
treea380800957d86a4a5955471beee46cb9e4b8d58d /sys-libs
parentSet MULTILIB_ABIS to DEFAULT_ABI if ! use multilib. (diff)
downloadgentoo-2-0a3753c42d0f74ab81d63fe1846b1750ff82f684.tar.gz
gentoo-2-0a3753c42d0f74ab81d63fe1846b1750ff82f684.tar.bz2
gentoo-2-0a3753c42d0f74ab81d63fe1846b1750ff82f684.zip
Set MULTILIB_ABIS to DEFAULT_ABI if ! use multilib.
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index c7d3b29f7c26..59f94e1e6889 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.397 2005/10/08 04:19:36 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.398 2005/10/11 23:55:21 eradicator Exp $
+
+ 11 Oct 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ glibc-2.3.5-r2.ebuild:
+ Set MULTILIB_ABIS to DEFAULT_ABI if ! use multilib.
08 Oct 2005; Chris PeBenito <pebenito@gentoo.org> glibc-2.3.5-r1.ebuild,
glibc-2.3.5-r2.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 93fbc6968ebf..c6f28d38a6c2 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.11 2005/10/11 00:00:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.12 2005/10/11 23:55:21 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -966,8 +966,11 @@ fix_lib64_symlinks() {
use_multilib() {
case ${CTARGET} in
+ *-uclibc) false ;;
+
sparc64*|mips64*|amd64|ppc64)
- is_crosscompile || has_multilib_profile || use multilib ;;
+ has_multilib_profile || use multilib ;;
+
*) false ;;
esac
}
@@ -976,6 +979,9 @@ use_multilib() {
setup_env() {
if is_crosscompile || tc-is-cross-compiler ; then
multilib_env ${CTARGET}
+ if ! use multilib ; then
+ MULTILIB_ABIS=${DEFAULT_ABI}
+ fi
fi
export ABI=${ABI:-${DEFAULT_ABI:-default}}