summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-06 00:34:09 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-06 00:34:09 +0000
commit005cedbfdecc70b81904dd935f428505e240ca63 (patch)
tree86519508a53a90b8f51a8a2e57ba5aac4fd8232f /sys-libs
parentMarked ~ppc for bug #83706. (diff)
downloadgentoo-2-005cedbfdecc70b81904dd935f428505e240ca63.tar.gz
gentoo-2-005cedbfdecc70b81904dd935f428505e240ca63.tar.bz2
gentoo-2-005cedbfdecc70b81904dd935f428505e240ca63.zip
Fixed up tls/nptl logic for sparc64.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild38
1 files changed, 22 insertions, 16 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 6a6813942266..a35018a83ddd 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.14 2005/03/05 23:45:05 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.15 2005/03/06 00:34:09 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -712,21 +712,16 @@ check_nptl_support() {
echo
}
-
want_nptl() {
- if use nptl || use nptlonly ; then
- # Archs that can use NPTL
- case $(tc-arch) in
- amd64|ia64|ppc|ppc64|s390|sparc)
- return 0;
- ;;
- x86)
- case ${CTARGET/-*} in
- i486|i586|i686) return 0 ;;
- esac
- ;;
- esac
- fi
+ want_tls || return 1
+ use nptl || return 1
+
+ # Archs that can use NPTL
+ case $(tc-arch) in
+ amd64|ia64|ppc|ppc64|s390|sparc|x86)
+ return 0;
+ ;;
+ esac
return 1
}
@@ -740,9 +735,20 @@ want_linuxthreads() {
want_tls() {
# Archs that can use TLS (Thread Local Storage)
case $(tc-arch) in
- alpha|amd64|ia64|ppc|ppc64|s390|sparc)
+ alpha|amd64|ia64|ppc|ppc64|s390)
return 0;
;;
+ sparc)
+ case ${CTARGET/-*} in
+ sparc64*)
+ [[ ${ABI} == "sparc32" ]] && return 0
+ return 1
+ ;;
+ *)
+ return 0
+ ;;
+ esac
+ ;;
x86)
case ${CHOST/-*} in
i486|i586|i686) return 0 ;;