summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-04-10 15:50:53 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-04-10 15:50:53 +0000
commit732899225ee051be9668aeda5497c33e62d46fa6 (patch)
treefbd2972098a9b99b5ee471e07105dc095cd19284 /sys-libs/tdb
parentUnused KDE 3 masks (diff)
downloadgentoo-2-732899225ee051be9668aeda5497c33e62d46fa6.tar.gz
gentoo-2-732899225ee051be9668aeda5497c33e62d46fa6.tar.bz2
gentoo-2-732899225ee051be9668aeda5497c33e62d46fa6.zip
Fixed bug #314453 by adding --nonet to the xsltproc call.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/ChangeLog5
-rw-r--r--sys-libs/tdb/tdb-1.2.1.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index 6ddfe1cd1bf0..7142f12e4d4f 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.13 2010/04/09 19:04:44 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.14 2010/04/10 15:50:53 dev-zero Exp $
+
+ 10 Apr 2010; Tiziano Müller <dev-zero@gentoo.org> tdb-1.2.1.ebuild:
+ Fixed bug #314453 by adding --nonet to the xsltproc call.
*tdb-1.2.1 (09 Apr 2010)
diff --git a/sys-libs/tdb/tdb-1.2.1.ebuild b/sys-libs/tdb/tdb-1.2.1.ebuild
index 174ccc11dc71..f22ded80dde7 100644
--- a/sys-libs/tdb/tdb-1.2.1.ebuild
+++ b/sys-libs/tdb/tdb-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1.ebuild,v 1.1 2010/04/09 19:04:44 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.1.ebuild,v 1.2 2010/04/10 15:50:53 dev-zero Exp $
EAPI="2"
@@ -17,13 +17,20 @@ IUSE="python static-libs tools tdbtest"
RDEPEND=""
DEPEND="python? ( dev-lang/python )
!<net-fs/samba-libs-3.4
- !<net-fs/samba-3.3"
+ !<net-fs/samba-3.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
src_prepare() {
eautoconf -Ilibreplace
sed -i \
-e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' \
Makefile.in || die "sed failed"
+
+ # xsltproc will display a warning but we can assume the xml files are valid
+ sed -i \
+ -e 's|$(XSLTPROC) -o|$(XSLTPROC) --nonet -o|' \
+ tdb.mk || die "sed failed"
}
src_configure() {