summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-28 19:18:58 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-28 19:18:58 +0000
commit3973385075e2ebfafefc6817190acc4dbf387c33 (patch)
tree06e270509b12d8842c84728e57b5f094f45d47a3 /sys-libs/pam_usb/pam_usb-0.2.2.ebuild
parentAdded myself to metadata.xml (Manifest recommit) (diff)
downloadgentoo-2-3973385075e2ebfafefc6817190acc4dbf387c33.tar.gz
gentoo-2-3973385075e2ebfafefc6817190acc4dbf387c33.tar.bz2
gentoo-2-3973385075e2ebfafefc6817190acc4dbf387c33.zip
Applying -fPIC patch on all archs now.
Diffstat (limited to 'sys-libs/pam_usb/pam_usb-0.2.2.ebuild')
-rw-r--r--sys-libs/pam_usb/pam_usb-0.2.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/pam_usb/pam_usb-0.2.2.ebuild b/sys-libs/pam_usb/pam_usb-0.2.2.ebuild
index 33ff8f862623..19fdd1c3e7b3 100644
--- a/sys-libs/pam_usb/pam_usb-0.2.2.ebuild
+++ b/sys-libs/pam_usb/pam_usb-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_usb/pam_usb-0.2.2.ebuild,v 1.3 2004/05/26 11:21:50 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_usb/pam_usb-0.2.2.ebuild,v 1.4 2004/05/28 19:18:58 kugelfang Exp $
inherit eutils
@@ -19,10 +19,10 @@ DEPEND="ssl? ( dev-libs/openssl )
sys-libs/pam"
src_compile() {
- if [ "${ARCH}" = "amd64" ]; then
- # append-flags / CFLAGS doesnt work...
- sed -i -e "s/CFLAGS. *=/& -fPIC/" src/Makefile
- fi
+ # append-flags / CFLAGS doesnt work...
+ # applying the patch to all archs now as agriffis suggested
+ # Danny van Dyk <kugelfang@gentoo.org> 2004/05/28
+ sed -i -e "s/CFLAGS. *=/& -fPIC/" src/Makefile
emake || die "make failed"
}