summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-25 19:42:48 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-25 19:42:48 +0000
commitfa43f5c06f288f02e7946af10bdfc954f63e0714 (patch)
tree7c318e628f4ff593f70a229dde2aac3b49274953 /sys-libs/newlib
parentAdd ruby22. (diff)
downloadgentoo-2-fa43f5c06f288f02e7946af10bdfc954f63e0714.tar.gz
gentoo-2-fa43f5c06f288f02e7946af10bdfc954f63e0714.tar.bz2
gentoo-2-fa43f5c06f288f02e7946af10bdfc954f63e0714.zip
Add support for new monthly snapshots.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/ChangeLog8
-rw-r--r--sys-libs/newlib/newlib-2.2.0.20150225.ebuild82
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild8
3 files changed, 94 insertions, 4 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index 95d9a2aacb2f..aa0c9add4091 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.27 2015/02/17 07:03:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.28 2015/02/25 19:42:48 vapier Exp $
+
+*newlib-2.2.0.20150225 (25 Feb 2015)
+
+ 25 Feb 2015; Mike Frysinger <vapier@gentoo.org> +newlib-2.2.0.20150225.ebuild,
+ newlib-9999.ebuild:
+ Add support for new monthly snapshots.
*newlib-2.2.0 (17 Feb 2015)
diff --git a/sys-libs/newlib/newlib-2.2.0.20150225.ebuild b/sys-libs/newlib/newlib-2.2.0.20150225.ebuild
new file mode 100644
index 000000000000..c813ebfd7f23
--- /dev/null
+++ b/sys-libs/newlib/newlib-2.2.0.20150225.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-2.2.0.20150225.ebuild,v 1.1 2015/02/25 19:42:48 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://sourceware.org/git/newlib.git"
+ inherit git-r3
+else
+ SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
+ if [[ ${PV} != *.201[5-9]???? ]] ; then
+ KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+ fi
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+SLOT="0"
+IUSE="nls threads unicode crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+NEWLIBBUILD="${WORKDIR}/build"
+
+pkg_setup() {
+ # Reject newlib-on-glibc type installs
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ case ${CHOST} in
+ *-newlib|*-elf) ;;
+ *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
+ esac
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=""
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf="${myconf} --disable-newlib-multithread" \
+ || myconf="${myconf} $(use_enable threads newlib-multithread)"
+
+ mkdir -p "${NEWLIBBUILD}"
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${NEWLIBBUILD}"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+# env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/share/info
+ rm -fR "${D}"/usr/info
+}
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index 8d6d281c3eec..4558c965002e 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-9999.ebuild,v 1.2 2014/01/02 12:57:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-9999.ebuild,v 1.3 2015/02/25 19:42:48 vapier Exp $
EAPI="4"
@@ -11,7 +11,9 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+ if [[ ${PV} != *.201[5-9]???? ]] ; then
+ KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+ fi
fi
export CBUILD=${CBUILD:-${CHOST}}