summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-10-07 18:59:36 +0000
committerSven Vermeulen <swift@gentoo.org>2014-10-07 18:59:36 +0000
commitfac127bf118c96bca476a94bdbd4b46f5dde2e9f (patch)
tree4320127e7655aec7381c803875ff33aa79afee4d /sys-libs/libsepol
parentVersion bump (diff)
downloadgentoo-2-fac127bf118c96bca476a94bdbd4b46f5dde2e9f.tar.gz
gentoo-2-fac127bf118c96bca476a94bdbd4b46f5dde2e9f.tar.bz2
gentoo-2-fac127bf118c96bca476a94bdbd4b46f5dde2e9f.zip
Bump to 2.4-rc4
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.4_rc4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 189b6eac65b5..5e04d805c787 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.68 2014/09/21 10:21:23 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.69 2014/10/07 18:59:36 swift Exp $
+
+*libsepol-2.4_rc4 (07 Oct 2014)
+
+ 07 Oct 2014; Sven Vermeulen <swift@gentoo.org> +libsepol-2.4_rc4.ebuild:
+ Bump to 2.4-rc4
*libsepol-2.4_rc2 (21 Sep 2014)
diff --git a/sys-libs/libsepol/libsepol-2.4_rc4.ebuild b/sys-libs/libsepol/libsepol-2.4_rc4.ebuild
new file mode 100644
index 000000000000..0aadec3597b0
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.4_rc4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.4_rc4.ebuild,v 1.1 2014/10/07 18:59:36 swift Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs eutils multilib-minimal
+
+MY_P="${P//_/-}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140826/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ epatch_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}