summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-26 00:44:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-26 00:44:05 +0000
commit4d235ca4a67c755087d2573ae5d5c80acf1b0b6b (patch)
tree0e7f0921d47b29c26abe30f7aa7ab05cfe52a031 /sys-libs/libcxx
parentWarn if building on top of libsupc++ since it is not well supported. (diff)
downloadgentoo-2-4d235ca4a67c755087d2573ae5d5c80acf1b0b6b.tar.gz
gentoo-2-4d235ca4a67c755087d2573ae5d5c80acf1b0b6b.tar.bz2
gentoo-2-4d235ca4a67c755087d2573ae5d5c80acf1b0b6b.zip
Die if someone tries to build it with <gcc-4.7. Based on a patch by Yuta SATOH in bug #475294
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog6
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 3558ae891426..fd14c2b14198 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.30 2013/07/26 00:37:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.31 2013/07/26 00:44:05 aballier Exp $
+
+ 26 Jul 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
+ Die if someone tries to build it with <gcc-4.7. Based on a patch by Yuta
+ SATOH in bug #475294
26 Jul 2013; Alexis Ballier <aballier@gentoo.org> libcxx-9999.ebuild:
Warn if building on top of libsupc++ since it is not well supported.
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 38c5fc4bf1ea..c5b1587a8e19 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.22 2013/07/26 00:37:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-9999.ebuild,v 1.23 2013/07/26 00:44:05 aballier Exp $
EAPI=5
@@ -41,6 +41,11 @@ pkg_setup() {
ewarn "libsupc++. Please note that this is not well supported."
ewarn "In particular, static linking will not work."
fi
+ if [[ $(gcc-version) < 4.7 ]] && [[ $(tc-getCXX) != *clang++* ]] ; then
+ eerror "${PN} needs to be built with clang++ or gcc-4.7 or later."
+ eerror "Please use gcc-config to switch to gcc-4.7 or later version."
+ die
+ fi
}
src_prepare() {